Bug 112325 - FILESAVE XLSX Hyperlinks disappear randomly
Summary: FILESAVE XLSX Hyperlinks disappear randomly
Status: RESOLVED DUPLICATE of bug 65136
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, filter:xlsx
Depends on:
Blocks: XLSX-Hyperlink Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2017-09-11 12:58 UTC by cmflatscher
Modified: 2019-04-04 15:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file, save in .xls or .xlsx format and re-open in Calc. Links are missing then (11.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-09-11 12:58 UTC, cmflatscher
Details
Sample file saved as .xlsx by MS Excel 2013 (12.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-12 22:16 UTC, Bartosz
Details
Sample file saved into .xlsx format by LibreOffice 5.4 on Ubuntu (10.06 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-12 22:22 UTC, Bartosz
Details
.ODS file saved from LOO as .xls file, a lot of links are missing (15.00 KB, application/vnd.ms-excel)
2017-09-13 05:06 UTC, cmflatscher
Details
ODS file saved from LOO as .xlsx file, a lot of links are missing (10.08 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-13 05:07 UTC, cmflatscher
Details
Screenshot of the problem (74.84 KB, image/png)
2017-11-03 14:08 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cmflatscher 2017-09-11 12:58:20 UTC
Created attachment 136172 [details]
Sample file, save in .xls or .xlsx format and re-open in Calc. Links are missing then

I created in LibreOffice calc a spreadsheet file that contains a list of web links. When I save the .ODS file in either .XLS or .XLSX format that a number of the Hyper-links are lost.

Please fix.

Thanks!
Comment 1 Bartosz 2017-09-12 22:16:32 UTC
Created attachment 136212 [details]
Sample file saved as .xlsx by MS Excel 2013
Comment 2 Bartosz 2017-09-12 22:22:18 UTC
Created attachment 136214 [details]
Sample file saved into .xlsx format by LibreOffice 5.4 on Ubuntu

Unfortunately I cannot reproduce this issue on my machine.
Could you please point in attached .xlsx after export, what is current result and what is expected?

It will be much easier for me to understand and fix this problem.
Comment 3 cmflatscher 2017-09-13 05:06:46 UTC
Created attachment 136216 [details]
.ODS file saved from LOO as .xls file, a lot of links are missing
Comment 4 cmflatscher 2017-09-13 05:07:35 UTC
Created attachment 136217 [details]
ODS file saved from LOO as .xlsx file, a lot of links are missing

All files created in Windows 7 Pro, 64-bit
Comment 5 cmflatscher 2017-09-13 05:09:00 UTC
Hi Bartosz,

Thank you for looking into this problem.

Please find attached the .xls and .xlsx files that I created with LOO in Windows 7 Pro, 64 bit.

I am using a 32 bit version of LOO.

Open up the MS files in LOO and you can see the problem.

Thanks!

--Christian
Comment 6 cmflatscher 2017-09-25 05:37:53 UTC Comment hidden (no-value)
Comment 7 cmflatscher 2017-10-06 06:29:36 UTC Comment hidden (no-value)
Comment 8 Buovjaga 2017-11-03 14:08:37 UTC
Created attachment 137504 [details]
Screenshot of the problem

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: 64024d7c18bd114eb9958cf80eea9129e09923bd
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 3rd 2017

Problem already in

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 9 Gabor Kelemen 2019-03-14 12:03:49 UTC
Part of this problem is that LO allows multiple links in a cell, but Excel does not and our export behavior follows that.
Comment 10 cmflatscher 2019-03-14 15:25:59 UTC Comment hidden (obsolete)
Comment 11 cmflatscher 2019-03-14 15:26:20 UTC Comment hidden (obsolete)
Comment 12 Gabor Kelemen 2019-04-04 15:18:08 UTC

*** This bug has been marked as a duplicate of bug 65136 ***