Bug 112411 - Merge toolbar "More Forms" with "Form Controls"
Summary: Merge toolbar "More Forms" with "Form Controls"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0 target:6.4.0
Keywords: difficultyBeginner, easyHack, skillCpp, skillUI, topicCleanup, topicUI
Depends on:
Blocks: Toolbars Form-Controls
  Show dependency treegraph
 
Reported: 2017-09-15 15:38 UTC by Samuel Mehrbrodt (CIB)
Modified: 2019-08-28 11:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2017-09-15 15:38:58 UTC
* Create a new XML Form Document
* Show the toolbar "Form Controls"

There is a toolbar button "More controls" which shows another toolbar with 6 controls.
I see no reason why those are in an extra toolbar. We should merge those 6 buttons back in the "Form Controls" toolbar.
Comment 1 Dieter Praas 2017-09-17 13:31:56 UTC
In LO 5.3.6.1 I only can see one toolbar with 13 buttons.
Comment 2 Buovjaga 2017-10-28 15:13:40 UTC
Yes.
Comment 3 Yousuf Philips (jay) (retired) 2017-10-28 17:45:00 UTC
Thought of the same issue as well when i was changing around the buttons in these two toolbars. Also the toolbar has a button for 'Form Design' which opens the Form Design toolbar, so it would be great if we could merge all three toolbars into one.
Comment 4 Samuel Mehrbrodt (CIB) 2019-03-08 07:45:46 UTC
The "Form Controls" toolbar is defined in sw/uiconfig/swform/toolbar/formcontrols.xml and the "More controls" toolbar is defined in sw/uiconfig/swform/toolbar/moreformcontrols.xml.

The items from moreformcontrols should be placed in formcontrols and the code to show the "More controls" toolbar should be removed.

The suggestion from Jay in comment 3 can be handled in a different ticket.
Comment 5 Roman Kuznetsov 2019-03-12 08:43:16 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #4)
> The "Form Controls" toolbar is defined in
> sw/uiconfig/swform/toolbar/formcontrols.xml and the "More controls" toolbar
> is defined in sw/uiconfig/swform/toolbar/moreformcontrols.xml.
> 
> The items from moreformcontrols should be placed in formcontrols and the
> code to show the "More controls" toolbar should be removed.
> 
> The suggestion from Jay in comment 3 can be handled in a different ticket.

1. There are formcontrols.xml and moreformcontrols.xml for Writer, Calc, Draw, Impress, sweb, sglobal, swform, swreport, swxform. May be need to change it all into one toolbar for every module?
2. Don't need merge Form Controls and Form Design because: 
    2.1 it have different actions, first for create of controls second for handle of controls on page
    2.2 it will be very large toolbar
Comment 6 Samuel Mehrbrodt (CIB) 2019-03-12 09:05:36 UTC
(In reply to Roman Kuznetsov from comment #5)
> 1. There are formcontrols.xml and moreformcontrols.xml for Writer, Calc,
> Draw, Impress, sweb, sglobal, swform, swreport, swxform. May be need to
> change it all into one toolbar for every module?

Yes.

> 2. Don't need merge Form Controls and Form Design because: 
>     2.1 it have different actions, first for create of controls second for
> handle of controls on page
>     2.2 it will be very large toolbar

Ok, then we leave that as it is.
Comment 7 Commit Notification 2019-03-13 11:08:32 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e89eba0e1fa56c64e0d572b4f32ce5951378c1d7%5E%21

tdf#112411 Merge "Form controls" and "More controls" into one toolbar

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-03-14 07:52:59 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/00f96e88a7c6feea98d446e82a2718c5aae6256c%5E%21

tdf#112411 Remove all that remains of the More controls toolbars

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-11 12:25:14 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/7eab913ccdb60bfaa2e1fd46b940957773b17825%5E%21

tdf#112411 (related) No more More Controls toolbar
Comment 10 stragu 2019-06-17 05:33:25 UTC
issue related to this fix: there are now two missing buttons in the default layout -> https://bugs.documentfoundation.org/show_bug.cgi?id=125947
Comment 11 Roman Kuznetsov 2019-06-17 05:38:52 UTC
(In reply to stragu from comment #10)
> issue related to this fix: there are now two missing buttons in the default
> layout -> https://bugs.documentfoundation.org/show_bug.cgi?id=125947

I'll fix it
Comment 12 Alex Thurgood 2019-07-30 08:26:12 UTC
Am hoping that these changes aren't the cause for 


https://bugs.documentfoundation.org/show_bug.cgi?id=126611
Comment 13 Dieter Praas 2019-08-28 11:15:30 UTC
(In reply to Commit Notification from comment #9)
> Gabor Kelemen committed a patch related to this issue.
> It has been pushed to "master":

> tdf#112411 (related) No more More Controls toolbar

I can verify it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded