Bug Hunting Session
Bug 126611 - XML Form Document: instance Data Navigator isn't shown in toolbar
Summary: XML Form Document: instance Data Navigator isn't shown in toolbar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.1 target:6.2....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-07-30 07:49 UTC by Robert Großkopf
Modified: 2019-08-08 19:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows where the data-navigator has been up to LO 6.1.* (97.61 KB, image/png)
2019-07-30 07:49 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-07-30 07:49:28 UTC
Created attachment 153050 [details]
Shows where the data-navigator has been up to LO 6.1.*

See the attachment: Screenshot where to find the Data Navigator up to LO 6.1.*
If opening an xml-form like https://bugs.documentfoundation.org/attachment.cgi?id=143785 you could show the definition of the xml-form when pressing on the button for the Data Navigator.

Since LO 6.2.0.3 the whole toolbar has been changed. No data-navigator is there when opening an xml-form. You have to add the navigator manually to a toolbar to see the data-navigator.

Expected behaviour: The button for switchin data-navigator on and off must appear every time you open a xml-form.

All tested with LO 6.2.0.3 and LO 6.3.0.2 on OpenSUSE 15 64bit rpm Linux.
Comment 1 Alex Thurgood 2019-07-30 08:02:57 UTC
Confirming with 

Version: 6.4.0.0.alpha0+
Build ID: 7618815f7080acc67a8d1cda1a6fc49797ded364
CPU threads: 4; OS: Mac OS X 10.14.5; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Alex Thurgood 2019-07-30 08:06:37 UTC
Correct display and access to this functionality in 

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
Threads CPU : 4; OS : Mac OS X 10.14.5; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 3 Alex Thurgood 2019-07-30 08:19:24 UTC
@Roman : seeing your recent work on form toolbars, any thoughts on this ?
Comment 4 Xisco Faulí 2019-07-30 09:02:11 UTC
The toolbar changed in

https://cgit.freedesktop.org/libreoffice/core/commit/?id=45b6f096e7ae86d0692ecdfd5b7069622d8a6efa

author	andreas kainz <kainz.a@gmail.com>	2018-10-28 17:02:34 +0100
committer	andreas_kainz <kainz.a@gmail.com>	2018-10-28 18:00:40 +0100
commit	45b6f096e7ae86d0692ecdfd5b7069622d8a6efa (patch)
tree	84c75cf81eda2644cbc90568bd793fb16e668925
parent	d7413085daa452b6315893e311d4249f23d0097f (diff)
sw toolbars sync context toolbars between different apps

Bisected with: bibisect-linux64-6.2

Adding Cc: to andreas kainz

I don't think it's a high severity bug, it's just a missing icon in the toolbar
Comment 5 Xisco Faulí 2019-07-30 09:04:50 UTC
it can be fixed by adding '<toolbar:toolbaritem xlink:href=".uno:ShowDataNavigator"/>' back, however, I don't know if it would be sync among apps
Comment 6 Alex Thurgood 2019-07-30 10:08:26 UTC
Notice also that in the toolbar that is currently displayed, the AddField button appears to call the DB AddField function which is supposed to populate a list of fields in the dialog from an underlying or linked DB table. Clearly, this appears to be irrelevant here, since when using XMLForms, the data instance configurator allows the user to set the fields and bound data that appears on the form, i.e. there is another necessary difference between the corresponding toolbars.

@Robert: can you confirm that the AddField button in this particular context is redundant ?
Comment 7 Alex Thurgood 2019-07-30 10:09:58 UTC
and therein lies the danger of attempting to harmonize the UI to a one-size-fits-all approach... ;-)
Comment 8 Alex Thurgood 2019-07-30 10:14:45 UTC
Note that the AddField button, which is only activated in form design mode, was already present in the toolbar in 6.1.x, and was already useless in that version. I haven't checked, but quite possibly this particular UI quirk was inherited from OOo.
Comment 9 andreas_k 2019-07-30 10:28:19 UTC
Thanks for the bug report.

I will add .uno:ShowDataNavigator to formdesign.xml for swxform, cause in swform .uno:ShowDataNavigator isn't available.

should I hide .uno:AddField by default for swxforms?
Comment 10 Alex Thurgood 2019-07-30 10:42:51 UTC
(In reply to andreas_k from comment #9)
> Thanks for the bug report.
> 
> I will add .uno:ShowDataNavigator to formdesign.xml for swxform, cause in
> swform .uno:ShowDataNavigator isn't available.
> 
> should I hide .uno:AddField by default for swxforms?

@Andreas, thanks !

As to hiding .uno:AddField, IMO yes, but can you wait for Robert to comment back on my question ? He knows this area better than I do.
Comment 11 Robert Großkopf 2019-07-30 14:05:03 UTC
(In reply to andreas_k from comment #9)
> Thanks for the bug report.
> 
> I will add .uno:ShowDataNavigator to formdesign.xml for swxform, cause in
> swform .uno:ShowDataNavigator isn't available.
> 
> should I hide .uno:AddField by default for swxforms?

Yes, AddField works only with connection to a database. The dialogue is complete empty in a xml-form.
Comment 12 Commit Notification 2019-07-30 14:07:17 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6fee2e7ec0b563d164e1d2317d6ec41bee0dac31%5E%21

tdf#126611 ShowDataNavigator in swxform

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 andreas_k 2019-07-30 21:04:02 UTC
thanks for reporting the bug. Form feedback is rare and always welcome.
Comment 14 Alex Thurgood 2019-07-31 11:21:09 UTC
Verified fixed in 

Version: 6.4.0.0.alpha0+
Build ID: 4fe32e65cc56cec959af811a9a99348e764e4966
CPU threads: 4; OS: Mac OS X 10.14.5; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Can we have a back port to 6.3 and 6.2 please ?
Comment 15 Commit Notification 2019-07-31 11:30:48 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/84448af004d69df72897f92076e82d854fa154cc%5E%21

tdf#126611 ShowDataNavigator in swxform

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-08-01 10:53:20 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/df8c2759668586bd501eb0766e3cdbcc4ceb3997%5E%21

tdf#126611 ShowDataNavigator in swxform

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-08-08 19:31:03 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-6":

https://git.libreoffice.org/core/+/3a5e09e6bb7f88ee32ac371560cf92d3254cbba1%5E%21

tdf#126611 ShowDataNavigator in swxform

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.