Bug Hunting Session
Bug 112492 - font rendering got worse looking in 5.3.2.2 (for Default rendering, OpenGL not affected)
Summary: font rendering got worse looking in 5.3.2.2 (for Default rendering, OpenGL no...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 106990 107121 107235 107382 109086 113118 (view as bug list)
Depends on:
Blocks: Font-Rendering DirectWrite DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-09-19 11:32 UTC by Xisco Faulí
Modified: 2018-02-14 14:42 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Detailed comparison of 5.4.1.2 and 5.3.1.2 (382.94 KB, application/zip)
2017-09-19 11:32 UTC, Xisco Faulí
Details
Font LO 5.3.7.0 vs AOO (9.24 KB, image/png)
2017-10-05 17:11 UTC, JeffD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-09-19 11:32:27 UTC
Created attachment 136365 [details]
Detailed comparison of 5.4.1.2 and 5.3.1.2

This is a follow-up bug of bug 106990 as this has grown so much it's impossible to follow.

Commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5a3e82e99e7a60ec65c339dd0463af5c680cead might has improved the issue to some users but not to all.

On the other hand, the issue in Impress slide rendered with GPU "Use hardware acceleration" is open as bug 107090

Text from https://bugs.documentfoundation.org/show_bug.cgi?id=106990#c90:

Ok, here is a more detailed comparison with options separately enabled/disabled. Caution: The screenshots incorrectly say "5.4.2.1", but "5.4.1.2" is correct!
The results are as follows:

LibreOffice 5.4.1.2 (current release)
a) OpenGL off:
- Rendering is ugly and blurry (both UI and in-document)
- "Hardware acceleration" on/off has no effect
- "Anti-aliasing" on/off has no effect
b) OpenGL on:
- Rendering is slightly different (but still ugly and blurry)
- Horizontal ruler: Different rendering of vertical lines
- "Hardware acceleration" is disabled
- "Anti-aliasing" on/off has no effect

LibreOffice 5.3.1.2 (last known good)
a) OpenGL off:
- Rendering is crispy and sharp (both UI and in-document)
- "Hardware acceleration" on/off has no effect
- "Anti-aliasing" on/off has no effect
b) OpenGL on:
- Rendering is ugly and blurry as in 5.4.1.2 (no extra screenshots)

So the only way to get sharp rendering is to (1) use LO before 5.3.2 and (2) disable OpenGL (which has always been ugly and blurry, as already said in my previous comments).

However, I couldn't observe any specific differences caused by hardware acceleration, anti-aliasing, or between UI and in-document content.
Comment 1 Xisco Faulí 2017-09-19 11:44:01 UTC
*** Bug 106990 has been marked as a duplicate of this bug. ***
Comment 2 Andy 2017-09-19 13:18:40 UTC Comment hidden (no-value)
Comment 3 V Stuart Foote 2017-10-03 18:04:02 UTC
The patch [1] just applied against a 5.3.7 release-- tdf#112486 Do not force GDI in no OpenGL, restores rendering quality. TDF TinderBox 62 builds available for testing both 32-bit and 64-bit build with the patch [2].

=-Testing-=
Windows 10 Ent 64-bit en-US with
Version: 5.3.7.0.0+ (x64)
Build ID: 149f28e9a5d66db18ffb36547b2ba394c303fc4d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-3, Time: 2017-09-30_08:04:07
Locale: en-US (en_US); Calc: CL

=-ref-=
[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=5440837e02dee8bc884e02be697bfd4def621d26&h=libreoffice-5-3

[2] http://dev-builds.libreoffice.org/daily/libreoffice-5-3/
Comment 5 JeffD 2017-10-05 17:11:37 UTC
Created attachment 136785 [details]
Font LO 5.3.7.0 vs AOO

Font rendering is much improved in the 5.3.7 Development Version.  Thanks for the work!

It may seem nitpicky, but there are still slight differences in rendering that bother me slightly.  In the attachment you can see differences in spacing, especially after the letter "v" using certain fonts.

Forgive me if this is covered by another bug, such as maybe Bug 107521(?), it's not clear to me.
Comment 6 pierre-yves samyn 2017-10-07 10:07:52 UTC
Hi

(In reply to V Stuart Foote from comment #3)
> The patch [1] just applied against a 5.3.7 release-- tdf#112486 

Verified on windows 7/64 & Version: 5.3.7.1
Build ID: 376eaac300a303c4ad2193fb7f6a7522caf550b9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR);

Thank you very much :)

Best regards
Pierre-Yves
Comment 7 V Stuart Foote 2017-10-15 18:25:00 UTC
*** Bug 113118 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2017-10-18 11:25:13 UTC
Currently there's no way to enable the DirectWrite from the UI, thus closing as
RESOLVED WORKSFORME
Comment 9 Lenge 2017-10-18 16:24:31 UTC
(In reply to Xisco Faulí from comment #8)
> Currently there's no way to enable the DirectWrite from the UI, thus closing
> as
> RESOLVED WORKSFORME

From what I read here, there is a patch that is only applied in some unofficial development version (5.3.7), but not included in any official release. There's no way to tell if the problem is resolved or not until the patch becomes available in a current official release such as 5.4.3+ or 6.x.

As of now, the bug is reproducibly present in any and all official releases, and no plans have been announced to include it, so its neither "fixed" nor "worksforme" => reopening.

BTW: My experience is the exact opposite of yours: There's no way to DISABLE DirectWrite in the UI, thus the ugly blurry rendering cannot be suppressed by returning to the traditional GDI rendering. Or am I missing something?
Comment 10 Xisco Faulí 2017-10-18 16:30:24 UTC
(In reply to Lenge from comment #9)
> (In reply to Xisco Faulí from comment #8)
> > Currently there's no way to enable the DirectWrite from the UI, thus closing
> > as
> > RESOLVED WORKSFORME
> 
> From what I read here, there is a patch that is only applied in some
> unofficial development version (5.3.7), but not included in any official
> release. There's no way to tell if the problem is resolved or not until the
> patch becomes available in a current official release such as 5.4.3+ or 6.x.
>

Yes, there's a way -> http://dev-builds.libreoffice.org/daily/master/
Comment 11 Andy 2017-10-18 16:53:49 UTC
I can confirm that 5.3.7 does NOT have the bug.
I am looking forward to release 5.4.3 so that i can update to latest version without the problem as is there now in 5.4.2.
Comment 12 Aron Budea 2017-10-18 16:58:15 UTC
(In reply to Lenge from comment #9)
> From what I read here, there is a patch that is only applied in some
> unofficial development version (5.3.7), but not included in any official
> release. There's no way to tell if the problem is resolved or not until the
> patch becomes available in a current official release such as 5.4.3+ or 6.x.

Additionally, 5.3.7.1 is already available as a pre-release version, and 5.4.3.1 binaries should be available in a couple of days as well (both are RC1s, RC2 should follow two weeks later).
Comment 13 V Stuart Foote 2017-10-18 17:07:36 UTC
Folks need to understand that ALL that has happened is that we have backed out use of DirectWrite Direct2D allowing _legacy_ GDI again.

That has been applied at 5.3.7, 5.4.3 and current master/6.0 but this is _not_ fixed.

We are still looking to correct our DriectWrite implementation (or replace it with a FreeType based rendering) and it is _likely_ that we will have another round of regressions as we strive to move the Windows builds away from unsupported Microsoft legacy GDI graphics that complicate code maintenance.
Comment 14 fios 2017-10-18 17:23:59 UTC
I tested on http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Win-x86_64@62-TDF/current/ as well as current master, and the issue is fixed for me.

Thanks for fixing!
Comment 15 Lenge 2017-10-19 01:59:44 UTC
Thanks for the hints and clarifications. No more opposition against closing this one, while I support Stuart's statement that the issue isn't truly fixed.

Reverting to legacy GDI is more of a temporary workaround, but still absolutely necessary until we have an alternative that delivers both comparable quality and speed. (OpenGL has never been an option due to its ugly/blurry rendering quality, and DirectWrite seems to combine both bad quality and inacceptable speed.)

In the meantime I'm eagerly waiting for 5.4.3 to regain GDI quality and speed.
Comment 16 Xisco Faulí 2017-10-27 11:19:14 UTC
*** Bug 107121 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2017-10-27 11:19:21 UTC
*** Bug 107235 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2017-10-27 11:19:25 UTC
*** Bug 109086 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2017-10-27 11:19:29 UTC
*** Bug 107382 has been marked as a duplicate of this bug. ***
Comment 20 fios 2018-02-14 14:42:56 UTC
I have just upgraded to 6.0.1.1 and everything looks fine out of the box. Thanks for finally fixing it/finding a workaround.