Download it now!
Bug 113017 - Font support for Old Hungarian missing, can it be added
Summary: Font support for Old Hungarian missing, can it be added
Status: RESOLVED DUPLICATE of bug 123219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: l10n-hu-Hung-HU 103405
  Show dependency treegraph
 
Reported: 2017-10-09 14:47 UTC by Kovács Viktor
Modified: 2019-02-08 07:22 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Attila-old-hun font (26.75 KB, application/x-font-ttf)
2017-10-09 14:47 UTC, Kovács Viktor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kovács Viktor 2017-10-09 14:47:57 UTC
Created attachment 136873 [details]
Attila-old-hun font

I did not found Old Hungarian conform fonts in the LibreOffice. I have one developed myself. Can I grant and upload this font for The LibreOffice fonts repo?
Comment 1 V Stuart Foote 2017-10-09 23:56:20 UTC
Sure, it is probably needed and blocks bug 10340. But the font as posted has some bad metrics that would need to be cleaned up for line spacing.

Also, think before we'd adopt and bundle the font for our use (likely becoming a standard for Székely-magyar rovás) is any discussion needed of the divergence of this contributed font from that of the current Unicode 10.0 "Old Hungarian" sample code table? [1]

Some general stylistic divergence, but notably the  10c9b, 10c9c, 10c9e, 10c9f and 10ca8 capital glyphs, and their corresponding lower case 10cdb, 10cdc, 10cde, 10cdf and 10ce8. If we were to bundle and deploy it, is it acceptable among the user community? Seems the academic/Rovás community has some issue with the block name of "Old Hungarian". [2]

=-ref-=
http://www.unicode.org/charts/PDF/U10C80.pdf

https://en.wikipedia.org/wiki/Old_Hungarian_(Unicode_block)
Comment 2 Xisco Faulí 2017-10-10 08:51:33 UTC
@Aron, any opinion on this?
Comment 3 Kovács Viktor 2017-10-10 19:10:26 UTC
Previously "Khaled" corrected LibreOfice Writer to accept that this codepage has right-to-left write-direction, must be set bidi language as no language, and it's works. In Xkeyboar database version 2.22 already adopted an easy useable keyboard layout implementation for this codepage. I thought, just the fonts are missing.
Comment 4 V Stuart Foote 2017-10-10 21:05:13 UTC
(In reply to Kovács Viktor from comment #3)
> ... I thought, just
> the fonts are missing.

Right, but you are proposing for LibreOffice to deploy a font that will service this Unicode page to support this script for many users--including supporting the font fallback needs.

I think that is a good idea, but the font will need to be trouble free and well designed before the project would consider to deploy it. As it is, it is not ready.

Clean it up (font metrics and the actual glyphs) get some outside help if you need it. 

@László N. can you lend a hand here?
Comment 5 Kovács Viktor 2017-10-11 02:52:18 UTC
Okay,that's true, it could be have some small rendering problems. I think, the forms of letters are correct. If the community would make a better fonts, do it! If the community tell me, wich points need corrections, I accept It. If the community want make changes inside the font, I agree to reuse well formed glyps from my font, and that case I accept, that my font do not need tho put the font repo!

My question: what was the problem about some capital and small letters?
Comment 6 Kovács Viktor 2018-02-13 18:15:20 UTC
@Stevart
Happened something? I think, did not.
Comment 7 Kovács Viktor 2018-02-13 18:59:06 UTC
I am sorry about my previous mistake!
@V Stuart Foote
Did something happened? Font is accepted? Should I resolve any mistakes?
Comment 8 V Stuart Foote 2018-02-13 23:53:51 UTC
Viktor,

So you know, the project does not develop our own fonts. We tweak some, like OpenSymbol to meet our needs, and we are shifting to favor open source choices where feasible. We bundle some fonts to install with LibreOffice--but that has been for general use. Not sure there is a lot of need to have a font dedicated to this SMP block. It might be better if it were delivered as a LibreOffice Extension.

Back in October I extracting and generating a font set from the Unicode 10.0 "Old Hungarian" (or Szekely-Hungarian Rovas) reference font introduced at Unicode 8.0/ISO IEC 10646:2014 --and it came out pretty good. Unfortunately I did not hear back from either Michael Everson or André Szabolcs Szelp with permission to use their glyph designs drawn from the Unicode SMP pages.

So guess you will need to clean yours up to be--trouble free and well designed--and continue, maybe László or Khaled would be able to advise.

I get the sense from looking at the history of the block at Unicode that there is some residual politics over the final Unicode/ISO approval of the block name and some of the glyphs. But the published Unicode/ISO block is legitimate.

Also, it looks like you probably will need to design some additional glyphs to provide punctuation with the font [1]:

U+0021 EXCLAMATION MARK
U+002D HYPHEN - MINUS
U+002E FULL STOP
U+003A COLON
U+201F DOUBLE HIGH-REVERSED-9 QUOTATION MARK
U+204F REVERSED SEMICOLON
U+2E2E REVERSED QUESTION MARK
U+2E41 REVERSED COMMA
U+2E42 DOUBLE LOW-REVERSED-9 QUOTATION MARK

Seems like a worthwhile project, good luck with it.

Stuart

=-ref-=
[1] http://www.unicode.org/wg2/docs/n4268.pdf
Comment 9 László Németh 2018-02-14 11:31:06 UTC
I believe, the best and suggested solution is to extend DejaVu with Old Hungarian Unicode characters, contributing to https://github.com/dejavu-fonts/dejavu-fonts (see also https://dejavu-fonts.github.io/).

“DejaVu is a project which aims for complete coverage of the alphabetic scripts...” (https://en.wikipedia.org/wiki/DejaVu_fonts), and DejaVu is one of the default fonts of LibreOffice (https://wiki.documentfoundation.org/Fonts). Also font design of “Attila” match well DejaVu.
Comment 10 Kovács Viktor 2018-02-16 17:33:03 UTC
(In reply to László Németh from comment #9)
> I believe, the best and suggested solution is to extend DejaVu with Old
> Hungarian Unicode characters, contributing to
> https://github.com/dejavu-fonts/dejavu-fonts (see also
> https://dejavu-fonts.github.io/).
> 
> “DejaVu is a project which aims for complete coverage of the alphabetic
> scripts...” (https://en.wikipedia.org/wiki/DejaVu_fonts), and DejaVu is one
> of the default fonts of LibreOffice
> (https://wiki.documentfoundation.org/Fonts). Also font design of “Attila”
> match well DejaVu.

Thank you! I think it's a good Idea. :)
Comment 11 Kovács Viktor 2018-07-22 09:45:23 UTC
@:Stuart 
There are two patches in dejavu-fonts, pull requests #23 and #24. Will be adopted to the LibreOffice? Those are open pull requests.
Comment 12 Xisco Faulí 2018-07-23 19:18:29 UTC
This bug was never confirmed by a third person, moving it back to UNCONFIRMED until someone else confirms it.
Comment 13 V Stuart Foote 2018-07-23 19:41:06 UTC
Its always been valid, but OP has instead integrated his font designs into the Unicode Old Hungarian subset of the DejaVu Sans font. 

Pull request [1] posted to the DejaVu fonts project github awaiting further action.

=> MOVED to DejaVu project [2]


=-ref-=
[1] https://github.com/dejavu-fonts/dejavu-fonts/pull/25/commits

[2] https://bugs.freedesktop.org/show_bug.cgi?id=105147
Comment 14 V Stuart Foote 2019-02-08 07:22:14 UTC

*** This bug has been marked as a duplicate of bug 123219 ***