Bug Hunting Session
Bug 123219 - Provide font support of Unicode "Old Hungarian" block (10c80-10cff) and required punctuation and quotation marks.
Summary: Provide font support of Unicode "Old Hungarian" block (10c80-10cff) and requi...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
: 113017 123203 (view as bug list)
Depends on:
Blocks: l10n-hu-Hung-HU 103405
  Show dependency treegraph
 
Reported: 2019-02-07 08:47 UTC by Kovács Viktor
Modified: 2019-02-20 07:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Testpage of the font (74.27 KB, application/pdf)
2019-02-07 08:56 UTC, Kovács Viktor
Details
The downloadable zipped font about this project (63.08 KB, application/zip)
2019-02-07 09:05 UTC, Kovács Viktor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kovács Viktor 2019-02-07 08:47:24 UTC
Description:
Without Old Hungarian fonts or font part I couldn't make the UI for Old Hungarian script (defined in UNICODE) and I couldn't make a hard test with the hunspell for that scripts.

Steps to Reproduce:
1.Accepting an invidual developer's font.
2.
3.

Actual Results:
When I would like typing Old Hungarian text (with settings RTL script named yet "None") just Tofus appear. PO file unable to appear without Tofus

Expected Results:
Must be appear Old Hungarian chars, no Tofus. Must be named this RTL area.


Reproducible: Always


User Profile Reset: No



Additional Info:
The UNICODE block downloadable from:
https://unicode.org/charts/PDF/U10C80.pdf
Comment 1 Kovács Viktor 2019-02-07 08:56:48 UTC
Created attachment 148972 [details]
Testpage of the font
Comment 2 Kovács Viktor 2019-02-07 09:03:22 UTC
(In reply to Kovács Viktor from comment #1)
> Created attachment 148972 [details]
> Testpage of the font

This document is the testpage of https://github.com/kende-fonts/kende-fonts/ project.
The github project's io page is:
https://kende-fonts.github.io/kende-fonts/
 (Unfortunately I couldn't find the other fully UNICODE standard fonts for this area)
Comment 3 Kovács Viktor 2019-02-07 09:05:17 UTC
Created attachment 148974 [details]
The downloadable zipped font about this project
Comment 4 Kovács Viktor 2019-02-07 09:08:34 UTC
cc: László Németh
The bugreport is correct?
If you agree with it, please switch it to NEW status.
Comment 5 Kovács Viktor 2019-02-07 09:29:59 UTC
cc: V Stuart Foote, László Németh
I'm waiting for a long time for the DejaVu's op. Denis. And I think It wouldn't be changed for longer time.
Comment 6 Kovács Viktor 2019-02-07 18:10:53 UTC
cc:All
I now discussed with an Old Hungarian-font specialist. I think, he would be develop better fonts, than me. If his github projectpage is made, (he have more font variant, we will pick of their repository)  I drop a comment about his project.
Comment 7 V Stuart Foote 2019-02-08 07:20:22 UTC
Sorry Viktor, but completing the integration into DejaVu remains the most feasible way for LibreOffice to provide coverage of rovás in the "Old Hungarian" UCS block.

Bundling specialized fonts to support the User Interface for a single Unicode block is not an effective way to do things.

IMHO that specialized effort belongs bundled as an Extension that would include any hu-Hung (SH) rovás transliteration tools (bug 97406 c#28) along with any grammar & dictionary/spelling data. And likewise the same for hu-hung (CB) should that gain usage.

Meaning--for its broader distribution, and its deployment by LibreOffice--DejaVu is a better choice. Your Kende, Maros, and Attila fonts with specialized coverage of the UCS block are not going to be helpful--they would not be built/bundled by any Linux distro, and would likely not be built into the projects official builds. 

Despite its limitations, absent the work needed to implement a User Interface in Hungarian rovás (bug 103405), the CTL handling of the script does detect the UCS block and correctly applies the ICU bidi filters to text runs for the range. It will also assign a "Hungarian Rovas" language tag if that is set as the default CTL.

Also regards a supporting font Tamas needs to clarify the additional glyphs necessary to provide as PUA and where in the 20 remaining reserved spots of the "Old Hungarian" block they could be mapped and manipulated. We understand the argument that Unicode TC may have gotten it wrong during voting to release at UCS version 8.0--but working within the defined block is the only effective way to implement and then to make the case for expansion or relocation of the block.
Comment 8 V Stuart Foote 2019-02-08 07:22:14 UTC
*** Bug 113017 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2019-02-08 07:22:48 UTC
*** Bug 123203 has been marked as a duplicate of this bug. ***
Comment 10 Kovács Viktor 2019-02-09 10:07:42 UTC
cc: V Stuart Foote
This fonts extended by required punctuation and quotation marks, as suggested by 
http://www.unicode.org/wg2/docs/n4268.pdf
document.
These glyphs are:
U+0021 EXCLAMATION MARK
U+002D HYPHEN - MINUS
U+002E FULL STOP
U+003A COLON 
U+201F DOUBLE HIGH-REVERSED-9 QUOTATION MARK 
U+204F REVERSED SEMICOLON 
U+2E2E REVERSED QUESTION MARK 
U+2E41 REVERSED COMMA 
U+2E42 DOUBLE LOW-REVERSED-9 QUOTATION MARK 
And, for backward compatibility with xkeyboards' Old Hungarian layout (that's between the e extras) DOUBLE QUOTATION MARK U+0022.
It also implements a SPACE (U+0020).
Comment 11 Kovács Viktor 2019-02-09 14:16:09 UTC
(In reply to V Stuart Foote from comment #7)
> Sorry Viktor, but completing the integration into DejaVu remains the most
> feasible way for LibreOffice to provide coverage of rovás in the "Old
> Hungarian" UCS block.

I understand.

> Bundling specialized fonts to support the User Interface for a single
> Unicode block is not an effective way to do things.

I understand.

 
> Meaning--for its broader distribution, and its deployment by
> LibreOffice--DejaVu is a better choice. Your Kende, Maros, and Attila fonts
> with specialized coverage of the UCS block are not going to be helpful--they
> would not be built/bundled by any Linux distro, and would likely not be
> built into the projects official builds. 

I understand.
 
> Despite its limitations, absent the work needed to implement a User
> Interface in Hungarian rovás (bug 103405), the CTL handling of the script
> does detect the UCS block and correctly applies the ICU bidi filters to text
> runs for the range. It will also assign a "Hungarian Rovas" language tag if
> that is set as the default CTL.

I understand.

> Also regards a supporting font Tamas needs to clarify the additional glyphs
> necessary to provide as PUA and where in the 20 remaining reserved spots of
> the "Old Hungarian" block they could be mapped and manipulated. We
> understand the argument that Unicode TC may have gotten it wrong during
> voting to release at UCS version 8.0--but working within the defined block
> is the only effective way to implement and then to make the case for
> expansion or relocation of the block.

I disagree with Tamás. I don't understand, what's the problem about "missing" 20 characters. The 108 characters are more, than for texts written in rovás required. Widely less characters are used. (See downloadable e-books from http://mek.oszk.hu page. Look it up in the "title" keyword Rovásírással.)
Comment 12 Kovács Viktor 2019-02-09 14:27:58 UTC
cc:Stuart 
http://mek.oszk.hu is the official homepage of the Hungarian National Library called "Országos Széchenyi Könyvtár" (OSZK.)
Comment 13 Kovács Viktor 2019-02-10 01:00:02 UTC
cc:Stuart
Then, what I need to do? ( to close this bug, or not)