Bug 97406 - i18n: add language “Székely-magyar rovás” Hungarian (Hungarian Rovas) [hu-Hung-HU]
Summary: i18n: add language “Székely-magyar rovás” Hungarian (Hungarian Rovas) [hu-Hun...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
: 95124 (view as bug list)
Depends on:
Blocks: l10n-hu-Hung-HU
  Show dependency treegraph
 
Reported: 2016-01-28 09:18 UTC by Óvári
Modified: 2016-10-22 10:44 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2016-01-28 09:18:25 UTC
Please add “Székely-magyar rovásírás” Language for localisation.

Identifier:     Hung
Name:   Székely-magyar rovásírás
Status:         Active
Code set:       15924
Scope:  Individual
Type:   Living


Thanks
Comment 1 Urmas 2016-01-28 10:30:39 UTC
The correct language code is (apparently) ohu-Hung.
Or did you mean the modern Hungarian in the runic script?
Comment 2 Óvári 2016-01-28 19:56:57 UTC
(In reply to Urmas from comment #1)

The language code was found at the upper right section of the following webpage:
https://hu.wikipedia.org/wiki/Sz%C3%A9kely%E2%80%93magyar_rov%C3%A1s%C3%ADr%C3%A1s

The language is in current use as shown on the following webpages:
http://mezofoldielet.hu/2011/08/21/rovasirasos-helysegnevtablak-mar-dunaujvarosban-is/

https://hu.wikipedia.org/wiki/Magyar_%C3%ADr%C3%A1sok#/media/File:Harkany_city_limit_sign_rovas_script.jpg 

Thank you
Comment 3 Urmas 2016-01-29 15:18:15 UTC
So, why cannot you use 'hu-Hung' language? There is bug #83376, but it is workable around.
Comment 4 Tamas Rumi 2016-08-25 08:11:28 UTC
(In reply to Urmas from comment #1)
> The correct language code is (apparently) ohu-Hung.
> Or did you mean the modern Hungarian in the runic script?

According to ISO 15924 the code for the Szekely-Hungarian Rovas script code is HUNG. On the other hand it is false to say that this script is runic. It is not runic, only runic like without any historical connection to the (German, north European) runes. (N.B: THe official terminology is not correct - Old Hungarian (Hungarian Runic). 
http://www.unicode.org/iso15924/codechanges.html
Comment 5 Tamas Rumi 2016-08-25 08:14:58 UTC
(In reply to Óvári from comment #0)

> Name:   Székely-magyar rovásírás

The name should be in Hungarian: Székely-magyar rovás (shorter form, without duplication, the "írás" means writing)
Comment 6 Óvári 2016-08-25 09:26:18 UTC
erack: Could you please add the “Székely-magyar rovás” living language to LibreOffice 5.3?

Thank you
Comment 7 Urmas 2016-08-26 07:43:29 UTC
*** Bug 95124 has been marked as a duplicate of this bug. ***
Comment 8 Eike Rathke 2016-08-26 09:35:59 UTC
To get things right, we are talking about hu-Hung-HU here, "Old Hungarian (Hungarian Runic)", correct? "Székely-magyar rovás" is up to the translators.
Comment 9 Tamas Rumi 2016-08-26 10:34:46 UTC
(In reply to Eike Rathke from comment #8)

In Hungarian: Székely-magyar rovás
In English: Szekler Hungarian rovas
According to ISO 15925: Old Hungarian (Hungarian Runic) 
There is no reason to use the "Old Hungarian" since it is a living script, not dead. On the other hand, Old Hungarian term refer to latin based historical script used in Hungary (A.D. 896–1526). See History of the Hungarian language. https://en.wikipedia.org/wiki/History_of_the_Hungarian_language

On the other hand, this script can not be connected to the Runes, so it is not correct to say it is Hungarian Runic. The "rovas" is the Hungarian term for so called runic like script.

The best way is to use both in the English description: Old Hungarian (Hungarian Rovas)
Comment 10 Eike Rathke 2016-08-26 10:53:40 UTC
(In reply to Tamas Rumi from comment #9)
> There is no reason to use the "Old Hungarian" since it is a living script,
> not dead.
Old does not imply dead ;-)

> On the other hand, Old Hungarian term refer to latin based
> historical script used in Hungary (A.D. 896–1526). See History of the
> Hungarian language.
That's probably why ISO 15924 called it "Old Hungarian (Hungarian Runic)".

> The best way is to use both in the English description: Old Hungarian
> (Hungarian Rovas)
Normally we name things after standards, but I can do.
Comment 11 Commit Notification 2016-08-26 11:03:04 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a0e60062d90652a3de5739630b152cd6215b6b6c

add Old Hungarian (Hungarian Rovas) [hu-Hung-HU] to language list, tdf#97406

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Tamas Rumi 2016-08-26 11:20:55 UTC
(In reply to Eike Rathke from comment #10)

> > The best way is to use both in the English description: Old Hungarian
> > (Hungarian Rovas)
> Normally we name things after standards, but I can do.
I really appreciate your effort. Thanks for the understanding.
Comment 13 Eike Rathke 2016-08-29 18:11:58 UTC
So, quite certainly this is not about [hu-Hung] but [ohu] instead.
See http://www-01.sil.org/iso639-3/documentation.asp?id=ohu
Comment 14 Eike Rathke 2016-08-29 18:13:32 UTC
Or [ohu-Hung] ?
Comment 15 Rimas Kudelis 2016-08-29 18:32:26 UTC
Tamas: in case you're not sure what Eike's question is about: we're asking if you're going to localize into the "Old Hungarian" language (in which case the language code is "ohu", and locale code is "ohu-Hung-HU"), or contemporary Hungarian simply written in a different script (in which case language code is "hu", and full locale code is "hu-Hung-HU"). "Hung" alone refers only to the writing system, but not to the language.
Comment 16 Eike Rathke 2016-08-29 18:36:35 UTC
Next question would be, is the script type 'Hung' already implied with the language tag 'ohu', i.e. is it the default script, or does it have to be explicitly mentioned as 'ohu-Hung'?
Comment 17 Eike Rathke 2016-08-29 19:10:40 UTC
So this might indeed be [hu-Hung] https://en.wikipedia.org/wiki/Old_Hungarian_alphabet but then the entry in the language list should not read "Old Hungarian (Hungarian Rovas)" but instead "Hungarian Rovas" or similar.
Comment 18 Rimas Kudelis 2016-08-29 19:13:17 UTC
I've tentatively named it "Hungarian (Rovas)" in Pootle.
Comment 19 Michael Bauer 2016-08-29 19:23:32 UTC
To butt in... the proposal is for localization into modern Hungarian but using the Runic (I'll call it that for simplicity) script. So it's like adding a locale for modern German but using Futhark runes as the script medium.

I'm normally very supportive of small or even tiny locales but this one makes me wonder a bit out the use case. At best, this script is used for decorative purposes. I've googled a slack handful of the Unicode characters for this script and there seems to be not one site or article which is written in it, the most hits are for either Wikipedia or the submission to the Unicode Consortium (has useful background reading http://www.evertype.com/standards/iso10646/pdf/oldhungarian-draft-20080821.pdf)

Is this a viable proposal?

Or is the proposal not for localization but to add the locale to LO so (for example) a text could be marked as Hungarian-Runic for the purposes of spellchecking etc?
Comment 20 Eike Rathke 2016-08-29 19:33:27 UTC
According to https://listarchives.libreoffice.org/global/l10n/msg10207.html there are plans to translate (or better transcribe) the UI. Anyway, for document content it's a valid request. I just care about the correct language tag and naming of the language list entry.

While "Hungarian (Rovas)" may work in Pootle, in the language/locale list we place countries in parentheses if two or more countries share the same language. Similar to "Serbian Latin" and "Serbian Cyrillic" this should be "Hungarian Rovas" then.
Comment 21 Tamas Rumi 2016-08-29 19:40:56 UTC
(In reply to Rimas Kudelis from comment #15)
Tha latter one is true: 
> contemporary Hungarian simply written in a different script (in which case
> language code is "hu", and full locale code is "hu-Hung-HU"). "Hung" alone
> refers only to the writing system, but not to the language.
Similiar example: Serbian sr (Cyrillic) / sh (Latin). Same language, different writing scripts.
Comment 22 Tamas Rumi 2016-08-29 19:45:53 UTC
(In reply to Eike Rathke from comment #17)
> So this might indeed be [hu-Hung]
> https://en.wikipedia.org/wiki/Old_Hungarian_alphabet but then the entry in
> the language list should not read "Old Hungarian (Hungarian Rovas)" but
> instead "Hungarian Rovas" or similar.

Exactly. The "Old Hungarian" is confusing, we always say, that there is one language (Hungarian) with two scripts (latin and rovas).
Comment 23 Eike Rathke 2016-08-29 19:49:09 UTC
Actually it's only Pootle that still calls Serbian Latin "sh (Latin)", the correct language tag is sr-Latn ...

Anyway, so hu-Hung was indeed intended and we can close this case again. I'll change the list entry to read "Hungarian Rovas".
Comment 24 Tamas Rumi 2016-08-29 20:09:59 UTC
(In reply to Michael Bauer from comment #19)
> To butt in... the proposal is for localization into modern Hungarian but
> using the Runic (I'll call it that for simplicity) script. So it's like
> adding a locale for modern German but using Futhark runes as the script
> medium.
Yes.
> 
> I'm normally very supportive of small or even tiny locales but this one
> makes me wonder a bit out the use case. At best, this script is used for
> decorative purposes. 
It is not mere decoration.
> I've googled a slack handful of the Unicode characters
> for this script and there seems to be not one site or article which is
> written in it, the most hits are for either Wikipedia or the submission to
> the Unicode Consortium (has useful background reading
> http://www.evertype.com/standards/iso10646/pdf/oldhungarian-draft-20080821.
> pdf)
Long story, the main problem is that the transcription was not possible till now, because the latin script is LTR the Rovas script is RTL. Rendering this on websites is not easy, but see: http://rovas.info/2015/09/a-kis-gomboc/  
> 
> Is this a viable proposal?
> 
> Or is the proposal not for localization but to add the locale to LO so (for example) a text could be marked as Hungarian-Runic for the purposes of
> spellchecking etc?
1. LO locale is a must. With Latin based UI, possibility to write CTL script by selecting Hungarian Rovas.
2. LO UI also is Rovas (further development). It can be technically solved by transcripting from Hungarian latin PO file to Hungarian Rovas PO file.
Comment 25 Commit Notification 2016-08-29 20:21:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5cd5627ae21f68643c07d2f6330aa8b8cbf8659

name it Hungarian Rovas, tdf#97406 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Óvári 2016-08-29 22:06:25 UTC
(In reply to Eike Rathke from comment #23)
> Actually it's only Pootle that still calls Serbian Latin "sh (Latin)", the
> correct language tag is sr-Latn ...
> 
> Anyway, so hu-Hung was indeed intended and we can close this case again.
> I'll change the list entry to read "Hungarian Rovas".

Thank you
Comment 27 Óvári 2016-09-05 09:55:42 UTC
@Tamas Rumi:

1. Will you, or your automated transcribing system, create the spell check dictionaries, thesaurus, hyphenation, grammar check etc. for Hungarian Rovás so it can be added to:
https://wiki.documentfoundation.org/Language_support_of_LibreOffice

2. Will your bulk transcribing system be incorporated in LibreOffice so when there is a Hungarian Latin translation it will automatically be transcribed into Hungarian Rovás and available in LibreOffice?

3. Are you, or someone you know, aware if these need to added as separate enhancement bug reports?

Thank you
Comment 28 Tamas Rumi 2016-09-30 08:43:30 UTC
(In reply to Óvári from comment #27)
> @Tamas Rumi:
> 
> 1. Will you, or your automated transcribing system, create the spell check
> dictionaries, thesaurus, hyphenation, grammar check etc. for Hungarian Rovás
> so it can be added to:
> https://wiki.documentfoundation.org/Language_support_of_LibreOffice

There are two area of use the transcribing system. 

A) Transcription of User Interface. From Hungarian latin PO file we have to generate Hungarian rovas PO file.

Our transcription method provides the transcription from latin based Hungarian text to rovas based Hungarian text. The quality of the transcription is depending on the quality of the source (latin based) text. Spell check dictionaries and thaeasurus do not play role in this case (there should not difference in content). Hyphenation differences occur, since there is no double or triple letters in rovas (for example: SZ, DZS). Grammar check is also unnecessary (the transctiption process provides the rules). 

B) Transcription in the LO document itself. Two case occur:

B1) User tpyes the rovas text directly
B2) User tpyes the latin text and he/she transcribe somehow it into rovas.

In B1 case, we need to cooperate the developers of spell check dictionary (hunspell), we think it is a separate project. The B2 case implies that someone just want use a transcription technology by clicking a button, like translate text to another language. At this moment we need to know the coding system of LO in order to start a development such a LO rovas-extension button. We use our transcription technology separately at this time, more research work is needed. 
 
> 
> 2. Will your bulk transcribing system be incorporated in LibreOffice so when
> there is a Hungarian Latin translation it will automatically be transcribed
> into Hungarian Rovás and available in LibreOffice?

At this moment the easiest solution is to provide a translation file manually, if we get a Hungarian latin PO file (in structured way), we can give back a Hungarian rovas PO file. We can do it quarterly a year (following the schedule of LO releases). To automatize this process in the future we would need to integrate the systems. We would prefer to test it as beta. 

> 
> 3. Are you, or someone you know, aware if these need to added as separate
> enhancement bug reports?

Yes, we would like to provide separate enhancement bug reports, but step by step.

> 
> Thank you
Comment 29 Óvári 2016-09-30 11:19:11 UTC
(In reply to Commit Notification from comment #25)
@Eike Rathke: Can this added language be added to the release notes please?
https://wiki.documentfoundation.org/ReleaseNotes/5.3#Localization
Thank you
Comment 30 Eike Rathke 2016-10-04 16:15:16 UTC
Done.
Comment 31 Óvári 2016-10-04 20:43:14 UTC
(In reply to Eike Rathke from comment #30)
> Done.
Thank you very much.
Comment 32 RovasFoundation 2016-10-22 10:44:12 UTC
Dear All,

Parallel to bug 103405, I suggest a consistent terminology.

1. As the language is Hungarian, it has to be the prior data element, thus the first part of the name.

2. The writing system logically is the second part of the name, similarly to other languages (like Serbian: Serbian (Latin) and Serbian (Cyrillic)).

3. Additional short index can be applied to distinguish between members of the same script family (practically, only in case of Rovas).

* Please note that within the Rovas script family there are distinct scripts (Szekely-Hungarian, Carpathian-basin, Steppean, etc.) The most widely used is the Szekely-Hungarian Rovas that is a contemporary writing system. The Carpathian-basin is a revitalized script with possibly growing user base in the future, Steppean is practically extinct).

Therefore, my suggestion for the terminology in English - similarly for other foreign languages - is:

Hungarian (Rovas-SH)

** While the Latin would be Hungarian (Latin). 

*** The index SH stands for Szekely-Hungarian. Index CB could stand for Carpathian Basin - if needed in the future.


For Hungarian translation, the name should be simpler as the language is obvious:

'Székely-magyar rovás' instead of 'Magyar (székely-magyar rovás)'

Rgds, László