Bug 113093 - The CPU usage for opening the Format Cells dialog after the first time has doubled since 5.3
Summary: The CPU usage for opening the Format Cells dialog after the first time has do...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2017-10-13 10:41 UTC by Telesto
Modified: 2017-11-09 13:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (3.39 KB, text/plain)
2017-10-13 10:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-13 10:41:35 UTC
Description:
The CPU usage for opening the Format Cells dialog after the first time has doubled since 5.3

Steps to Reproduce:
1. Open Calc
2. Open the Format Cell dialog CTRL+1 (the clear out initial loading stuff)
3. Open the Format Cell dialog CTRL+1 again and take notice of the CPU power needed

Actual Results:  
7% for a brief second

Expected Results:
3-4% for a brief second


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-07_01:04:25
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-10-13 10:42:13 UTC
Created attachment 136951 [details]
Bibisect log

Bibisected to:
author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-02 21:52:06 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-03 00:17:06 (GMT)
commit	8f2dd1df1d6cc94ebbc1149de72bc6d6dffa6533 (patch)
tree	db496889434c484a87b13ffcc4650d65e6672129
parent	c8be45889217c555e4bec92af838d0524ceba4e0 (diff)
Revert "Revert "Enable the new text layout engine by default""
This reverts commit 3950166877bf1308f9e449992e20b558342af825.
Comment 2 Xisco Faulí 2017-10-18 11:48:05 UTC
I'm sorry but I do not consider this report an issue. In an ideal world, 3-4% would be too much too. The development resources are really limited in LibreOffice and we need them to focus on real issues. Besides, as demonstrated in other issues, the measurements change depending on the PC
Comment 3 Kevin Suo 2017-11-09 13:27:29 UTC
The cells fomatting dialog takes some time before it appears. Under linux when I run the build on master with dbgutil enabled, I see the following output:

warn:vcl:381:381:vcl/unx/generic/fontmanager/fontconfig.cxx:852: In glyph fallback throwing away the language property of en because the detected script for '0x9f3' is Bengali and that language doesn't make sense. Autodetecting instead.
warn:vcl:381:381:vcl/unx/generic/fontmanager/fontconfig.cxx:852: In glyph fallback throwing away the language property of en because the detected script for '0x9f3' is Bengali and that language doesn't make sense. Autodetecting instead.
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x7e0 with unknown name, so returning lang-tag of: {en-AG}
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x7e1 with unknown name, so returning lang-tag of: {en-NG}
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x7e2 with unknown name, so returning lang-tag of: {en-ZM}
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x7e3 with unknown name, so returning lang-tag of: {en-DK}
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x3c09 with unknown name, so returning lang-tag of: {en-HK}
warn:svtools.misc:381:381:svtools/source/misc/langtab.cxx:222: Language: 0x4809 with unknown name, so returning lang-tag of: {en-SG}

Apparently Calc is trying to detect the fonts to be used for the special chars appears in the language list (and the cell format strings) within the "Numbers" tab.

This is not a big issue anyway, but I am putting the above information on the record just for FYI.