Bug 113138 - FILESAVE general input/output error on save, files truncated when saving to network drive
Summary: FILESAVE general input/output error on save, files truncated when saving to n...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: dataLoss
Depends on:
Blocks: Save UX
  Show dependency treegraph
Reported: 2017-10-15 17:05 UTC by heseltine.michael
Modified: 2023-07-19 14:45 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

Crash log: crash after closing LibreOffice Writer without saving DOCX document after fail to save it due to general input/output error (22.97 KB, text/plain)
2020-07-02 14:34 UTC, opensuse.lietuviu.kalba

Note You need to log in before you can comment on or make changes to this bug.
Description heseltine.michael 2017-10-15 17:05:12 UTC
I fully expect this to be useless, as I cannot give an exact way to reproduce the error but here it goes anyway: 

For several x64 versions, up to (which I'm currently using), Writer and Calc have destroyed my work on several occasion by suddenly saying "general input/output error" to all tries to save the file currently open. When this happens, I can only close the program (losing all changes made till my last backup). The file I tried to save to is truncated to zero bytes, though I can't say whether it was truncated by the save that caused the aforementioned error, or the one before that. 

The error appears without rhyme or reason, but always on file save, and seems to occur quicker and/or more often when I save more often (which I did to lose less work in between saves, to no avail). 

The problem has occured on two different Win10 professional installations on two different computers, with files of vastly different sizes, but always created with one of those LO installations. I have tried several LO versions, but the problem persists. 

If this happens, nothing can be saved (even after restarting LO or the whole machine) until I delete the user profile for LO. After that, I can use the suite again for a few minutes to a few days until the problem reappears. The files however, are gone. All I can do is get the backups and redo the changes.

I'm usually saving the files in question to a newwork drive (SMB share or SFTP drive using ExpandDrive or MountainDuck), but once the error occurs, the file can't be saved to any drive, be it remote or local. 

This seems to be related to a number of bugs reports of both LO and OO going back up to seven(!) years, e.g.


I have stopped using LO for now as I can't afford to lose any more time or files with this.
Comment 1 Buovjaga 2017-11-07 13:21:02 UTC
(In reply to heseltine.michael from comment #0)
> I'm usually saving the files in question to a newwork drive (SMB share or
> SFTP drive using ExpandDrive or MountainDuck), but once the error occurs,
> the file can't be saved to any drive, be it remote or local. 

Has it ever happened when saving to a local drive?
Comment 2 Timur 2017-11-07 17:54:17 UTC
(In reply to heseltine.michael from comment #0)
> This seems to be related to a number of bugs reports of both LO and OO going
> back up to seven(!) years, e.g.
There were different network issues, some of these are Linux, like Bug 99667.
Windows had bug 67534. And some Netware like Bug 81556.
But generally network works. You have to find why it doesn't in you case "(SMB share or SFTP drive using ExpandDrive or MountainDuck)".
Comment 3 Xisco Faulí 2018-01-09 11:18:56 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2018-07-31 09:38:32 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2018-09-03 14:57:19 UTC Comment hidden (obsolete)
Comment 6 Stéphane Aulery 2019-05-13 11:53:59 UTC
From: Stanislav Maslovski <stanislav.maslovski@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: impossible to save file: General input/output error
Date: Sun, 24 Feb 2019 14:51:26 +0000

Package: libreoffice-writer
Version: 1:6.1.5-1
Severity: important


After a recent upgrade from Debian stable to testing I am getting a
very strange error in LibreOffice Writer, when trying to save a
document to the local hard drive. This never happened to me before on
this machine. To reproduce the bug, I just need to continue working on
a file and periodically press the Save button.

The error appears when trying to save the document. When working on
the text, I periodically click the "Save" button (a habbit I have from
the time when computers were big enough to fit a room, and
unreliable enough to destroy your work in a sudden freeze).
Anyway, after a series of succesfull saves, this strange error appears,
after which it is only possible to close the application and accept
the loss of the recently entered data.

I did a search on the internet, and found that some people experienced
the same problem before, notably, when saving to a network drive.
Let me stress, that here this problem appears when saving to the local
HDD. You can check, for example, this bug report:


His simptoms are similar to mine, however, I do not have to erase the
LO profile in order to be able to save files in LibreOffice again.
Just closing and opening the application is enough, however, of
course, the recently entered data are lost anyway. Also, when this
error happens, the file length is not truncated to zero, and the file
still has the content from the last successfull save.

As this problem results in a loss of data, I set the severity of this
bug as important. 


Comment 7 Buovjaga 2019-05-13 12:07:16 UTC
I guess we'll set to NEW, but it would be helpful for Stanislav to be present in this report. Otherwise I don't see this moving anywhere as more information is clearly required.
Comment 8 Stéphane Aulery 2019-05-13 12:14:14 UTC
Indeed, I send a message to him to encourage him to participate in the discussion on this report. If nothing moves, it falls back into limbo.
Comment 9 Timur 2019-05-13 14:37:43 UTC
Stéphane's issue in Debian is unlikely related to Michael's in Windows. 
There are some strange bugs in Debian like Bug 124607.
Comment 10 Xisco Faulí 2019-05-16 13:58:02 UTC
Changing severity back to medium until we hear back from Stanislav
Comment 11 D Schumann 2019-07-21 00:24:34 UTC
I have had the same error several different times over the past month or two. I'm using on Arch Linux.

All saves are to the local hard drive. I suspect (but don't know for sure) that they are related to .docx or .xlsx files. I am taking a course where the instructor requires submissions of assignments in .docx format, so I am saving assignments in .docx format.

I click "Save" and Libreoffice says "General Input/Output Error", and freezes up. I have to kill libreoffice, and then when it starts up again, it goes through the recovery steps, acts as if the document was recovered successfully, but shows the last successfully saved version of a document.

I have lost days worth of work from the error, and I think it should be elevated in status. The most frustration aspect of this error is that once the "General Input/Output Error" pops up, I do not have the option of saving the document to a different format or under a different filename. This is a major failure of the software, in my opinion.

One other thing - when this happens, it's clear that Libreoffice had problems with autosaving the document, but did not warn of the failure. This too is a major failure.

I am going to try working with the documents in native .odt format and seeing if that fixes this problem, but I am hoping that you will elevate the problem and also add better error handling to the autosave and save functionality of Libreoffice.

My issue sounds identical to Stanislav's. Local hard drive. No need to delete profile to start saving again, just kill and restart. Changes lost since last successful save.
Comment 12 Saskia S 2019-08-08 00:25:22 UTC
Similar, but not quite identical situation here: LO on Arch Linux running Linux 5.2.6 kernel; in my case the error was clearly linked to saving a relatively large (340 KiB) .docx file into Dropbox and then attempting to save again (regardless of save destination). Very small files appear unaffected; I tested this by creating a new .docx file, saving to Dropbox, adding more text and saving again (with no error). This seems to implicate Dropbox as doing *something* with the file that causes LO to consider it corrupt/otherwise unsaveable in this case; could it be that in the original filer's case, the network drive management software or in the last two reports, something else running is altering the files whilst LO still has them open?

https://ask.libreoffice.org/en/question/134688/general-inputoutput-error-keeps-destroying-my-work/ This describes a set of similar issues.
https://ask.libreoffice.org/en/question/134688/general-inputoutput-error-keeps-destroying-my-work/?answer=168551#post-id-168551 This comment in particular seems to come to the same conclusions as me with regards to Dropbox.

One very simplistic workaround that seems to work just fine is to copy the entire contents of the affected document into a new file (via creating a new, empty document in LO) and then saving it in a different location. I'm unsure if this helps with the version in which the bug takes place while saving locally, but it might be worth a try.
Comment 13 CRWTOM 2019-08-19 23:05:54 UTC
Same issue here:

Trying to work with LibreOffice (v x64) spreadsheets on 
a remote Apache server that is mounted via SFTP Drive (v 2.0.7131) 
to my Windows 10 (Enterprise v 1809) machine. 

This does not happen when I move the .ods-file to my local 
Desktop and it also does not happen when I work on files on 
the remote server with other software (MS Office, Notepad, etc) 
through the SFTP Drive mount. 

It look like the way LO tries to save files is not compatible
with some types of SSH/SFTP-mounts. This would be a nuisance for
people trying to collaborate via SSH-servers on LO spreadsheets.
Comment 14 aaditya 2020-02-11 12:58:48 UTC
I face the same issue while trying to save to local disk attached via USB.

No workaround works. Tested on Aarch64 with LibreOffice

Exporting as PDF works. Saving odt file does not work.

The directory where the file exists and where I am trying to save it is getting cluttered with files like:


The files size of above files is reported as 0 by the file manager.
Comment 15 opensuse.lietuviu.kalba 2020-07-02 14:34:48 UTC
Created attachment 162597 [details]
Crash log: crash after closing LibreOffice Writer without saving DOCX document after fail to save it due to general input/output error

I can reproduce bug in openSUSE Leap 15.1 Linux, LibreOffice installed from official LibreOffice site TAG.GZ ball with RPMs.

I tried to save document in DOCX or to export into PDF – in both cases it hit general input output error. Most usually I get corrupted lu297483a9*.tmp files in saving directory. If I try save document in /tmp directory with short simple name via "File" > "Save copy" (translation may not be precise as I use non-English version) , sometimes it produces DOCX files, witch seems not corrupted (opens successfully later), however LibreOffice still shows the same general input/output error.

Workaround that worked for me to not to loose your data: save document as ODT instead of DOCX.

I attach a crash log. Crash happened after closing LibreOffice Writer after fail to save DOCX due to general input/output error.

Darinio identifikatorius: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
Procesoriaus gijos: 4; OS:Linux 4.12; Sąsajos pateikimas: GL; VCL: kf5; 
Lokalė: lt-LT (lt_LT.UTF-8); Sąsajos kalba: lt-LT
Calc: threaded
Comment 16 opensuse.lietuviu.kalba 2020-07-02 14:52:49 UTC
...after crash I reopened LibreOffice, it proposed to recover two old files (that was closed long time ago befre crash), however LibreOffice not proposed to recover the one that was not saved (seems due to auto-save error). Indeed, I noticed general input/output error after seeing repeatedly tryings to do autosave for some minute – after waiting, it stopped to try to do autosavings, I closed all simultaneously opened documents except one (i.e. except the problematic one). What I did unusually that could provoke this bug? I did many things, am not sure if these could help to reproduce bug: 
- I renamed DOCX file while editing it in LibreOffice;
- I worked in track-changes mode. Some changes where done in text block that was marked and commented.
- Generally I was replaying in comments at margins – there were a lot of comments.
- I used Zotero plugin enabled with 50 bibliographic entries.
- I replaced existing images
- I worked in multiple files simultaneously that have very similar names, some of them in different directories.
- ...
Comment 17 b. 2020-07-19 08:10:35 UTC
similar problems ... 

win7 SP1 x64, different LO ver. from to, open from and save to network share slow (share on router, accessed local by wifi or remote by shrewsoft vpn client, samba 1.0), save often fails with 'general input/output error', 'insufficient user rights', 'file in use', 'file locked for editing by ...' up to 'contains more columns than supported' (what the fu..?, i'd just before open! that file in that format! with that amount of columns!)

didn't experience the 'all data lost' situation yet, working with calc, not writer, had! quite some crashes as testing against bugs, but recovery produced usable content with low losses as auto-save was on and working, 

one way for reproducible problems (that's why i'm writing here): open a file, disconnect from the share, reconnect, try to save the file, 'locked' or other errors ... 

(that happens quite often when i change location (and thus network) without closing all files but simply 'sleeping' laptop, i assume similar for local network fails or 'switchovers' for any reason) 

assumption: calc is unable to understand/check that/if an existing locking was created by the same client (same instance of calc?) which wants to access after the reconnect, and thus wrongly assumes access and lock conflicting, 

simple cross check with notepad: connected - save - ok - disconnected - save - share not any longer accessible - connected - save - ok, no delays, no questions, no problems, - close and reopen file - ok, no delays, no questions, no problems ... thus there is a special weakness in calc / LO
Comment 18 b. 2020-07-19 12:25:16 UTC
pls. look at and check: 


'local and network access credentials different, calc tried to use the wrong (local) username to access the network share for filesave',
Comment 19 JJ Méric 2021-11-25 10:25:01 UTC
I want to report on the same problem, also on Windows 10, example location:

I am always sending the reports, but after several updates to new version of Libreoffice, I still have the problem : LibreOffice Writer crashes on save.
And it ALWAYS crashes on network drives.

Note : the files are recovered correctly.

But this is a big nuisance since I usually have to work on network drives.

As a workaround, I have to save the file on local hard drive, and then use theFile manager to copy to the network. 

I have never had the problem on a local drive. I cannot report about usb keys (not using in general).

Version (x64)
on Windows 10 Build 19042