Download it now!
Bug 113198 - FILEOPEN: PPTX: Incorrect alignment of text on images
Summary: FILEOPEN: PPTX: Incorrect alignment of text on images
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords: bibisected, bisected, filter:pptx, regression
: 126747 (view as bug list)
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2017-10-17 16:40 UTC by Xisco Faulí
Modified: 2019-12-29 13:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (47.10 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-10-17 16:40 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.0 (92.23 KB, image/png)
2017-10-17 16:42 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-10-17 16:40:32 UTC
Created attachment 137059 [details]
sample document

Steps to reproduce:
1. Open attached document

Observed behaviour: text should have center alignment. it has left alignment instead.

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 616f21db9e50a77b0c02dfb123f871a742f46216
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2017-10-17 16:42:55 UTC
Created attachment 137060 [details]
comparison MSO 2010 and LibreOffice 6.0
Comment 2 Xisco Faulí 2017-10-17 16:44:27 UTC
Regression introduced by:

author	Tamás Zolnai <tamas.zolnai@collabora.com>	2016-12-17 15:11:06 (GMT)
committer	Tamás Zolnai <tamas.zolnai@collabora.com>	2016-12-17 16:39:55 (GMT)
commit	5694b4970e3af096130e172ac6968b10ed587a6f (patch)
tree	4e1285389cbd88c318beda765bf7becc0795a0cf
parent	2beb90a041bc99644330977f13bfaa10a05b9a39 (diff)
tdf#104722: Wrong text alignment when text box is smaller than the text inside
The default TextHorizontalAlignment is block. Setting
paragraph alignment (on UI) works when this text
alignment property is set to block (otherwise has no effect).
In general this works on this way, but the existing
algorithm did not work in those cases when the
text was bigger than the container shape.

Bisected with bibisect-linux-64-5.4

Adding Cc: to Tamás Zolnai
Comment 3 Xisco Faulí 2019-08-08 10:11:25 UTC
*** Bug 126747 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2019-11-28 00:48:05 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/89f0af144c18efafe2573801641689a1432c0cae

tdf#113198 set default shape paragraph alignment..

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-11-28 10:09:28 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 2bf687bebb30defe576ddb20c1c9680979ed3086
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamas, thanks for fixing this issue! Should it be closed as RESOLVED now ?
Comment 6 Commit Notification 2019-11-28 11:08:29 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/af6e4633ca12bc2f08db1e86d77847b7793d5791

tdf#113198 set default shape paragraph alignment..

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-11-28 13:08:12 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/dfacdb99208be964111b8c7bdfa2458b080fba71

tdf#113198 set default shape paragraph alignment..

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.