Download it now!
Bug 129685 - FILEOPEN: PPTX: Incorrect paragraph alignment in shape
Summary: FILEOPEN: PPTX: Incorrect paragraph alignment in shape
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.3 target:6.4.7
Keywords: bibisected, bisected, filter:pptx, regression
: 130182 134289 (view as bug list)
Depends on:
Blocks: PPTX-Shapes
  Show dependency treegraph
 
Reported: 2019-12-29 13:06 UTC by Xisco Faulí
Modified: 2020-10-30 05:09 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.5 Master (84.63 KB, image/png)
2019-12-29 13:06 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-29 13:06:36 UTC
Created attachment 156834 [details]
comparison MSO 2010 and LibreOffice 6.5 Master

Steps to reproduce:
1. Open attachment 98510 [details] from bug 78308

-> Text in first shape is center alignment, it should be aligned to the right. See comparison

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 1abfc8e2f677024ea058e96f3133e503ba89ea02
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-12-29 13:08:03 UTC
[Bug found by office-interoperability-tools]

https://cgit.freedesktop.org/libreoffice/core/commit/?id=89f0af144c18efafe2573801641689a1432c0cae

Regression introduced by:

author	Tamas Bunth <tamas.bunth@collabora.co.uk>	2019-11-19 12:38:56 +0100
committer	Tamás Bunth <btomi96@gmail.com>	2019-11-28 01:47:13 +0100
commit	89f0af144c18efafe2573801641689a1432c0cae (patch)
tree	a321a7120c7faf14bcbecbe3f7158d66e6c64e6b
parent	c2d689790c332ffd2f0d73de6aae53f26f0fbe53 (diff)
tdf#113198 set default shape paragraph alignment..

Bisected with: bibisect-linux64-6.5 

Adding Cc: to Tamas Bunth
Comment 2 Xisco Faulí 2019-12-29 13:09:45 UTC
attachment 129703 [details] from bug 104722 is also affected
Comment 3 Xisco Faulí 2019-12-29 13:20:33 UTC
attachment 98433 [details] from bug 78146 is also affected
Comment 4 Xisco Faulí 2019-12-29 13:21:33 UTC
and attachment 121205 [details] from bug 96391
Comment 5 Xisco Faulí 2019-12-29 13:22:58 UTC
and attachment 104380 [details] from bug 82417
Comment 6 Xisco Faulí 2020-01-24 12:41:11 UTC
Taking...
Comment 7 Xisco Faulí 2020-01-24 14:52:22 UTC
The text gets to the right position when checking the Position & Size dialog of the shape ( right click - Position & Size )
Comment 8 Xisco Faulí 2020-01-24 14:57:10 UTC
in fact, when the file is saved to pptx and open in MSO, it's displayed correctly.
Comment 9 Xisco Faulí 2020-01-24 14:57:57 UTC
Since 89f0af144c18efafe2573801641689a1432c0cae, this https://opengrok.libreoffice.org/xref/core/oox/source/drawingml/textbodypropertiescontext.cxx?r=a7f28581#82 no longer makes sense
Comment 10 Xisco Faulí 2020-01-24 19:35:50 UTC
unassigning, I gave it a try but the problem isn't where I thought it was...
Comment 11 Xisco Faulí 2020-09-14 14:45:40 UTC
Still reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 63317c6b5f3330dcbf977f37a9d01eafbc7451c2
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, any idea if Tamás Bunth is still active in the project ?
Comment 12 Miklos Vajna 2020-09-14 15:35:06 UTC
Unfortunately he's not a Collaboran anymore, that's all I know.
Comment 13 Xisco Faulí 2020-09-15 12:35:43 UTC
(In reply to Miklos Vajna from comment #12)
> Unfortunately he's not a Collaboran anymore, that's all I know.

That's unfortunate. I've found using the office-interoperability-tools that the problem is affecting many documents. Any chance someone from Collabora could take a look at it ?
Comment 14 Commit Notification 2020-09-18 18:12:30 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10bb02efd8afd42e633e370480104e2575546d8e

tdf#129685 PPTX import: fix unexpected centering of shape text

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-09-21 12:58:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/876f1ddab04fc6d655638274fb90dd601bd3039f

tdf#129685 PPTX import: fix unexpected centering of shape text

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2020-09-21 14:18:41 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 121771e37f7e2de41cd5643475861062bf25627b
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 17 Xisco Faulí 2020-09-21 14:51:27 UTC
*** Bug 130182 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2020-09-21 21:51:11 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/55505edc8eca0e4ba30f192e81ff18982b8e2f95

tdf#129685 PPTX import: fix unexpected centering of shape text

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Aron Budea 2020-10-30 05:09:54 UTC
*** Bug 134289 has been marked as a duplicate of this bug. ***