Download it now!
Bug 137023 - FILEOPEN: PPTX: Text is center aligned instead of left
Summary: FILEOPEN: PPTX: Text is center aligned instead of left
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: high major
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.3 target:6.4....
Keywords: bibisected, bisected, regression
: 136999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-25 11:41 UTC by Xisco Faulí
Modified: 2020-10-07 12:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.1 master (348.45 KB, image/png)
2020-09-25 11:41 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-09-25 11:41:48 UTC
Created attachment 165835 [details]
Comparison MSO 2010 and LibreOffice 7.1 master

Steps to reproduce:
1. Open attachment 57581 [details] from bug 46562

-> The title is all slides is center aligned, they should be left aligned. See comparison image

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 4a899a5f8a72ea29a6919316afe3627de9f33e95
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-09-25 11:43:01 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=10bb02efd8afd42e633e370480104e2575546d8e

author	Miklos Vajna <vmiklos@collabora.com>	2020-09-18 17:53:33 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-09-18 20:12:00 +0200
commit	10bb02efd8afd42e633e370480104e2575546d8e (patch)
tree	5e95cb9f12cd64a48b99325938e05e58cdb06bbe
parent	cb15d181b6446003ddc5a13eff9dfb14fc5a8179 (diff)
tdf#129685 PPTX import: fix unexpected centering of shape text

Bisected with: bibisect-linux64-7.1

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2020-09-25 11:45:23 UTC
attachment 62000 [details] from bug 50265 is also affected by this issue. Alignment should be displayed as right and is center
Comment 3 Xisco Faulí 2020-09-25 11:59:08 UTC
Can be easily reproduced with attachment 81513 [details] from bug 66228 where the text in all the shapes is center aligned
Comment 4 Xisco Faulí 2020-09-25 12:18:52 UTC
Also reproduced with sd/qa/unit/data/pptx/tdf119187.pptx. Titles are aligned to the center. Increasing priority since quite some files are affected by this issue according to office-interoperability-tools.

@Miklos, if you need more examples, I can provide more.
Comment 5 NISZ LibreOffice Team 2020-09-28 14:28:46 UTC
Same as our bug #136999 :)
Comment 6 Xisco Faulí 2020-09-29 08:16:54 UTC
*** Bug 136999 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2020-10-06 07:21:41 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dfa1856cdb4c69985ef1e809d33055427b6fbd76

tdf#137023 PPTX import: fix unexpected center alignment of shape text, 2nd try

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-10-06 11:07:31 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: ff5ca4e5fc6a9fb24b0eb6eb629210b024473f67
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 9 Commit Notification 2020-10-06 11:15:22 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/0e5e3434d23fff4e5ae8cd4d3201be3903bcae06

tdf#137023 PPTX import: fix unexpected center alignment of shape text, 2nd try

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-10-06 17:16:54 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/bcfe68c96893c39b07c15efd99cd010d6736f560

tdf#137023 PPTX import: fix unexpected center alignment of shape text, 2nd try

It will be available in 6.4.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-10-07 12:14:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-7":

https://git.libreoffice.org/core/commit/699f46a4ec9fb66fb0db4657e200e0615dc193e2

tdf#137023 PPTX import: fix unexpected center alignment of shape text, 2nd try

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.