Bug 113465 - Language / localization mixed up
Summary: Language / localization mixed up
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2017-10-26 15:50 UTC by jens
Modified: 2017-11-09 16:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jens 2017-10-26 15:50:16 UTC
Description:
I have installed LibreOffice in German, but - using customized install - also added Dutch / Nederlands as additional language.

Throughout different parts of LibreOffice, some menu items or default document titles are now in Dutch / Nederlands instead in German.

Examples:
Opening up Impress:
-> Dialogue for Templates shows "Openen" and "Annuleren" (Nederlands; WRONG here) and the title of the empty document is "Geen titel 1" (which is also Nederlands; WRONG here).
The menus are displayed completely in German (CORRECT), with exceptions regarding closing LibreOffice ("LibreOffice afsluiten" - Nederlands, WRONG) and saving files: "Datei" (File) menu and Burger menu both include the Nederlands "Opslaan" (WRONG) instead of the German "Speichern" entry. The file menu has a few more of those "opslaan" entries (WRONG), while the ribbon menu displays the correct German "Speichern" and "Speichern unter" (CORRECT).

Steps to Reproduce:
1. Install LibreOffice with custom install. Primary language German, additional language Dutch / Nederlands.
2. Start LibreOffice Impress (or Writer, similar behaviour).

Actual Results:  
see "Steps to Reproduce"

Expected Results:
Localization should have been in German, only, unless explicitly selected otherwise.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
As you can see below, the mixed localization also shows in the "About" dialogue:

Version: 5.4.2.2 (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-threads: 4; Besturingssysteem:Windows 6.19; UI-render: standaard; 
Gebietsschema: de-DE (de_DE); Calc: group




User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Buovjaga 2017-11-09 14:17:20 UTC
So German is your operating system language as well?
Comment 2 jens 2017-11-09 14:45:21 UTC
Yes, German is the Windows 10 OS setting, too.

However: A fresh install of the whole system (from scratch to Win 10 Pro Build 1709 = FCU) incl. new install of LibreOffice 5.4.2.2 and new user profiles does not show this bug, anymore. I cannot it reproduce it under these circumstances, anymore. Tested today. :-/

Before, it was a Creators Update release. LibreOffice had been updated multiple times (installing latest version on top of existing version using the installer) and at some point in time started to show that bug in that environment.
Comment 3 Buovjaga 2017-11-09 16:04:34 UTC
All right, then we can close with good conscience.