Bug 103417 - Mixed strings in menus (OS language shown instead of UI language)
Summary: Mixed strings in menus (OS language shown instead of UI language)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
: 108581 (view as bug list)
Depends on:
Blocks: Main-Menu User-Locale
  Show dependency treegraph
 
Reported: 2016-10-22 21:21 UTC by Robert Gonzalez MX
Modified: 2019-05-15 16:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots of menus (119.72 KB, application/vnd.oasis.opendocument.text)
2016-10-22 21:22 UTC, Robert Gonzalez MX
Details
Writer menu in Spanish (37.33 KB, image/png)
2016-10-22 21:51 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2016-10-22 21:21:28 UTC
Description:
Testing Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: es-MX (es_MX); Calc: group in Windows 10 and Window XP SP3

I found some mixed spanish translations in menus, when the user interface is set to english, "Guardar" for "save", "guardar como" for "save as..." and "Guardar copia" for "Save copy as..."


Steps to Reproduce:
0.Set the user interface to english
1.Open any type of new file, like writer
2.Open the File menu
3.See the Save options Save, Save as... and Save copy as... they have the spanish translations.


Actual Results:  
Also in the save icon, the "Save as..." option is also in spanish
Changing the user interface to spanish, some of the options are in english, like open remote file and save remote file.


Expected Results:
The user interface should all be in the language set in the language options


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Robert Gonzalez MX 2016-10-22 21:22:17 UTC
Created attachment 128168 [details]
screenshots of menus
Comment 2 Aron Budea 2016-10-22 21:51:48 UTC
Created attachment 128169 [details]
Writer menu in Spanish

Hm, I don't have the exact same issue, but changing the UI language of my separate-installed 5.3.0.0 alpha1 (x64) / Windows 7 to Spanish shows some menu items in English.

Seems like most of them are the same ones that stayed Spanish when you switched to English UI.
Comment 3 Adolfo Jayme 2016-10-23 09:00:53 UTC Comment hidden (i-misread, no-value)
Comment 4 Aron Budea 2016-10-23 15:55:42 UTC
I don't know how this works in the background, but the original report is about the English translation not being there when UI is changed to English. I assume English (USA) is the basis of all translations, and should always be present.

Additionally, I admit my example was somewhat different, but at first glance it seems related (the menu items involved are almost the same), and I assume basic strings like "Save" wouldn't be changed.

Then again, as I wrote, I don't know how things work there, so if someone can give an explanation for this particular behavior, I'm not going to argue.
Comment 5 Pedro 2017-04-11 21:14:43 UTC
The problem is that LibreOffice is getting the language for these 4 items from the OS language. The same happens in my Windows 10 Portuguese laptop. If I switch to English UI those 4 items remain in Portuguese.
Inversely on a Windows XP English machine, switching LibreOffice to a Portuguese UI will show those 4 items in English.

This is a regression from branch 5.2

May I edit the title of the Bug? This is NOT a Spanish specific problem. It happens on any Windows version (tested on XP, 7 and 10) where the user is changing to a UI language different from the OS language.
Comment 6 kavalec74 2017-06-17 03:24:05 UTC
Confirmed on Windows XP, LO 5.3.3.2 Spanish strings in German UI, also  in German offline-help. I checked now again and it is OK. I mean it the problem is, I installed several offline-helps, probably the  problem is the order of installation of the help files, but I am not sure. I dont get why the menu is now OK. If I remember correctly, I reinstalled the German help-file. My Windows is in Spanish.
Comment 7 Xisco Faulí 2017-06-18 21:19:48 UTC
*** Bug 108581 has been marked as a duplicate of this bug. ***
Comment 8 milupo 2017-08-27 16:44:32 UTC
When will the bug be fixed? Some of the strings - Save, Save as... and Save copy as... are often used. I am translator for Upper Sorbian and Lower Sorbian. There is no operating system in these languages, the most often used OS language is German. So those menuitems are shown in German.

See here as well: https://redmine.documentfoundation.org/issues/2334
Comment 9 QA Administrators 2018-11-11 03:47:02 UTC Comment hidden (obsolete)
Comment 10 milupo 2019-05-15 12:38:36 UTC
Hi,

sorry for the late reply. The bug is already fixed for Sorbian languages for a long time. Thanks.
Comment 11 Aron Budea 2019-05-15 13:12:21 UTC
Good to hear, thanks for the feedback!
Robert, does this still occur for you with a recent release? (6.2.3)
Comment 12 Robert Gonzalez MX 2019-05-15 15:32:23 UTC
Hi. Tested in Versión: 6.2.3.2
Id. de compilación: aecc05fe267cc68dde00352a451aa867b3b546ac
Subprocs. CPU: 8; SO: Linux 4.12; Repres. IU: predet.; VCL: gtk3; 
Configuración regional: es-MX (es_MX.UTF-8); Idioma de IU: es-ES
Calc: threaded

and tested in Versión: 6.2.3.2 (x64)
Id. de compilación: aecc05fe267cc68dde00352a451aa867b3b546ac
Subprocs. CPU: 8; SO: Windows 10.0; Repres. IU: predet.; VCL: win;
Configuración regional: es-MX (es_MX); Idioma de IU: es-ES
Calc: threaded


I've verified all the translations and found that they are OK for Spanish and English, as for the original problem reported.
Comment 13 Pedro 2019-05-15 15:42:04 UTC
Verified fixed also under Win7 Pro x86 using version 6.1.6.3
OS Language en_US, UI Language pt_PT
All menu items show correctly on both languages
Comment 14 Aron Budea 2019-05-15 16:34:44 UTC
Let's use status WORKSFORME, as the fixing change is unknown.