Bug 114306 - fix unexpected page break in row-spanned table
Summary: fix unexpected page break in row-spanned table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: manfred.blume
URL:
Whiteboard: target:6.1.0 target:6.0.0.2 target:6.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-07 11:27 UTC by manfred.blume
Modified: 2018-02-07 09:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal document (16.71 KB, application/vnd.oasis.opendocument.text)
2017-12-07 11:27 UTC, manfred.blume
Details
Unexpected layout (168.57 KB, image/jpeg)
2017-12-07 12:04 UTC, manfred.blume
Details
Expected layout (172.00 KB, image/jpeg)
2017-12-07 12:05 UTC, manfred.blume
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manfred.blume 2017-12-07 11:27:53 UTC
Created attachment 138271 [details]
Minimal document
Comment 1 manfred.blume 2017-12-07 12:04:53 UTC
Created attachment 138274 [details]
Unexpected layout
Comment 2 manfred.blume 2017-12-07 12:05:28 UTC
Created attachment 138275 [details]
Expected layout
Comment 3 manfred.blume 2017-12-07 12:09:46 UTC
Minimal preconditions:

* Long table on at least 2 pages. Column 3 is used to make the table long.
* 2 or more short cells on page 1. At least 1 cell on page 2. E.g column 2 is used for that.
* More than 1 paragraph in one cell with a row span over the whole table in another column e.g. column 1.
Comment 4 Xisco Faulí 2017-12-07 14:07:10 UTC
Reproduced in

- Version: 6.1.0.0.alpha0+
Build ID: 495ac1bc97f3deea8e13cb1a2b9f59d087873c3f
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: group threaded

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e


- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Thorsten Behrens (CIB) 2017-12-21 22:29:01 UTC
Catch is in SwFrame::IsMoveable():

Method is mostly used like:

if (<other conditions> && IsMoveable())
{
    ...
    SwFlowFrame::MoveFwd()
}

or

if (<other conditions> && IsMoveable())
{
    ...
    SwFlowFrame::MoveBwd()
}

If IsMovable() is called before a MoveFwd() the method may return
false if there is no NextCellLeaf. If IsMovable() is called before a
MoveBwd() the method may return false if there is no PrevCellLeaf.
Comment 6 Commit Notification 2017-12-21 23:21:45 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18765b9fa739337d2d891513f6e2fb7c3ce23b50

tdf#114306 fix unexpected page break in row-spanned table

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-12-22 12:42:02 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b4704f84814cecb2e60ab0ab6aa4924968a51e5&h=libreoffice-6-0

tdf#114306 fix unexpected page break in row-spanned table

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-01-26 22:54:33 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4400f4c4e267f8528df3a7d5a09623c888bd10c

tdf#114306 fix crash caused by special document

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-01-27 22:34:44 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26dc825d9fe7fe6a4188fc6ef68bc801fc8db064&h=libreoffice-6-0

tdf#114306 fix crash caused by special document

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-02-06 16:10:34 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d30eefb677b446886f7b5bab6de93d489ba63529

tdf#114306 fix crash caused by special document 2

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-02-07 09:53:04 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f00070deee9ff550d6ee370eae1402af71928265&h=libreoffice-6-0

tdf#114306 fix crash caused by special document 2

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.