Bug 122207 - FILEOPEN DOCX: LO freezes after opening a certain document
Summary: FILEOPEN DOCX: LO freezes after opening a certain document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Opening tdf#114306-regressions
  Show dependency treegraph
 
Reported: 2018-12-19 21:46 UTC by Serkan KURT
Modified: 2019-05-20 08:20 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serkan KURT 2018-12-19 21:46:25 UTC
Description:
When I try to open the file that is contained in the following link, the file opens, then libreoffice freezes. In the meantime, processor usage increases to 50%.

http://ilbap07.meb.gov.tr/meb_iys_dosyalar/2018_10/02095551_TYRKYE.zip

Tested file : "2018-2019  7. Snf Ylk Plan.docx"

System: Debian 9 amd64 KDE

Steps to Reproduce:
1.The error occurs with the process of opening the file.


Actual Results:
LibreOffice freezes.

Expected Results:
Libreoffice's not freezing.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Dieter Praas 2018-12-20 08:34:11 UTC
I confirm this with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded
Comment 2 Telesto 2018-12-20 19:17:54 UTC
No repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 3 raal 2018-12-21 13:14:13 UTC
This seems to have begun at the below commit.
Adding Cc: to Manfred Blume; Could you possibly take a look at this one? Thanks

 dacaa363b4ca5713c4f3536f91071c6008cb49f9 is the first bad commit
commit dacaa363b4ca5713c4f3536f91071c6008cb49f9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Dec 21 15:36:28 2017 -0800

    source sha:18765b9fa739337d2d891513f6e2fb7c3ce23b50

author	Manfred Blume <manfred.blume@cib.de>	2017-12-08 15:01:51 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-12-22 00:20:40 +0100
commit	18765b9fa739337d2d891513f6e2fb7c3ce23b50 (patch)
tree	61acc1c9001d529d0df88affe48310187784cc99
parent	baaf6c12c8e9f785dc91e5d3db8b2f5072d4e3f5 (diff)
tdf#114306 fix unexpected page break in row-spanned table
Comment 4 Michael Stahl (CIB) 2019-03-11 17:19:47 UTC
b7d4418c309c8bc4fd25485dd3a0ea6ad9edf34e "tdf#122892 sw: fix IsPrepWidow() loop in SwTextFrame::CalcFollow()" fixed one loop but then there was another one around tables.

with the btLR layout import in commit 8fdbda18b593e7014e44a0fd590bbf98d83258b7
"sw btlr writing mode: implement DOCX filter" the second loop is gone so it's time to call it fixed i guess.
Comment 5 Xisco Faulí 2019-03-13 11:56:38 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 8aa579830b20072af8d6e149d6b279362fe98b91
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 6.2.3.0.0+
Build ID: 3450311c403af714d3fc0ba14b9f7673c717a6a2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!
Comment 6 Xisco Faulí 2019-05-16 10:17:06 UTC
*** Bug 118991 has been marked as a duplicate of this bug. ***
Comment 7 raroru 2019-05-18 17:08:15 UTC
Hello,

crosspost from 11899 :
are we sure its resolved ?


-----------------
Hello Xisco;

maybe i'm missing something but why resolved ?

in calc: 

i just tried with fresh install of

Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (en_FR.UTF-8); UI-Language: en-US
Calc: threaded

with mac os  mojave 10.14.4 (18E226)
Model Name:	MacBook Pro
  Model Identifier:	MacBookPro13,1
  Processor Name:	Intel Core i5
  Processor Speed:	2 GHz
  Number of Processors:	1
  Total Number of Cores:	2
  L2 Cache (per Core):	256 KB
  L3 Cache:	4 MB
  Memory:	8 GB
  Boot ROM Version:	231.0.0.0.0
  SMC Version (system):	2.36f97

and it still lags !

Only not satisfying solution is to check "open in low resolution"...

I will post in bug 122207 as well.

---------

but maybe i am missing something ?
Comment 8 Xisco Faulí 2019-05-20 08:17:29 UTC
*** Bug 118991 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2019-05-20 08:20:32 UTC
(In reply to raroru from comment #7)
> Hello,
> 
> crosspost from 11899 :
> are we sure its resolved ?
> 
> 
> -----------------
> Hello Xisco;
> 
> maybe i'm missing something but why resolved ?
> 
> in calc: 
> 
> i just tried with fresh install of
> 
> Version: 6.2.3.2
> Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
> CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
> Locale: fr-FR (en_FR.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> with mac os  mojave 10.14.4 (18E226)
> Model Name:	MacBook Pro
>   Model Identifier:	MacBookPro13,1
>   Processor Name:	Intel Core i5
>   Processor Speed:	2 GHz
>   Number of Processors:	1
>   Total Number of Cores:	2
>   L2 Cache (per Core):	256 KB
>   L3 Cache:	4 MB
>   Memory:	8 GB
>   Boot ROM Version:	231.0.0.0.0
>   SMC Version (system):	2.36f97
> 
> and it still lags !
> 
> Only not satisfying solution is to check "open in low resolution"...

Do you mean it works fine if you check "open in low resolution" ?
In that case, that's another problem for sure. This issue is related to a loop handling tables.
Please report it to https://bugs.documentfoundation.org/enter_bug.cgi?product=LibreOffice&format=guided providing the steps to reproduce it and attaching a file is needed