Bug 118104 - Writer freezes after opening a file with 230 pages
Summary: Writer freezes after opening a file with 230 pages
Status: VERIFIED DUPLICATE of bug 122892
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 82143 (view as bug list)
Depends on:
Blocks: File-Opening tdf#114306-regressions
  Show dependency treegraph
 
Reported: 2018-06-11 00:45 UTC by Doug Morrison-Cleary
Modified: 2019-04-11 08:54 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document with many pages but few graphics elements (573.13 KB, application/vnd.oasis.opendocument.text)
2018-06-11 00:49 UTC, Doug Morrison-Cleary
Details
another file affected by the same problem (245.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-12 17:11 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Morrison-Cleary 2018-06-11 00:45:45 UTC
Description:
The file appears to open correctly, the first page is visible and the information in the bar at the bottom is correct. However, the application is completely frozen and attempting to 'x' out of it brings up an OS message that the window is not responding, do I want to terminate it.

A similar 127 page document seems to load without any problems.

Steps to Reproduce:
1.open the particular file in writer
2.
3.

Actual Results:  
application freezes

Expected Results:
document can be edited, all functions of the application are available


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); Calc: group

OpenGL vendor string: X.Org
OpenGL renderer string: AMD KABINI (DRM 2.50.0 / 4.15.0-22-generic, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0-rc5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:



User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.181 Chrome/66.0.3359.181 Safari/537.36
Comment 1 Doug Morrison-Cleary 2018-06-11 00:49:02 UTC
Created attachment 142642 [details]
Writer document with many pages but few graphics elements

This document is the one that causes the freeze. I last opened it in the 5.4 series and edited it successfully. Most of the document is under a Creative Commons licence.
Comment 2 Doug Morrison-Cleary 2018-06-11 05:24:35 UTC
I have confirmed that this file opens properly in 5.4.4.2 (in Windows 10).

I have also saved the file as a new file, as an .ott, as both types of .docx, and as a .doc file--all saved in 5.4.4.2. In all cases but the last, Libreoffice freezes with the first page rendered on the screen. However, in both versions of .docx, the rendering seems to finish before the whole document has been loaded into memory--as an .odt, the file renders as a 230p document with 46 978 words and 288 285 characters--as a .docx it rendered as a 218p document with 822 words and 5001 characters.

The .doc file seems to finish loading but fails to render at all!

I have also tried opening the original .odt file with opengl turned off and in safe mode, and the same thing happens in every case--rendered first page but the application frozen.
Comment 3 Dieter Praas 2018-06-11 08:15:03 UTC
I can open the document without any problems, but if I click inside, LO becomes unresposive

Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (de_DE); Calc: CL


No problem in

Version: 4.4.7.2
Build-ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Gebietsschema: de_DE
Comment 4 MM 2018-06-11 20:04:35 UTC
Looks a bit like bug 118058.
Comment 5 Xisco Faulí 2018-06-12 09:07:31 UTC
Regression introduced by:

author	Manfred Blume <manfred.blume@cib.de>	2017-12-08 15:01:51 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-12-22 00:20:40 +0100
commit	18765b9fa739337d2d891513f6e2fb7c3ce23b50 (patch)
tree	61acc1c9001d529d0df88affe48310187784cc99
parent	baaf6c12c8e9f785dc91e5d3db8b2f5072d4e3f5 (diff)
tdf#114306 fix unexpected page break in row-spanned table
If a para gets moved off to another page, it never gets
moved back. Make IsMoveable() more symmetric, add condition
to MoveBwd to also claim table content back.


Bisected with: bibisect-linux64-6.1

Adding Cc: to Manfred Blume
Comment 6 Xisco Faulí 2018-07-24 16:43:30 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-12-12 17:11:59 UTC
Created attachment 147472 [details]
another file affected by the same problem
Comment 8 Xavier Van Wijmeersch 2018-12-13 20:54:17 UTC
Can open the document and select words or scrolling without any freezing
Double clicking on a image is no problem
But with the .docx file its not responding and i have to kill the process after 3 min

Version: 6.3.0.0.alpha0+
Build ID: 7c35d5f0669f461254668c1854291e1324b37c21
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Xisco Faulí 2019-01-23 23:24:27 UTC
*** Bug 82143 has been marked as a duplicate of this bug. ***
Comment 10 Michael Stahl (CIB) 2019-02-27 12:43:24 UTC
both of these are fixed by https://gerrit.libreoffice.org/#/c/68402/
-> duplicate

*** This bug has been marked as a duplicate of bug 122892 ***
Comment 11 Xisco Faulí 2019-03-14 16:19:43 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: c196d70337f6b755cfc4c34beda05554c6fab114
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded