Bug 119253 - [Writer Table] Freezes/hangs when splits a table with merged cells to 2 pages
Summary: [Writer Table] Freezes/hangs when splits a table with merged cells to 2 pages
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables tdf#114306-regressions
  Show dependency treegraph
 
Reported: 2018-08-13 14:27 UTC by Alexander Polkhovskiy
Modified: 2019-04-17 14:10 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Table split exaple file (11.38 KB, application/vnd.oasis.opendocument.text)
2018-08-13 14:28 UTC, Alexander Polkhovskiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Polkhovskiy 2018-08-13 14:27:41 UTC
Description:
When you add a new line above the table, that has merged cells, and its part goes to the next page, LO hangs (with text) or freezes for some time (without text).

Steps to Reproduce:
1. Open the example file.
2. Place cursor above the table on the first page.
3. Press Enter several times.
4. Enjoy LO hang.
5. Reopen the example file.
2. Place cursor above the table on the second page.
3. Press Enter several times.
4. Enjoy LO freeze for some time.

Actual Results:
Hangs/Freezes

Expected Results:
Split table


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
That only happens when the table has manually set height larger than automatically chosen by the row contents (i.e. manually set height exceeds minimal required height to place the text) AND the table has merged cells. Without merged cells you can see other effect, I guess is has been described in another bug, maybe here:
https://bugs.documentfoundation.org/show_bug.cgi?id=114968

LO 6.1.0.3
ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; Windows 6.3; Render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

Tried to turn off hardware acceleration, OGL and smooth - same result.
Comment 1 Alexander Polkhovskiy 2018-08-13 14:28:28 UTC
Created attachment 144152 [details]
Table split exaple file
Comment 2 Telesto 2018-08-13 15:46:29 UTC
Repro with
Version: 6.2.0.0.alpha0+
Build ID: c0fdcece6b886912618deee9656cb2d169a9b999
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-12_00:35:45
Locale: en-US (nl_NL); Calc: CL

and with
Version: 5.4.1.0.0+
Build ID: f200d5700782ae179fd96b6ad4b0fe8e7edd1616
CPU threads: 4; OS: Windows 6.29; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL

but not with
Version: 5.2.5.0.0+
Build ID: 78223678b7513ffe46804cb08f2dc5bc899b2bab
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 raal 2018-08-31 11:01:53 UTC
This seems to have begun at the below commit.
Adding Cc: to Manfred Blume; Could you possibly take a look at this one? Thanks

dacaa363b4ca5713c4f3536f91071c6008cb49f9 is the first bad commit
commit dacaa363b4ca5713c4f3536f91071c6008cb49f9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Dec 21 15:36:28 2017 -0800

    source sha:18765b9fa739337d2d891513f6e2fb7c3ce23b50

author	Manfred Blume <manfred.blume@cib.de>	2017-12-08 15:01:51 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-12-22 00:20:40 +0100
commit	18765b9fa739337d2d891513f6e2fb7c3ce23b50 (patch)
tree	61acc1c9001d529d0df88affe48310187784cc99
parent	baaf6c12c8e9f785dc91e5d3db8b2f5072d4e3f5 (diff)
tdf#114306 fix unexpected page break in row-spanned table
Comment 4 Commit Notification 2019-03-12 10:18:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/00a86e8be983f7a92723dfe6cf5986974d77644e%5E%21

tdf#119253 sw: fix layout loop with row-span table

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (CIB) 2019-03-12 10:37:15 UTC
fixed on master
Comment 6 Commit Notification 2019-03-12 17:24:40 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ab9d3c535800e972d893ebc6415d0f616a89316b%5E%21

tdf#119253 sw: fix layout loop with row-span table

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-03-13 11:28:01 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 8aa579830b20072af8d6e149d6b279362fe98b91
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this!!
Comment 8 Alexander Polkhovskiy 2019-03-13 11:54:25 UTC
Confirm. Thank you!
Version: 6.3.0.0.alpha0+
Build ID: ce01727e4d6779ea128aa1be09f4af8cad4e1854
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 9 Xisco Faulí 2019-04-17 14:10:49 UTC
*** Bug 124795 has been marked as a duplicate of this bug. ***