Bug 114968 - LibreOffice CPU usage at ~100% after opening specific file [docx]
Summary: LibreOffice CPU usage at ~100% after opening specific file [docx]
Status: RESOLVED DUPLICATE of bug 121720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2018-01-12 06:34 UTC by sunweb
Modified: 2020-11-07 00:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bad file (23.94 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-12 06:35 UTC, sunweb
Details
Bibisect log (2.91 KB, text/plain)
2018-01-14 15:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunweb 2018-01-12 06:34:38 UTC
Description:
When i open this file CPU usage goes up to 100%, then at some point it goes down until you scroll down a few times before CPU usage goes up again. And each time CPU hits 100% it does it for longer period of time.

Steps to Reproduce:
1. Open attached document
2. CPU usage starts to go up to 90-100%
3. wait until CPU usage backs to normal
4. scroll down until you can't because CPU usageis at 100%, notice how the freeze part takes longer this time
5. repeat 3 and 4

Actual Results:  
At some point the freeze may take 2-5 minutes, depending on the machine you're testing with.

Expected Results:
Opens as usual, no slowdowns even on weak old notebooks.


Reproducible: Always


User Profile Reset: No



Additional Info:
If i copy contents(Ctrl+A -> Ctrl+C) of the file to freshly created odt it works fast there.


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 sunweb 2018-01-12 06:35:27 UTC
Created attachment 139055 [details]
bad file
Comment 2 Telesto 2018-01-12 14:18:05 UTC
Repro with
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL

but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 3 Telesto 2018-01-12 14:21:01 UTC
No repro with
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Telesto 2018-01-14 15:12:53 UTC
Created attachment 139090 [details]
Bibisect log

Bisected to:
author	Mike Kaganski <mike.kaganski@collabora.com>	2016-12-08 23:01:03 +0300
committer	Andras Timar <andras.timar@collabora.com>	2016-12-12 20:24:29 +0000
commit 8a800eea613c0f5ad3302136766791dc58880fb3 (patch)
tree ce9572a518b84b42e10d987ff5923bddaa055135
parent 6238f71ddbdc766e733b1c808a4fa7d66f7bde87 (diff)
tdf#104425 sw: split rows w/large min height (fix layout loop)
This solves the problem of rows with too big minimal height causing
layout failure (the table just goes out of page, does not flow to
next page).
Comment 5 Telesto 2018-01-14 15:14:34 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2018-06-05 21:07:38 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-06-05 21:12:12 UTC
Adding Cc: to Mike Kaganski
Comment 8 Telesto 2019-12-27 17:17:28 UTC
Repro
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 9 Telesto 2019-12-27 17:24:25 UTC

*** This bug has been marked as a duplicate of bug 121720 ***