Download it now!
Bug 114705 - Images distorted after export to PDF from Writer with enabled JPG-compression if OpenGL ist active
Summary: Images distorted after export to PDF from Writer with enabled JPG-compression...
Status: RESOLVED DUPLICATE of bug 121615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: VCL-OpenGL PDF-Export
  Show dependency treegraph
 
Reported: 2017-12-26 22:09 UTC by christoph.webmail
Modified: 2019-03-27 11:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Image with OpenGL activated (212.62 KB, image/jpeg)
2017-12-27 18:14 UTC, christoph.webmail
Details
Image with OpenGL deactivated of jpg-compression deactivated (or both) (241.71 KB, image/jpeg)
2017-12-27 18:16 UTC, christoph.webmail
Details
Sample Document which shows the described behaviour (4.63 MB, application/vnd.oasis.opendocument.text)
2017-12-27 18:25 UTC, christoph.webmail
Details
PDF-Output whith jpg-compression and activated OpenGL (1.01 MB, application/pdf)
2017-12-27 18:27 UTC, christoph.webmail
Details
PDF-Output with deactivated jpeg-compression (4.62 MB, application/pdf)
2017-12-27 18:29 UTC, christoph.webmail
Details
Bibisect log (4.18 KB, text/plain)
2017-12-27 19:20 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christoph.webmail 2017-12-26 22:09:11 UTC
Description:
If I export a writer document with embedded images to a pdf, some of them get distorted using the standard-export-settings. If I deactivate the jpg-compression inside the export dialog, the images get not distorted. The same happens if I let the jpg-compression activated but deactivate OpenGL. The bug was adressed in further versions and was announced to be fixed (https://www.bitblokes.de/libreoffice-5-1-rc1-ist-verfuegbar-kuemmert-sich-um-schusterjungen-und-hurenkinder/, " Weiterhin sollen Bilder bei einem PDF-Export nicht mehr verzerrt werden, wenn OpenGL aktiviert ist"), but it seems like it still exists in 5.3.7 and 5.4.4.

Steps to Reproduce:
1. Create a writer document with embedded images
2. Export to pdf with standard settings
3. Export to pdf with deactivated OpenGL or without jpeg-compresion

Actual Results:  
It seems like not all images get distorted, at the moment I don't know why some are and some not. But I seems that bigger images are affected.

Expected Results:
Images should be not distorted


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Telesto 2017-12-27 14:33:14 UTC
A sample document would be really, really nice :-). Especially if some image are affected, and not all of them.. Thanks!
Comment 2 christoph.webmail 2017-12-27 18:14:52 UTC
Created attachment 138687 [details]
Image with OpenGL activated
Comment 3 christoph.webmail 2017-12-27 18:16:07 UTC
Created attachment 138688 [details]
Image with OpenGL deactivated of jpg-compression deactivated (or both)
Comment 4 christoph.webmail 2017-12-27 18:16:59 UTC
Hello,

here are some screenshots, a sample document will follow.

Best regards!
Comment 5 christoph.webmail 2017-12-27 18:25:55 UTC
Created attachment 138689 [details]
Sample Document which shows the described behaviour
Comment 6 christoph.webmail 2017-12-27 18:27:15 UTC
Created attachment 138690 [details]
PDF-Output whith jpg-compression and activated OpenGL
Comment 7 christoph.webmail 2017-12-27 18:29:00 UTC
Created attachment 138691 [details]
PDF-Output with deactivated jpeg-compression

You get the same result with activated jpg-compression and deactivated OpenGl.
Comment 8 christoph.webmail 2017-12-27 18:30:45 UTC
Okay, I hope the attachments can help the reproduce the behaviour. Thanks for helping and best regards!
Comment 9 Telesto 2017-12-27 19:05:25 UTC
Repro with
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL

and with:
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

but not with:
Versie: 5.1.6.2 
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 10 Telesto 2017-12-27 19:20:18 UTC
Created attachment 138695 [details]
Bibisect log

Bisected to:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-11-03 23:05:25 +0100
committer	Michael Meeks <michael.meeks@collabora.com>	2016-11-11 11:06:54 +0000
commit	d05b11e5f590272b0036cf09cf8721c37db33791 (patch)
tree	8da16be50adaf18936699c8e6653324169569156
parent	74eebc7a0768659426911541e16973bdf037c157 (diff)
tdf#103803 change from BGRA to RGBA color arrangement on Windows
BGRA is native color arrangement on Windows however some intel
drivers have problems with large textures if they read from a
BGRA buffer. So with this commit we switch to RGBA color
arrangement. This shouldn't cause much performance differences,
but we need to convert from RGBA to BGRA when printing.

+ fix: wrong GL format for RGBA image buffers
commit: ed42212f53b2e52238346e64dae31a931d6c90a1
Comment 11 Telesto 2017-12-27 19:22:01 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2018-06-05 20:59:34 UTC
Adding Cc: to Tomaž Vajngerl
Comment 13 Luboš Luňák 2019-03-27 11:36:19 UTC

*** This bug has been marked as a duplicate of bug 121615 ***