Download it now!
Bug 114840 - Can't open 128-bit AES encrypted PDF created with Office 2013
Summary: Can't open 128-bit AES encrypted PDF created with Office 2013
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Import-Draw Password-Protected
  Show dependency treegraph
 
Reported: 2018-01-04 22:11 UTC by Aron Budea
Modified: 2019-01-08 10:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample PDF (80.87 KB, application/pdf)
2018-01-04 22:11 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-01-04 22:11:42 UTC
Created attachment 138890 [details]
Sample PDF

The attached PDF was created with Word 2013 by exporting a simple document to PDF.
During export, the option "Encrypt the document with a password" was selected.
Password: 123456

Draw gives the following error upon opening: "Version Incompatibility. Incorrect file version."

Acrobat Reader DC says the file can be opened by "Acrobat 7.0 and later", and encryption level is 128-bit AES.

Observed using LO 6.0.0.1 / Windows 7. LO 3.3.0 asks for password, but claims it's incorrect.
Comment 1 Thomas Lendo 2018-01-05 08:28:02 UTC
I confirm the error message and that the PDF can't be opened.

Version: 6.0.0.1 (x64)
Build-ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard

Version: 5.1.6.2 (x64)
Build-ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU-Threads: 8; BS-Version: Windows 6.19; UI-Render: Standard

LO 3.3.0 asks for password but can't open it as Aron said.

Word 2013 can reopen it with the password.
Comment 2 QA Administrators 2019-01-06 04:20:08 UTC Comment hidden (obsolete)
Comment 3 Timur 2019-01-08 10:18:42 UTC
Repro LO 6.3+