Download it now!
Bug 101270 - Error opening 128-bit RC4 password encrypted PDF
Summary: Error opening 128-bit RC4 password encrypted PDF
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Import-Draw Password-Protected
  Show dependency treegraph
 
Reported: 2016-08-03 14:08 UTC by Francisco A. Galván Báez
Modified: 2019-01-08 10:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of message and version (64.54 KB, image/png)
2016-08-03 14:08 UTC, Francisco A. Galván Báez
Details
Encrypted test file (14.97 KB, application/pdf)
2016-08-04 07:27 UTC, Francisco A. Galván Báez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco A. Galván Báez 2016-08-03 14:08:58 UTC
Created attachment 126546 [details]
Screenshot of message and version

When I try to open a encrypted PDF file appears a message saying "This PDF file is encrypted and can't be opened."
Comment 1 Aron Budea 2016-08-04 00:30:03 UTC
Since there's no sample attached, I tried with an example encrypted PDF from [1] ("PDF Example - Password protection" in particular), got a password entry dialog, but even with correct password "test" supplied, this was displayed instead of the document:
"This PDF file is encrypted and can't be opened."

I can confirm there is an issue, but not sure if it's the exact same issue as reported (there could be different formats, plus there's also bug 70705 that shows this message with certain unencrypted files).
Version used: LibreOffice 5.2.0.4/Windows 7.

Can you attach a sample encrypted PDF with the password? (obviously with no sensitive data, the simpler the better)
Return status of bug report to UNCONFIRMED with your reply.

[1] http://www.novapdf.com/kb/pdf-example-files-created-with-novapdf-138.html
Comment 2 Francisco A. Galván Báez 2016-08-04 07:27:50 UTC
Created attachment 126567 [details]
Encrypted test file

I attached a test PDF file with the same problem. The password to open it is "1234"

regards!
Comment 3 Aron Budea 2016-08-04 12:47:48 UTC
Thank you for the sample.
Issue reproduced, tried with some earlier versions as well, happens with 4.2.0.4, too, and in Linux.
Comment 4 QA Administrators 2017-09-01 11:17:33 UTC Comment hidden (obsolete)
Comment 5 Aron Budea 2018-01-04 21:40:40 UTC
Bug still there in LO 6.0.0.1 / Windows 7.
Comment 6 QA Administrators 2019-01-06 04:19:29 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-01-08 10:17:16 UTC
Opens with LO 6.2 and LO 6.3+