Bug 114962 - FILEOPEN DOCX: First table is covered by second table in text box with "move with text" option
Summary: FILEOPEN DOCX: First table is covered by second table in text box with "move ...
Status: RESOLVED DUPLICATE of bug 104354
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2018-01-11 14:15 UTC by sunweb
Modified: 2020-10-21 14:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problematic file (28.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-12 06:03 UTC, sunweb
Details
How it looks in MS Word 2003 with conversion pack (13.17 KB, application/pdf)
2018-01-13 11:39 UTC, Telesto
Details
Problematic file saved in MSO without "move with text" option in text box (32.50 KB, application/vnd.ms-word.document.12)
2019-03-27 14:08 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunweb 2018-01-11 14:15:35 UTC
Description:
The second table should be lower instead it covers the upper one.

Steps to Reproduce:
1. Open File

Actual Results:  
second table covers the first one

Expected Results:
second table is placed lower


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2018-01-11 17:18:42 UTC Comment hidden (obsolete)
Comment 2 sunweb 2018-01-12 06:03:43 UTC
Created attachment 139054 [details]
Problematic file

I'm so sorry. I was on my way out and forgot to add the file.
Comment 3 Dieter 2018-01-13 08:44:28 UTC Comment hidden (obsolete)
Comment 4 Telesto 2018-01-13 11:39:20 UTC
Created attachment 139076 [details]
How it looks in MS Word 2003 with conversion pack

Repro with:
Version: 6.1.0.0.alpha0+
Build ID: ef22c4a0a99be5d2903fb9e9d09fc852cd791173
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-12_09:16:04
Locale: nl-NL (nl_NL); Calc: CL

two pages & no overlap with:
but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

However, the position of the second table is wrong
Comment 5 Telesto 2018-01-13 11:41:46 UTC Comment hidden (obsolete)
Comment 6 Telesto 2018-01-14 15:47:39 UTC
Repro with
Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: nl-NL (nl_NL)
Comment 7 Aron Budea 2018-01-15 04:58:59 UTC
Bibisected to the commit referenced below, using repo bibisect-50max.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a4dee94afed9ade6ac50237c8d99a6e49d3bebc1
author		László Németh <laszlo.nemeth@collabora.com>	2015-05-13 17:47:36 +0200
committer	László Németh <laszlo.nemeth@collabora.com>	2015-05-13 18:10:45 +0200

tdf#91260: allow textboxes extending beyond the page bottom
Comment 8 QA Administrators 2019-03-08 03:39:58 UTC Comment hidden (obsolete)
Comment 9 Dieter 2019-03-08 06:54:19 UTC
Overlapping in 

Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

But not in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

=> RESOLVED WORKSFORME
Comment 10 Timur 2019-03-27 14:08:16 UTC
Created attachment 150314 [details]
Problematic file saved in MSO without "move with text" option in text box

Here is this problematic file saved in MSO without "move with text" option in text box that contains 2nd table. That DOCX opens OK with 6.1, unlike original DOCX.
Comment 11 Timur 2020-10-21 14:03:43 UTC
Bibisect 6.2.

This commit split tables:

commit d19f01ea1e078c4fa3b9115e0908cfd5a550ba3e
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jul 17 12:11:05 2018 +0200

    source sha:5c6bce38a01b21403a603acd3148cf3bbb4c685f
    prev source sha:8a304fe8b1282efa2d40bdf337728e64b7532a35

author	László Németh <nemeth@numbertext.org>	2018-07-12 17:15:03 +0200
committer	László Németh <nemeth@numbertext.org>	2018-07-17 11:59:07 +0200
commit 5c6bce38a01b21403a603acd3148cf3bbb4c685f (patch)
tree 083a6ca71da0cc6cbd63ccc91a7c5897f7453aea
parent 8a304fe8b1282efa2d40bdf337728e64b7532a35 (diff)
tdf#104354 DOCX import: fix paragraph auto spacing in tables

*** This bug has been marked as a duplicate of bug 104354 ***
Comment 12 Timur 2020-10-21 14:14:11 UTC
attachment 139054 [details] is 2007 DOCX, but even if resaved in MSO, LO 7.1+ opens not correct with larger tables.

There was another commit in 6.2 where tables went from small in 1 page to too large in 2 pages, and it's still so in 7.1+.

commit 59743b3abc1564d814df83eb60a0785f01285608
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Aug 1 21:15:19 2018 +0200

    source sha:58e266ae808dbf3e157b38eb2c8f24774131e0f8
    prev source sha:45f4d02dd0129d20accc62b889d4e36968ee27b0

author	László Németh <nemeth@numbertext.org>	2018-08-01 16:44:00 +0200
committer	László Németh <nemeth@numbertext.org>	2018-08-01 20:58:40 +0200
commit 58e266ae808dbf3e157b38eb2c8f24774131e0f8 (patch)
tree f3ac0a01c34bf3be103179883ce96d2ce0c9c028
parent 45f4d02dd0129d20accc62b889d4e36968ee27b0 (diff)
tdf#118949 don't set zero auto top margin in every first paragraph