Bug 115088 - Pasting multi-line text from external source behaves strangely
Summary: Pasting multi-line text from external source behaves strangely
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.1.0 target:6.0.1 target:5.4.5
Keywords: bibisected, bisected, regression
: 111079 111349 113708 114706 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2018-01-18 12:22 UTC by Tamás Zolnai
Modified: 2018-02-17 18:24 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Document after copy+paste (84.11 KB, image/png)
2018-01-18 12:23 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2018-01-18 12:22:05 UTC
Description:
Pasting multiline text into a line with content does the text insertion on a wrong way in Writer. The original text does not move with the line endings, but reamins in the same paragraph.
See the attached screenshot. The original text was "text" and copied the next two line from a plain text editor (e.g. gedit or kate):
1
1





Steps to Reproduce:
1. Open an empty text document
2. Insert "text" text to the first line of the document
3. Open a new document in a text editor (e.g. gedit) and type 1 <enter> 1
4. Copy the two lines from the external editor (CTRL+C)
5. Paste (CTRL+V) the copied text to the start of the first line in Writer (before he typed "text" word) 

Actual Results:  
Writer show this:
1text
1

Expected Results:
Writer should show this
1
1text


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 Tamás Zolnai 2018-01-18 12:23:00 UTC
Created attachment 139182 [details]
Document after copy+paste
Comment 2 Tamás Zolnai 2018-01-18 12:23:26 UTC
A regression from this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e68b6e349c31ac1376e90218013e1e7612f2b522
Comment 3 Xisco Faulí 2018-01-18 16:43:03 UTC
Dupe of bug 111349 or bug 111079 ?
Comment 4 Thomas Lendo 2018-01-18 21:38:11 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2018-01-19 09:51:51 UTC
Patch in gerrit -> https://gerrit.libreoffice.org/#/c/48124/ Moving to ASSIGNED

@Tamás, Does it fix bug 111349 or bug 111079 as well ?
Comment 6 Tamás Zolnai 2018-01-19 11:48:50 UTC
(In reply to Xisco Faulí from comment #5)
> Patch in gerrit -> https://gerrit.libreoffice.org/#/c/48124/ Moving to
> ASSIGNED
> 
> @Tamás, Does it fix bug 111349 or bug 111079 as well ?

I'll check. Thanks for assigning! I forgot to do it.
Comment 7 Commit Notification 2018-01-19 12:56:07 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=657da4697379274295e9fd32d3abc1334ebd50d2

tdf#115088: Pasting multi-line text from external source behaves strangely

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Tamás Zolnai 2018-01-19 14:16:58 UTC
*** Bug 111079 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2018-01-19 15:14:54 UTC
@Tamás, should it be backported to 6-0-0 and 5-4 as well ?
Comment 10 Commit Notification 2018-01-25 07:35:07 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b4c0621134d24080479b7f11e07cbb2ea3d80769

Test for tdf#115088.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-01-27 20:05:35 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=960c96eabb15577b52f626cb0a3c8932757911b6&h=libreoffice-6-0

tdf#115088: Pasting multi-line text from external source behaves strangely

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-01-27 20:05:44 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90ee98190302de9a5f570b73d48a628ce41190f3&h=libreoffice-5-4

tdf#115088: Pasting multi-line text from external source behaves strangely

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Kevin Suo 2018-02-09 15:28:47 UTC
*** Bug 111349 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Suo 2018-02-09 15:30:45 UTC
*** Bug 113708 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Suo 2018-02-09 15:31:47 UTC
*** Bug 114706 has been marked as a duplicate of this bug. ***
Comment 16 John 2018-02-10 18:22:54 UTC
Just to confirm this is fixed in 6.0.1.1 x86 and x64. Now I can move on from 5.3.
Comment 17 Commit Notification 2018-02-17 17:45:33 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c9b620efc314050246bef9b7ef9c6daeb482ae1

add uitest for bug tdf#115088

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.