Download it now!
Bug 115229 - Save as file filter prevents *.* on Linux with kf5 backend
Summary: Save as file filter prevents *.* on Linux with kf5 backend
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE File-Dialog
  Show dependency treegraph
 
Reported: 2018-01-25 13:45 UTC by ffs
Modified: 2019-11-05 23:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of kf5 save dialog with '*.*' filter (4.11 MB, image/png)
2019-10-28 12:00 UTC, Michael Weghorn
Details
optins missing in filter (15.49 KB, image/png)
2019-11-05 09:04 UTC, ffs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ffs 2018-01-25 13:45:59 UTC
Description:
in the saveas dialogue there is a filter - this should allow <anything> including * and *.* but it only allows filenames recognises by LO as formats it can save in and only one format (eg *.doc but not *.doc *.docx *.odt).

This is bloody annoying unless you only ever use one format and only ever use the official file extensions.

Allow the user to enter their own filter.

Steps to Reproduce:
file:saveas:select the filter

Actual Results:  
can't select custom filter

Expected Results:
should be able to select custom filter and, at the very least, *, *.* and any combination of filters from the list


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]Locale: en-GBModule: TextDocument[Information guessed from browser]OS: Linux (All)OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Regina Henschel 2018-01-25 23:22:10 UTC
If you use the file dialog of LibreOffice, then you can e.g. enter *.svg into the file name field and press the enter key. Then the file list will show all .svg files, independent of the chosen file type filter. The same is true for the native file dialog of Windows.

It seems the native file dialog of your Linux version has a restriction.

I'm no regular Linux user and have only Ubuntu 16 in a virtual box. I get no files listed if the file type is set to "All Formats" although the folder is not empty. A Linux expert should say, whether this is the usual behavior or a bug.
Comment 2 ffs 2018-02-09 20:30:20 UTC
Ha! I tried this and got an entertaining result:

Entering *.* did nothing, entering *.* <return> simply save the file to "*.*"

Same for "*.xxx" or "*.svg" etc.

Anyway changing the filter to a specific name isn't what I want - I want to be able to see multiple file types and to change the filter arbitrarily. If I'm saving as another format I usually want to see the same file in the original format in the list.
Comment 3 Buovjaga 2018-03-03 18:59:59 UTC
Yep, the only file dialog this works with is
SAL_USE_VCLPLUGIN=gen

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 51291f2352976b2f875197de83486a74795e86a3
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 1st 2018
Comment 4 Buovjaga 2018-03-03 19:02:46 UTC
Grmblll... found an older one.

*** This bug has been marked as a duplicate of bug 111201 ***
Comment 5 Buovjaga 2018-03-03 19:03:59 UTC
Argh I misread the other report (regarding Windows). Reverting status.
Comment 6 QA Administrators 2019-03-04 03:53:19 UTC Comment hidden (obsolete)
Comment 7 ffs 2019-03-04 18:42:23 UTC
Still present in 6.0.7.3
Comment 8 Buovjaga 2019-10-28 11:45:57 UTC
Now gtk3 backend has "All Formats", I guess due the dialog now being gtk3-native. Kf5 backend does not have this and inputting *.* does not work.

Arch Linux 64-bit
Version: 6.4.0.0.alpha1+
Build ID: 01d28b0b85f99590c0581e4bbf636bc9281e0571
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 17 October 2019
Comment 9 Michael Weghorn 2019-10-28 12:00:41 UTC
Created attachment 155360 [details]
Screenshot of kf5 save dialog with '*.*' filter

Either I don't fully understand what this bug is about or it works for me, s. attached screenshot where all files are shown with the '*.*' filter in use. This is on KDE Plasma, where the native kf5 QFileDialog is used.

Can you be more explicit what's wrong (e.g. give a step by step description with actual/expected result)?
Comment 10 Buovjaga 2019-10-28 12:02:34 UTC
Oh, indeed, I was typing into the wrong input field!! Thanks.
Comment 11 ffs 2019-11-05 09:04:54 UTC
Created attachment 155518 [details]
optins missing in filter

optins missing in filter
Comment 12 ffs 2019-11-05 09:07:36 UTC
My filter dropdown is different from yours - it cannot be edited - hence the problem.
Comment 13 Buovjaga 2019-11-05 10:08:50 UTC
(In reply to ffs from comment #12)
> My filter dropdown is different from yours - it cannot be edited - hence the
> problem.

Yeah. So update to 6.3. No patches to versions older than 6.3 will be coming anyway.
Comment 14 ffs 2019-11-05 23:37:55 UTC
ok - thanks - will wait for this to filter down to me...