Download it now!
Bug 115238 - Menu items are shown to the top of the menu boundary (covers the menu thus makes the menu invisible)
Summary: Menu items are shown to the top of the menu boundary (covers the menu thus ma...
Status: RESOLVED DUPLICATE of bug 113713
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2018-01-26 06:21 UTC by Kevin Suo
Modified: 2018-01-26 11:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
libreoffice UI (bad) (137.92 KB, image/png)
2018-01-26 06:27 UTC, Kevin Suo
Details
Firefox UI (good) (664.38 KB, image/png)
2018-01-26 06:28 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2018-01-26 06:21:17 UTC
When you move/hover/navigate around the menus, if the number of items within this menu is big thus the menu items can not fit the screen, the menu items displayed will flow up to the menu boundary. These makes the menus covered (shielded) by the menu items shown.

Steps to Reproduce:
1. Put your mouse on the "File" menu.

Current Result:
The "File" menu and the other menus next to it are invisible. If you want to move to another menu, you have to firstly move you mouse cursor to a blank area.

Expected:
The menu items shown should never cover the menus.

Further information:
The behaviour in Firefox is good, menu items are shown below the menu. If there are many menu items so they can not fit to the screen, an up or down triangle button is shown.

Version: 6.1.0.0.alpha0+
Build ID:ff8826d438a9fd080e8e61f8e66b3d3b2c8d752b
CPU 线程:2; 操作系统:Linux 4.14; UI 渲染:默认; VCL: gtk3; 
区域语言:zh-CN (zh_CN.UTF-8); Calc: group threaded

版本:5.4.4.2
Build ID:5.4.4.2-1.fc27
CPU 线程:2; 操作系统:Linux 4.14; UI 渲染:默认; VCL: gtk3; 
区域语言:zh-CN (zh_CN.UTF-8); Calc: group

Fedora 27, Gnome Desktop
Comment 1 Kevin Suo 2018-01-26 06:27:33 UTC
Created attachment 139369 [details]
libreoffice UI (bad)
Comment 2 Kevin Suo 2018-01-26 06:28:02 UTC
Created attachment 139370 [details]
Firefox UI (good)
Comment 3 Maxim Monastirsky 2018-01-26 08:29:20 UTC

*** This bug has been marked as a duplicate of bug 113713 ***