Download it now!
Bug 113713 - Long drop-down menus cover parent toolbar button
Summary: Long drop-down menus cover parent toolbar button
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 108117 114491 115238 120813 120817 125832 (view as bug list)
Depends on:
Blocks: Main-Menu GTK3
  Show dependency treegraph
 
Reported: 2017-11-08 08:19 UTC by siphomateke
Modified: 2019-06-10 17:14 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing long drop-down menu bug. First is expected behaviour. (111.61 KB, image/png)
2017-11-08 08:21 UTC, siphomateke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description siphomateke 2017-11-08 08:19:41 UTC
Description:
Long drop-down menus from the toolbar overlap their parent toolbar button. For example, on a 1366x768 resolution, in Writer, the "Format" menu is rather long and overlaps the parent "Format" button. This happens with drop-down menus that reach the bottom of the screen.

Steps to Reproduce:
1.Open any LibreOffice application
2.Click on a toolbar button that has a long drop-down menu, such as Format, in Writer

Actual Results:  
The drop-down menu covers up the parent toolbar button

Expected Results:
The drop-down menu's top should be lined up with the bottom of the toolbar like shorter drop-down menus are


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

[From Help - About LibreOffice]
Version: 5.4.2.2.0+
Build ID: 40m0(Build:2)
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group

[From neofetch]
OS: Solus x86_64
Kernel: 4.13.11-31.current
Resolution: 1366x768
DE: Budgie
Theme: Arc-Darker [GTK2/3]
Icons: Moka [GTK2/3]
CPU: Intel i5-4210U (4) @ 2.700GHz
GPU: Intel Integrated Graphics
Memory: 7877MiB



User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 siphomateke 2017-11-08 08:21:31 UTC
Created attachment 137615 [details]
Screenshot showing long drop-down menu bug. First is expected behaviour.
Comment 2 tommy27 2017-11-08 10:15:06 UTC
did it work in the previous 5.3.x releases or in ealier 5.4.x versions?
Comment 3 siphomateke 2017-11-08 10:22:35 UTC
(In reply to tommy27 from comment #2)
> did it work in the previous 5.3.x releases or in ealier 5.4.x versions?

I don't know. I have only tried and can only install version 5.4.2.2 on Solus. Installing an older version would require building it myself which I do not have the expertise to do.
Comment 4 Buovjaga 2017-11-13 18:43:24 UTC
(In reply to siphomateke from comment #3)
> (In reply to tommy27 from comment #2)
> > did it work in the previous 5.3.x releases or in ealier 5.4.x versions?
> 
> I don't know. I have only tried and can only install version 5.4.2.2 on
> Solus. Installing an older version would require building it myself which I
> do not have the expertise to do.

You don't have to build them: https://wiki.documentfoundation.org/Installing_in_parallel/Linux

But this might just be GTK3 behaviour that is out of our control.

You can try by launching from the command line:
SAL_USE_VCLPLUGIN=gtk libreoffice

It will launch it with GTK2.
Comment 5 siphomateke 2017-11-15 09:49:48 UTC
(In reply to Buovjaga from comment #4)
> (In reply to siphomateke from comment #3)
> > (In reply to tommy27 from comment #2)
> > > did it work in the previous 5.3.x releases or in ealier 5.4.x versions?
> > 
> > I don't know. I have only tried and can only install version 5.4.2.2 on
> > Solus. Installing an older version would require building it myself which I
> > do not have the expertise to do.
> 
> You don't have to build them:
> https://wiki.documentfoundation.org/Installing_in_parallel/Linux
> 
> But this might just be GTK3 behaviour that is out of our control.
> 
> You can try by launching from the command line:
> SAL_USE_VCLPLUGIN=gtk libreoffice
> 
> It will launch it with GTK2.

Running libreoffice with GTK2 fixed the issue. So I guess this is a GTK3 issue?
Comment 6 Buovjaga 2017-11-30 13:21:44 UTC
I switched the resolution to 1366x768 and I can reproduce this.
I compared it with Firefox (added bookmarks to make the menu long) and it just has the triangles at the top and bottom - the menu does not go over the toolbar.

Arch Linux with GNOME desktop
Version: 5.4.3.2
Build ID: 5.4.3-4
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 7 Caolán McNamara 2017-11-30 14:22:50 UTC
They're native gtk3 menus and menubars, how they behave is out of our control. e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1380402#c2 standalone demo
Comment 8 V Stuart Foote 2017-12-17 12:59:21 UTC
*** Bug 114491 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2018-01-26 08:29:20 UTC
*** Bug 115238 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2018-10-23 12:12:41 UTC
*** Bug 120813 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2018-10-23 12:13:32 UTC
*** Bug 120817 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2018-10-23 12:14:59 UTC
*** Bug 108117 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2019-06-10 16:48:33 UTC
*** Bug 125832 has been marked as a duplicate of this bug. ***
Comment 14 V Stuart Foote 2019-06-10 17:14:05 UTC
Looking at dupe bug 125832, xfce with gtk3 rendering

the menu list extends to application frames with more to show, yet still does not expose a v-scrollbar for the menu.

Is that back on us?