Download it now!
Bug 115361 - Strange keyboard short-cut keys in Start center of non-Latin versions (Japanese, Chinese)
Summary: Strange keyboard short-cut keys in Start center of non-Latin versions (Japane...
Status: RESOLVED DUPLICATE of bug 115052
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86 (IA32) Mac OS X (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 117548 (view as bug list)
Depends on:
Blocks: Shortcuts-Mac
  Show dependency treegraph
 
Reported: 2018-02-01 05:24 UTC by h.horikawa
Modified: 2018-05-31 14:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of the "strange" menu (32.68 KB, image/png)
2018-02-01 05:26 UTC, h.horikawa
Details
Same problem in Chinese. (7.17 MB, image/jpeg)
2018-05-10 13:12 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h.horikawa 2018-02-01 05:24:01 UTC
Description:
procedure: 
1. start LibreOffice
2. close "start center" window
3. click "File" on the menu bar that appera on the top of screen
The menu that appears after clicking the "File" contains strange keyboard short cuts, almost all of which are impossible to type.  
NOTE: this bug appears after installing the Japanese language pack to the LibreOffice


Steps to Reproduce:
1. start LibreOffice
2. close "start center" window
3. click "File" on the menu bar that appera on the top of screen
The menu that appears after clicking the "File" contains strange keyboard short cuts, almost all of which are impossible to type.  
NOTE: this bug appears after installing the Japanese language pack to the LibreOffice

Actual Results:  
The menu that appears after clicking the "File" contains strange keyboard short cuts, almost all of which are impossible to type.  

Expected Results:
The menu that appears after clicking the "File" should show appropriate keyboard short cuts all of which can be typed.  


Reproducible: Always


User Profile Reset: No



Additional Info:
バージョン: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 24; OS:Mac OS X 10.13.3; UI render: default; 
ロケール: ja-JP (ja_JP.UTF-8); Calc: group



User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.119 Safari/537.36
Comment 1 h.horikawa 2018-02-01 05:26:42 UTC
Created attachment 139486 [details]
screen shot of the "strange" menu
Comment 2 eisa01 2018-05-10 12:56:29 UTC
*** Bug 117548 has been marked as a duplicate of this bug. ***
Comment 3 eisa01 2018-05-10 13:01:40 UTC
Confirmed by a duplicate bug report by a Chinese language user.

The start center has "non-latin" short cut keys that are not possible to press/type

Is it correct that other menus outside of the Start center have normal shortcuts?

When was the last version where this worked?

I guess this might be a possible regression, but might be hard to bibisect given the need for a language pack installation
Comment 4 Franklin Weng 2018-05-10 13:11:25 UTC
(In reply to eisa01 from comment #3)
> Confirmed by a duplicate bug report by a Chinese language user.
> 
> The start center has "non-latin" short cut keys that are not possible to
> press/type
> 
> Is it correct that other menus outside of the Start center have normal
> shortcuts?

Right.  It's my friend's Mac and I checked that other components are correct.

> 
> When was the last version where this worked?

No idea.  My friend started using LibreOffice since this version 6.0.3.
Comment 5 Franklin Weng 2018-05-10 13:12:33 UTC
Created attachment 142015 [details]
Same problem in Chinese.
Comment 6 Xisco Faulí 2018-05-30 14:27:06 UTC
@Heiko, since you have been doing some work related to shotcuts, I thought you might interested in this one...
Comment 7 Heiko Tietze 2018-05-31 08:46:39 UTC
It's a duplicate of bug 115052 IMHO.
Comment 8 Xisco Faulí 2018-05-31 14:58:27 UTC
(In reply to Heiko Tietze from comment #7)
> It's a duplicate of bug 115052 IMHO.

Thanks for the info!!
Closing a RESOLVED DUPLICATED then. Let's keep the discussion there...

*** This bug has been marked as a duplicate of bug 115052 ***