Download it now!
Bug 35550 - macOS: "Previous Window" keyboard shortcut goes to next window/wrong interpretation of `in keyboard shortcut
Summary: macOS: "Previous Window" keyboard shortcut goes to next window/wrong interpre...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist Shortcuts-Mac
  Show dependency treegraph
 
Reported: 2011-03-22 10:16 UTC by javert03
Modified: 2019-08-11 11:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javert03 2011-03-22 10:16:07 UTC
Background:
In OS X, command+Tab switches to the next application while command+` switches to the next window of an application. Adding shift to the commands causes them to switch to the previous application or window, respectively.

Problem:
In OpenOffice (and now continuing into LibreOffice), command+` correctly switches to the next LibreOffice window, but command+shift+` does too, when it should switch to the previous window. In other words, if you have several documents open but are only working on documents 3 and 4 at the moment, you can go from 3 to 4 using keyboard shortcuts, but you can only get back to 3 by either using the Window menu or repeatedly hitting the keyboard shortcut.

To Reproduce:
Open 3 documents. Cycle through them using command+`, and then cycle through using command+shift+`. It will only cycle forward, never back.
Comment 1 Björn Michaelsen 2011-12-23 11:47:05 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:00:16 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:01:24 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:06:07 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:08:09 UTC Comment hidden (obsolete)
Comment 6 javert03 2012-08-14 19:25:52 UTC
Hi,

Just checked in Version 3.6.0.4 (Build ID: 932b512), and this bug is still present. The method to reproduce still works exactly as originally stated. Thanks!
Comment 7 Florian Reisinger 2012-08-16 10:55:10 UTC
Please always use the oldest version in version field..
Comment 8 Roman Eisele 2012-09-20 10:39:08 UTC
Bug was never confirmed by an independent reviewer, therefore reset Status to UNCONFIRMED.

(No offence -- this does not mean that I doubt the existence of this bug --
when status is UNCONFIRMED, the chance is even better that a bugwrangler will
try to reproduce this issue or search for duplicates, while with Status NEW the
bug will probably just be overlooked.)
Comment 9 Uwe Altmann 2012-10-09 18:12:12 UTC
Tested in 3.5.6.2 and 3.6.2.2 in US- and german keyboard layout > works for me.
The ` key is the one right from the left shift key (in between shift and z).
Comment 10 javert03 2012-10-10 00:34:53 UTC
Hi Uwe,

Thanks for checking that. Couple things:

1) I just tested in 3.6.2.2 and the bug is still present. Sounds like we're using different keyboards, which might be contributing to the problem. I have a US keyboard where the ` is immediately above tab and left of 1. There's nothing between shift and Z.

2) This does appear to be a problem with keyboard layout. For the heck of it I tried Greek Polytonic and the bug disappears. The bug is present in US, US Extended, and US International - PC.

3) When you tested the US layout, did you try CMD + Shift + `? Cmd + ` works fine, but Cmd + Shift + ` doesn't. They should go in opposite orders.

4) I just downloaded and tried all major releases starting with OpenOffice 3.0.0, the first to officially support Mac OS X.

3.0.0: Bug not present! Both Cmd+` and Cmd+Shift+` work, but there's a different bug causing their order to periodically reverse. Nonetheless, I can flip through windows both forwards and backwards, which is more than what the current version does.

3.0.1: Nothing changed.

3.1.0: Nothing changed.

3.1.1: Nothing changed.

3.2.0: Bug present! This was the release where some key bindings were changed to finally allow Cmd + ` to work in Calc. I can't find a particular bug that was fixed for this, but in earlier versions Cmd + ` enables formula view in calc. In 3.2.0 Cmd + ` starts switching windows instead. Here's the closest reference I can find (from 2009): https://issues.apache.org/ooo/show_bug.cgi?id=100730. That might be related.

Anyways, thanks for looking into this!
Comment 11 Uwe Altmann 2012-10-10 08:46:18 UTC
Thanks for your additional comments - that could help a lot. 
Yes, I'm using a german keyboard (hardware). Using LO 3.5.6 and 3.6.2 with german keyboard input layout (system pref pane) everything worked perfect - shift reverts the order of windows. 
But changing to US international PC input layout (system pref pane), shift doesn't revert the order of windows any more! 
btw - the order with US layout is always backwards (previous window) compared to german layout (same as using shift-cmd-'>').
Comment 12 QA Administrators 2015-01-05 17:52:22 UTC Comment hidden (obsolete)
Comment 13 Alex Thurgood 2015-03-08 14:59:43 UTC
Confirming also on 


Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_

OSX 10.10.2

using Macbook Pro with FR locale keyboard layout.
Comment 14 tommy27 2016-04-16 07:25:18 UTC Comment hidden (obsolete)
Comment 15 javert03 2016-04-17 22:06:43 UTC
Just confirmed again using version 5.1.2.2 on Mac OS X 10.9.5.
Comment 16 QA Administrators 2017-05-22 13:26:51 UTC Comment hidden (obsolete)
Comment 17 eisa01 2017-08-27 17:32:50 UTC
I had a look at this bug

To press cmd+` on the Norwegian keyboard layout, I actually have to press shift+´ to send the ` button.

That means the actual shortcut I have to press cmd+shift+´ to cycle windows.

As described then it doesn't work to cycle backwards.

However, when testing in TextEdit I get the exact same behaviour as in LibreOffice, I can't cycle backwards either, so this would indicate an upstream bug

Switching to a saner key such as cmd+' (' is above tab) does let me cycle through the windows both ways when pressing shift

However, I also wanted to check how this was on US keyboard layouts, as cmd+` is supposedly the default there as well, and has a much saner position right next to the left shift button.

Then it doesn't work in LibreOffice, while TextEdit works, so there still seems to be a bug here

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 18 duthen-mac 2018-04-20 16:34:47 UTC
I have the "bug" too, with: 

Version: 5.4.4.2
Build ID: 2524958677847fb3bb44820e40380acbe820f960
Threads CPU : 8; OS : Mac OS X 10.13.4; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

I'm using a fully french mac (french keyboard, french system, french locale, french software...).

In all applications, "`" is a dead key. Pressing the "`" key and then "a" key produces "à", which is very common in french (but is usually obtained by pressing the "à" key itself (the "0" key without "shift")). To get a "`" character alone (useful in lisp macros), we have to press once the "`" key and then the space bar.

In many applications, pressing cmd-` switches to the next window and cmd-shift-` to the previous window.

In LibreOffice, the behaviour of cmd-` depends on the document type.

= In a Writer document, it's almost the same with or without keeping "cmd" down:
- press "`" (without "cmd")
-> insert a "`" dead character, with the same background as a selected character, but without any border.
- click menu "Fenêtre" > some other window ("Fenêtre" means "Window")
- click menu "Fenêtre" > the previous window
-> the "`" is still highlighted
- press "a"
-> the "`" is replaced by a "a" (not a "à")

- press "cmd-`"
-> it switches to the next window
- click menu "Fenêtre" > the previous window
-> there is a "`" highlighted character
- press "a"
-> the "`" is replaced by a "a" (not a "à")

= In a Calc document, it's more complexe.
- double click a cell
- press "l" and then "`"
-> insert a "l" and a "`" dead character, with the a lighter background than a selected character.
- click menu "Fenêtre" > some other window ("Fenêtre" means "Window")
- click menu "Fenêtre" > the previous window
-> the cell itself is highlighted (and contains "l`")

if you:
- press "a"
-> the whole contents of the cell is replaced by a "a".

but if you:
- double click the cell to edit its contents
-> it contains "l`"
- press "a"
-> nothing happens: no "a", no "à", the "`" remains

When pressing "cmd-`", we have the same behaviour (plus the window switching).
Comment 19 QA Administrators 2019-04-24 02:49:22 UTC Comment hidden (obsolete)
Comment 20 eisa01 2019-08-10 19:49:41 UTC Comment hidden (obsolete)
Comment 21 eisa01 2019-08-11 11:49:11 UTC
This now works fine on:
US keyboard layout
Spanish ISO keyboard layout

I can cycle back and forth

On Norwegian keyboard layout I can only cycle one way, because I have to hold the shift key to produce the default ` key. But that is also the case in e.g., TextEdit, so that would be an upstream bug on choosing the default keyboard selections.

The bug on inserting the ` mark is covered in bug 53965 which remains

Version: 6.4.0.0.alpha0+
Build ID: 54028dc503fc08eb12e287919d5e2850cff05b73
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2019-07-31_01:48:19
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded