Bug Hunting Session
Bug 115953 - Keyboard shortcut bindings missing for Bullet and Number Lists in Styles Menu
Summary: Keyboard shortcut bindings missing for Bullet and Number Lists in Styles Menu
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2018-02-23 02:45 UTC by am_dxer
Modified: 2018-03-07 17:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2018-02-23 02:45:38 UTC
Description:
When pressing the down arrow to navigate the Styles menu, the keyboard shortcuts F12 and Shift+f12 which are used for a bullet list and a number list are not spoken by the screen reader.

Steps to Reproduce:
1. Press F10 to open the menu.
2. Press Right arrow to reach the Styles menu.
3. Press Down arrow until the Cursor reaches Number list and Bullet List

Actual Results:  
Orca did not speak the keyboard shortcuts

Expected Results:
Orca should speak the keyboard shortcuts.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.1.1
Build ID: 6.0.1-1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Alex ARNAUD 2018-02-23 09:18:47 UTC
Hello am_dxer,

On LibreOfficeDev 6.1 GTK2, I see no keyboard shortcuts on the screen bound to the menus Number list and Bullet List so it seems normal that Orca couldn't announce something not displayed on screen.

Just to be sure I'm correctly understanding you, why do you think it should announce keyboard shortcut?

Best regards.
Comment 2 am_dxer 2018-02-23 13:16:59 UTC
If you visit the Format and Lists menu, you can see that these keyboard shortcuts are bound. From what I can tell, both of these perform the same function but keyboard shortcuts are not listed in the Styles menu. For example, if you check one it checks it in the other place in the menus as well
Comment 3 am_dxer 2018-02-23 13:27:58 UTC
I just booted a Windows vm in Qemu and was able to produce it there with NVDA as well.
Comment 4 Buovjaga 2018-03-07 17:18:43 UTC
Ok, I get it, but would it be confusing for the user because the shortcuts do not work when the focus is in Styles?

Should the keyboard shortcuts of default and heading styles be announced as well? Bug 106785 is a request about adding shortcuts for some character styles.
Comment 5 am_dxer 2018-03-07 17:43:39 UTC
It might be confusing, however, the heading styles like Default Paragraph and Heading levels 1 through 3 are not able to be accessed via their shortcut when the menu is open either, however, they are listed in the menu. I was mostly reporting this bug due to the inconsistency in some keyboard shortcuts being listed and others not.
Comment 6 Maxim Monastirsky 2018-03-07 17:52:30 UTC
(In reply to am_dxer from comment #2)
> From what I can tell, both of these perform the same function
They don't. The commands under the Format menu are about direct formatting, while the Styles menu is about applying styles (in particular "List 1" and "Numbering 1" list styles).