Bug 116250 - When Keyboard is in RTL layout, up/down movement scrolls the viewport
Summary: When Keyboard is in RTL layout, up/down movement scrolls the viewport
Status: RESOLVED DUPLICATE of bug 120206
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2018-03-06 21:45 UTC by Eyal Rozenberg
Modified: 2018-09-30 08:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2018-03-06 21:45:57 UTC
On a GNU/Linux desktop environment (I use XFCE on Mint 18.3),

1. Start up Libreoffice 6.0.2.1.
2. Switch your keyboard layout to Hebrew (you need to have that enabled)
3. Press the down key

Instead of the cursor moving down by one cell, the viewport scrolls down by one cell, i.e. now cell A2 is the first one you see rather than A1.

If you switch back to English (or whatever LTR layout you have), the problem goes away and pressing up and down does what you expect.

Same behavior with the numpad arrows if NumLock is off.
Comment 1 m.a.riosv 2018-03-07 01:23:46 UTC
Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 112876 ***
Comment 2 Eyal Rozenberg 2018-09-30 08:54:48 UTC
Considering the title of the supposed-dupe, this is not actually a duplicate. But I'll keep it closed an open a new bug instead.

*** This bug has been marked as a duplicate of bug 120206 ***