Bug 116434 - Libreoffice startup exceedingly slow in 6.0.2.1
Summary: Libreoffice startup exceedingly slow in 6.0.2.1
Status: RESOLVED DUPLICATE of bug 103252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-16 17:08 UTC by Jon R Kibler
Modified: 2018-03-20 17:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon R Kibler 2018-03-16 17:08:34 UTC
Version: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8);
Comment 1 Jon R Kibler 2018-03-16 17:15:11 UTC
(Side note: When I was typing in the Summary description, suddenly the bug was submitted in the middle of my typing! That is why the original comments were brief and uninformative.)

Version: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: GL; 
Locale: en-US (en_US.UTF-8);

After upgrading from Libreoffice 5.4.6.2 to 6.0.2.1, the amount of time it takes from clicking on the Libreoffice icon in Dock to Start Center being displayed has increased from 10-15 seconds to now be 30-90 seconds.

I have cleared all recent documents and reset libreoffice, and it makes no difference in how slow libreoffice now is at startup.

I have also noticed a similar slowdown when opening a single document from Finder. However, that delay is highly variable, depending upon the document size. I have had one large document take over 3 minutes to open.

What changed?
Comment 2 Buovjaga 2018-03-16 19:08:36 UTC
Have not noticed this on macOS 10.12.6.

You could test Help - Restart in safe mode and then Continue in safe mode and then opening some document.
Comment 3 Telesto 2018-03-17 10:39:04 UTC
This might work; no guarantee 
1. Run the following command from the Terminal:
xattr -d com.apple.quarantine /Applications/LibreOffice.app

2. Start LibreOffice again

-> Please report back your findings here.

Based on bug 103892 and bug 114965
Comment 4 Jon R Kibler 2018-03-19 17:30:23 UTC
Starting in safe mode ($ open -a LibreOffice --args --safe-mode) starts somewhat faster, but not significantly. Simply starting the app in safe mode takes between 20 and 35 seconds (based on 5 repetitions). As a comparison, OpenOffice consistently starts in less than 5 seconds.

Once LibreOffice starts, opening documents is relatively fast. I should clarify that the large document that takes 3 minutes to open from Finder when LibreOffice is not running, only takes about 10 seconds to open once LibreOffice is running, and it does not seem to make a significant difference if I open the document from Finder or if I open it from within LibreOffice.

I also cleared the quarantine attribute, and that did not make any difference.
Comment 5 Jon R Kibler 2018-03-19 17:37:30 UTC
Experimenting, I have found an issue that SIGNIFICANTLY impacts how fast LibreOffice starts: Desktop Assignment.

I have all the apps I use on a regular basis assigned to specific desktops. When I remove the desktop assignment from LibreOffice, it now consistently starts in under 10 seconds.

As a point of reference, desktop assignment does not appear to have any impact on OpenOffice's startup time.

Also, I have OpenOffice and LibreOffice assigned to the same desktop.

What desktop I am on when I start LibreOffice from Dock (including the desktop to which it is assigned) does not appear to impact its start time.
Comment 6 Alex Thurgood 2018-03-20 16:34:50 UTC
Well I can reproduce the  behaviour when switching between 

LO5451 and

LO6021

but it works both ways.

In other words, on launch of either version after having previously assigned the other version to a given workspace, it takes about 20s for the app to bring up the StartCenter.

If however, the same version is launched, it takes about 6 seconds.

MacOS 10.13.3 High Sierra on a Macbook Pro
Comment 7 Alex Thurgood 2018-03-20 16:35:41 UTC
I'm pretty certain that this was reported before for a much earlier version (5.2 or 5.3 ?)
Comment 8 Alex Thurgood 2018-03-20 16:39:05 UTC
The pinning of the app to a workspace seems to cause it to take longer to load when compared to a previous version of the app, and maybe that is because LO reloads the whole configuration settings each time into the assigned workspace context.
Comment 9 Telesto 2018-03-20 16:45:50 UTC
(In reply to Alex Thurgood from comment #7)
> I'm pretty certain that this was reported before for a much earlier version
> (5.2 or 5.3 ?)

Bug 103252
Comment 10 Alex Thurgood 2018-03-20 17:16:52 UTC
(In reply to Telesto from comment #9)
> (In reply to Alex Thurgood from comment #7)
> > I'm pretty certain that this was reported before for a much earlier version
> > (5.2 or 5.3 ?)
> 
> Bug 103252

Ah, that's awkward then :-)
Re-opening.
Comment 11 Alex Thurgood 2018-03-20 17:18:00 UTC

*** This bug has been marked as a duplicate of bug 103252 ***