Download it now!
Bug 116674 - Link table styles to paragraph style
Summary: Link table styles to paragraph style
Status: RESOLVED DUPLICATE of bug 115573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2018-03-28 08:16 UTC by Heiko Tietze
Modified: 2018-03-28 09:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2018-03-28 08:16:45 UTC
Tables are added with the default table style, which is Serif/12 since 6.0 (bug 101349, bug 107554, bug 107555). If the paragraph has different settings, let's say handwriting style, the table doesn't take this style regardless what is set in the paragraph style Table Contents. Even worse, every time the table is modified (add/delete row/col) it's style is reapplied making any direct formatting pointless. The only workaround is to modify the table style itself, which is only possible via the legacy feature of autoformatting. Unchecking font in the legacy autoformat dialog is overridden on changes to the table.

Two possible solutions come in mind: do not set font, alignment, pattern in the default table style (blocked by the missing XML serialization yet bug 49437) or link font to what is set under paragraph styles (error-prone as users can delete Table Content there or have different styles). And finally if the user applied direct formatting it must not reverted on any modifications to the table (likely a result of bug 115573). Jim, you committed a patch...

@QA: Cannot follow the various not-closed-but-solved tickets.
Comment 2 Cor Nouws 2018-03-28 08:38:54 UTC
Hi Heiko,

To me it looks two different subjects:
 - paragraph style Table inherits from Standard (it does, doesn't it? and what is the problem?)
 - direct formatting of a table is nasty with the automatic applying of table styles after changing number of rows/columns. I thought I saw an issue reverting this behavior for time being?
Comment 3 RGB 2018-03-28 08:47:16 UTC
I think this is related to Bug 104389
Comment 4 Heiko Tietze 2018-03-28 09:01:39 UTC
Xisco told me on IRC the issue is fixed in master. Not tested myself.

(In reply to Cor Nouws from comment #2)
> To me it looks two different subjects:

Yes, the first is meant as solution for the second.
Comment 5 Xisco Faulí 2018-03-28 09:05:01 UTC
Yes, it's a dupe of bug 115573

*** This bug has been marked as a duplicate of bug 115573 ***