Bug 116675 - Autofilter: Clicking on item name does not select the item like in Excel
Summary: Autofilter: Clicking on item name does not select the item like in Excel
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.1.0
Keywords:
: 138667 (view as bug list)
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2018-03-28 08:55 UTC by Gabor Kelemen (allotropia)
Modified: 2021-05-07 09:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-03-28 08:55:12 UTC
Create an autofilter in Calc.
Open it, and try to select some items by clicking on their names. 
Nothing happens, you have to click on the checkbox in front to have the item selected.

In comparison, in Excel you can click on the item name as well to have it selected.

This can be inconvenient for users switching from Excel.
Comment 1 Heiko Tietze 2018-03-28 09:55:12 UTC
Yes, looks like a checkbox with an attached label. Guidelines for checkboxes say: "Do not separate check box and label. Clicking on both the box and the label should toggle the option."

No need for further UX input, but if CC to ux-advice is required.
Comment 2 m.a.riosv 2018-12-14 10:40:44 UTC
Maybe it is so, because when the text is selected you can use the buttons for show only current item or hide only the current item, while the checkbox change the selection status without select the item.
Comment 3 Gabor Kelemen (allotropia) 2019-07-16 09:05:02 UTC
I did a little more investigation into this.

In the autofilter widgets code this is handled by the ScCheckListBox (in sc/source/ui/cctrl/checklistmenu.cxx which is derived from SvTreeListBox

Now we also have a similar derived class that can do the trick requested here: SvxCheckListBox in svx/source/dialog/checklbx.cxx that is also derived from SvTreeListBox
This can be still seen in Options - Writer - Compatibility - click on the name of the compatibility option and the corresponding checkbox will be checked.

SvxCheckListBox was also used on the Options - Language Settings - Writing Aids page until it was recently welded to use weld::TreeView instead. 
As a consequence now the "click on the items name to select it" no longer happens there, unlike in 6.2.
Similar consequence that it is no longer possible on the Writing Aids page to use the Space or Enter keys to select/unselect a highlighted item in the lists.

This is how far I got: it looks like SvxCheckListBox can do some tricks that would be nice to have on the VCL level too.

@Caolán, this might interest you...
Comment 4 Commit Notification 2020-10-19 11:45:17 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2471d6f44c7e8ecbe86a90eeb593b899a08a7408

tdf#116675 vcl tree list: toggle by label click (e.g. in AutoFilter)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 László Németh 2020-10-19 11:49:37 UTC
Fixed only for the generic VCL plugin, i.e. on Windows by default (check it with the SAL_USE_VCLPLUGIN=gen environmental variable under Linux). Maybe it's worth to add to the other VCL plugins in the future, too.

Note: Interestingly, Excel can select the list items only clicking on the labels, i.e. Calc seems to be more comfortable now, because it's enough to click on the line, including the wide empty area after the short label.
Comment 6 NISZ LibreOffice Team 2020-11-12 11:04:24 UTC
Verified in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a689cf1672e89cb78fbcfa14c505850927e71f58
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!
Comment 7 Jim Raykowski 2020-12-27 00:51:27 UTC
In the Customize dialog (menu > Tools > Customize...) Toolbars tab, Assigned Commands list box (treeview) this causes the checkbox to toggle when item text is clicked which is a problem when the item is being selected as an insert position or to move. Expected behavior is for the checkbox to toggled only when mouse click is done directly on the checkbox or space bar key is used when item entry is highlighted.

Version: 7.2.0.0.alpha0+
Build ID: ed1235280520852d0eb0f19f05dc4c39d565a6d7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 8 Aron Budea 2020-12-27 02:17:19 UTC
Jim, please open a separate bug report for the regression, and add this bug to the See Also field.
Comment 9 NISZ LibreOffice Team 2021-05-07 09:05:29 UTC
*** Bug 138667 has been marked as a duplicate of this bug. ***