Download it now!
Bug 117332 - Conditional formatting: selecting a cell range for the condition with the mouse gets you every cell individually, but not the range (see comment 10)
Summary: Conditional formatting: selecting a cell range for the condition with the mou...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium minor
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-04-29 15:10 UTC by Torsten
Modified: 2019-02-07 16:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten 2018-04-29 15:10:00 UTC
Description:
If you select an address range with the mouse you get no range for your formating but every cell you select is going into the addressfield.


Steps to Reproduce:
1.Open Calc
2.Select Condition
3.click in the texfield 
4.select some cellcs

Actual Results:  
Sheet1.$B$14$Sheet1.$B$14:$B$15$Sheet1.$B$14

Expected Results:
Sheet1.$B$14:$B$15


Reproducible: Always


User Profile Reset: No



Additional Info:
With Libre Office 5.0 this works as expected. I think F4 should work for change adressing.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 raal 2018-04-29 18:17:14 UTC
Works for me in Version: 6.1.0.0.alpha1+
Build ID: 4dbce627d3643babaf90a93c70b365ff08abfca6
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
and 6.0.3.2 (x64); windows


Seems to be fixed. Please upgrade to actual version and try again.

http://www.libreoffice.org/download/libreoffice-fresh/
Comment 2 Torsten 2018-04-30 07:30:52 UTC
If have installed the new Version 6.1.0.0.alpha1 with no luck.

You can add a cell but you can't select a cell.

1. click on cell you have $Tabelle1.$D$11
2. click another cell you have $Tabelle1.$D$11$Tabelle1.$D$15

With Version 5.0.6.3 you can select a cell.
Comment 3 Buovjaga 2018-06-07 15:30:08 UTC
I could repro on Win and Linux.
Bibisected with Win 5.4 repo to range 169bd7718264b0e312052757f9bbd2321e1399c2...ff8b873936aa72b17309da4bfc2775573a5b1f55

Examined the commit range and then on Linux master reverted this and did a build: https://cgit.freedesktop.org/libreoffice/core/commit/?id=42aece949ec96c775b31216bddd723aa5321e966

don't replace content of formula field when selecting range, tdf#58635
Change-Id: I85953fdd7c2b7f193b2a815564526d985ae2bba4

The problem was not seen in the build with the reverted commit.

Adding Cc: to Markus Mohrhard
Comment 4 Buovjaga 2018-12-03 12:18:18 UTC
Kompi alerted me about this and I no longer reproduce this on Windows or Linux. Closing
Comment 5 Torsten 2018-12-03 17:53:46 UTC
Nothing has changed the Problem persists.
Even in Version 6.1.3
Select Cells an getting a Range ist not working like in any other Calulation Program.
Closing the Bug is not a Solution.
Thanks
Comment 6 Buovjaga 2018-12-03 19:44:20 UTC
Fine, let's set it to unconfirmed. We should find someone with a Mac to confirm
Comment 7 Torsten 2018-12-04 12:55:01 UTC
Today I have checked all LibreOffice versions on all Systems.
Linux LibreOffice 64 6.0.5.2
Windows 7 64 Libre Office 6.1.3.2
OSX
Comment 8 Buovjaga 2018-12-04 12:58:47 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2018-12-04 13:01:18 UTC Comment hidden (obsolete)
Comment 10 Torsten 2018-12-04 13:10:58 UTC
Today I have checked all LibreOffice versions on all Systems.
Linux LibreOffice 64 6.0.5.2
Windows 7 64 Libre Office 6.1.3.2
OSX Libre Office 6.1.3.2
Same Bug
New try of explain:
1. put in B10 any kind of text for conditional formating
2. put in C10 1, C11 2 ... C16 6
3. select conditional formating
3. select formula is
4. put in sum(C10:C16)>10
5. select a format for B10
6. press ok 
This works
If you select the cells C10-C16 with your mouse
you will get not the range for the formula like in any other calculation program
you get:
$Tabelle1.$C$10$Tabelle1.$C$10$Tabelle1.$C$10:$C$11$Tabelle1.$C$10:$C$12$Tabelle1.$C$10:$C$13$Tabelle1.$C$10:$C$14$Tabelle1.$C$10:$C$15$Tabelle1.$C$10:$C$16$Tabelle1.$C$10:$C$17$Tabelle1.$C$10:$C$18$Tabelle1.$C$10:$C$17$Tabelle1.$C$10:$C$16

I expected
$Tabelle1.$C$10:$C$16
Comment 11 Buovjaga 2018-12-04 13:16:44 UTC
Ok, with the steps you mentioned, I can repro. Maybe in my comment 3 I was able to deduce the steps, but now I did not remember what they were.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 9059457a1a8385cb80b5dd2c797cee77af4222a9
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 30 November 2018
Comment 12 Mike Kaganski 2018-12-04 13:41:02 UTC
I still cannot decipher the steps from comment 10, so I cannot reproduce.

I assume I understand what "3. select conditional formating" should mean (it's "Format"→"Conditional"→"Condition" menu?); but is it important where the cursor is at that moment? Well, let's suppose it's unimportant. Next is: at what moment and where should I do "If you select the cells C10-C16 with your mouse"? and where should I look for the formula string "$Tabelle1.$C$10$Tabelle1.$C$10$Tabelle1..." then? Should it be something like "if in step X above, you do instead ...., then ..."?
Comment 13 Buovjaga 2018-12-04 13:43:21 UTC
(In reply to Mike Kaganski from comment #12)
> I still cannot decipher the steps from comment 10, so I cannot reproduce.
> 
> I assume I understand what "3. select conditional formating" should mean
> (it's "Format"→"Conditional"→"Condition" menu?); but is it important where
> the cursor is at that moment? Well, let's suppose it's unimportant. Next is:
> at what moment and where should I do "If you select the cells C10-C16 with
> your mouse"? and where should I look for the formula string
> "$Tabelle1.$C$10$Tabelle1.$C$10$Tabelle1..." then? Should it be something
> like "if in step X above, you do instead ...., then ..."?

After selecting Formula is, type into the input box =SUM( and then mouse-select the range. The formula string will appear in the input box after your =SUM(
Comment 14 Mike Kaganski 2018-12-04 13:45:12 UTC
(In reply to Buovjaga from comment #13)

Thanks! Repro.
Comment 15 Mike Kaganski 2018-12-04 18:36:08 UTC
https://gerrit.libreoffice.org/64574
Comment 16 Commit Notification 2018-12-05 04:28:04 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6c5839d399c6277a7f2f0e214a20996761563525%5E%21

tdf#117332: select replaced text to properly replace it next time

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2018-12-12 13:06:44 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 3911bf8364dae4c855ad37237c114f9007f70657
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this!!

Cherry-picked to
6-2: https://gerrit.libreoffice.org/#/c/65026/
6-1: https://gerrit.libreoffice.org/#/c/65027/
Comment 18 Commit Notification 2018-12-17 08:46:58 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/264c0bd303fa77932959e4265d2dd05a29a4da09%5E%21

tdf#117332: select replaced text to properly replace it next time

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2018-12-20 00:02:24 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/9396cf7edb101983c56f44ae814029ce78f0fc71%5E%21

tdf#117332: select replaced text to properly replace it next time

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Torsten 2019-02-07 16:02:34 UTC
Thank you for fixing.

Tested with Version 6.1.5.2 on Windows.