Download it now!
Bug 117595 - UI hangs on Tools -> Options (or Alt-F12)
Summary: UI hangs on Tools -> Options (or Alt-F12)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2018-05-13 06:49 UTC by Macky
Modified: 2019-10-19 20:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
A freshly created reset user profile that continues to give me the same problems as before (61.97 KB, application/zip)
2018-05-14 08:07 UTC, Macky
Details
strace for hang on Tools->Options (15.09 MB, application/x-bzip)
2019-10-18 10:09 UTC, Macky
Details
strace for Arch Linux's default LO package (3.01 MB, application/x-bzip)
2019-10-18 10:55 UTC, Macky
Details
strace of Tools->Options working properly (15.59 MB, application/x-bzip)
2019-10-19 05:23 UTC, Macky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Macky 2018-05-13 06:49:47 UTC
Steps to reproduce:

Start libreoffice and click on Tools->Options (or hit Alt-F12). The UI hangs indifinitely. The results are the same if I create a Libreoffice document first (tried with Writer, Calc, and Impress), and then visit Tools -> Options.

System Info:

Arch Linux 4.16.8-1-ARCH x86_64

Prerequisite Packages:

bash - 4.4.019-1
clucene - 2.3.3.4-9
curl - 7.59.0-2
dbus-glib - 0.110-1
desktop-file-utils - 0.23+4+g92af410-1
gcc-libs - 8.1.0-1
glew - 2.1.0-1
glu - 9.0.0-4
graphite - 1:1.3.11-1
gst-plugins-base-libs - 1.14.0-1
gtk2 - 2.24.32-1
gtk3 - 3.22.30-1
harfbuzz-icu - 1.7.6-2
hicolor-icon-theme - 0.17-1
hunspell - 1.6.2-1
hyphen - 2.8.8-1
icu - 61.1-1
jdk - 10.0.1-1
kdelibs4support - 5.45.0-1
lcms2 - 2.9-1
libabw - 0.1.2-1
libatomic_ops - 7.6.4-1
libcdr - 0.1.4-3
libcmis - 0.5.1-8
libcups - 2.2.7-2
libe-book - 0.1.3-2
libepubgen - 0.1.0-1
libetonyek - 0.1.8-1
libexttextcat - 3.4.5-1
libfreehand - 0.1.2-1
libglvnd - 1.0.0-1
libjpeg-turbo - 1.5.3-1
liblangtag - 0.6.2-1
libmspub - 0.1.4-2
libmwaw - 0.3.14-1
libodfgen - 0.1.6-1
liborcus - 0.13.4-1
libpagemaker - 0.0.4-1
libpaper - 1.1.24-10
libqxp - 0.0.1-2
libstaroffice - 0.0.5-1
libtommath - 1.0.1-1
libvisio - 0.1.6-3
libwpd - 0.10.2-1
libwpg - 0.3.2-1
libwps - 0.4.9-1
libxinerama - 1.1.3-2
libxrandr - 1.5.1-2
libxslt - 1.1.32+3+g32c88216-1
libzmf - 0.0.2-3
lpsolve - 5.5.2.5-2
neon - 0.30.2-3
nspr - 4.19-1
nss - 3.36.1-1
pango - 1.42.1-1
poppler - 0.64.0-1
postgresql-libs - 10.4-2
python - 3.6.5-2
redland - 1:1.0.17-4
sane - 1.0.27-1
shared-mime-info - 1.9-1
unixodbc - 2.3.6-1
xmlsec - 1.2.25-1
Comment 1 Jean-Baptiste Faure 2018-05-13 08:39:32 UTC
Not reproducible with version 6.0.4 provided by Ubuntu.

Best regards. JBF
Comment 2 Xavier Van Wijmeersch 2018-05-13 08:42:02 UTC
no repro, try to disable opengl, and retest

Version: 5.4.8.0.0+
Build ID: cc68977f1be22ac0f4a15eb37e05ccba13a7a554
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2018-05-12_11:32:19
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 6.0.5.0.0+
Build ID: 4fd9ba592c2a9a566813942b06c864ad37e96243
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 6.1.0.0.alpha1+
Build ID: ecf50fe71596c3edba8ce437481ab80ae1cd8935
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-05-08_00:13:13
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 3 Macky 2018-05-13 09:10:17 UTC
(In reply to Xavier Van Wijmeersch from comment #2)
> no repro, try to disable opengl, and retest
> 


I used the instructions from https://wiki.documentfoundation.org/OpenGL#Crash_on_program_start to disable OpenGL. It made no difference.

I tested with libreoffice 6.0.3 too, and got the same results. I was unable to run versions older than that because they need versions of libraries that are older than what's available on my system.

Is there a way to display detailed logging information on the terminal or a logfile without rebuilding the app?
Comment 4 Jean-Baptiste Faure 2018-05-13 10:06:28 UTC
Please try with a new user profile: https://wiki.documentfoundation.org/Faq/General/110

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 5 Macky 2018-05-14 08:05:28 UTC
(In reply to Jean-Baptiste Faure from comment #4)
> Please try with a new user profile:
> https://wiki.documentfoundation.org/Faq/General/110


I created a new login on my computer. Libreoffice works fine there. I came back to my own user login, and through safe mode, I reset my libreoffice profile to factory settings, including "settings and user interface modifications" and "entire user profile".

I continue to have the problem on my profile. I will attach the user profile zip file that I created from safe-mode.
Comment 6 Macky 2018-05-14 08:07:58 UTC
Created attachment 142087 [details]
A freshly created reset user profile that continues to give me the same problems as before
Comment 7 Thomas Lendo 2018-05-21 19:30:32 UTC Comment hidden (obsolete)
Comment 8 Macky 2018-05-28 23:04:08 UTC
(In reply to Thomas Lendo from comment #7)
> Is this issue related to Bug 104332 'Thesaurus in the Tools menu causes it
> to open slowly the first time'?

I don't think so. My problem occurs when I open even plain libreoffice, and not any of its components. The language menu is not available in that context.
Comment 9 Xisco Faulí 2018-08-15 18:26:32 UTC
Hi Macky,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 10 Macky 2018-11-07 13:44:24 UTC
Hi Xisco,

I did what you asked, and tried the master build today.

I could not install it, because I'm running Arch Linux. However, after extracting all the RPM files, I ran the soffice executable in LibreOfficeDev_6.2.0.0.alpha1_Linux_x86-64_deb/DEBS/opt/libreofficedev6.2/program

All the usual operations work as expected. However the problem with hanging on Alt-F12 persists.


I downloaded the file that was released on 2018-Nov-06 23:16. Here is the version info from the program:

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: en-IE (en_IE.UTF-8); Calc: CL
Comment 11 Macky 2018-11-07 14:09:45 UTC
Oops, I meant I extracted all the .deb files, not rpm. I had downloaded both, that's why I got confused.
Comment 12 Macky 2018-12-14 10:57:56 UTC
The bug report was first created against 6.0.4.2, but is still present as of 6.1.3.2.
Comment 13 Jean-Baptiste Faure 2018-12-15 21:18:04 UTC
Please, do not change version number. It is intended to show the oldest version in which the bug has been found.

Best regards. JBF
Comment 14 Xisco Faulí 2019-01-17 12:26:40 UTC
Hi Macky,
Could you please try it in LibreOffice 6.2.0.2 from
https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 15 Macky 2019-02-03 18:38:07 UTC
I checked with 6.2.0.3, the latest pre-release at the moment. The bug is still present in the latest version.
Comment 16 Julien Nabet 2019-05-15 08:49:35 UTC
(In reply to Macky from comment #5)
> (In reply to Jean-Baptiste Faure from comment #4)
> > Please try with a new user profile:
> > https://wiki.documentfoundation.org/Faq/General/110
> 
> 
> I created a new login on my computer. Libreoffice works fine there. I came
> back to my own user login, and through safe mode, I reset my libreoffice
> profile to factory settings, including "settings and user interface
> modifications" and "entire user profile".
> 
> I continue to have the problem on my profile. I will attach the user profile
> zip file that I created from safe-mode.

I don't understand this comment.
When reading https://wiki.documentfoundation.org/UserProfile, restart LO in  safe-mode means you don't use your current profile in safe mode.

Resetting LO profile just means renaming LO directory profile, you can't choose specifically what component to reset.

If you indicate that by creating a new user, you got no pb, it reduces the list of things to investigate.
Except a corrupted LO profile or a buggy config from your user profile (Java or something), the other points should be ok.

In brief, could you rename your LO directory profile and give a new try?
Comment 17 Macky 2019-05-15 13:43:55 UTC
(In reply to Julien Nabet from comment #16)
> Resetting LO profile just means renaming LO directory profile, you can't
> choose specifically what component to reset.

You can. See here: https://i.imgur.com/TTdJ1Aa.png

> In brief, could you rename your LO directory profile and give a new try?

I have been trying that option all along. In fact, I delete whatever comes up with ' find ~ -iname "*libreoffice*"' The problem still persists.
Comment 18 Julien Nabet 2019-05-15 13:58:22 UTC
(In reply to Macky from comment #17)
> (In reply to Julien Nabet from comment #16)
> > Resetting LO profile just means renaming LO directory profile, you can't
> > choose specifically what component to reset.
> 
> You can. See here: https://i.imgur.com/TTdJ1Aa.png
Thank you for the screenshot, I didn't know this screen.

> 
> > In brief, could you rename your LO directory profile and give a new try?
> 
> I have been trying that option all along. In fact, I delete whatever comes
> up with ' find ~ -iname "*libreoffice*"' The problem still persists.

Could you provide an strace (not a stacktrace/backtrace), see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace?
The goal is to see if we can find what LO waits for.
Comment 19 Willy Weisz 2019-07-28 11:42:11 UTC
As I've described in a comment in bug report 124737 I made the following observations:

The problem is present even in:

Version: 6.2.5.2
Build-ID: 20(Build:2)
CPU-Threads: 4; BS: Linux 4.12; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-AT (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

on openSuSE Leap 15.1.

The options window pops up after a long delay (about 2 minutes 30 seconds).

The call to tools->options (Extras -> Optionen in the German language version) triggers the start of a pgp2 process that uses 100% of one CPU. The disappearance of the gpg2 process and the pop up of the options window happen after the delay mentioned above.

I've watched an strace and there was no message line for the time between calling options and the appearance of the window.
Comment 20 mattia.b89 2019-09-07 09:15:23 UTC
I can't reproduce the issue on my system:
Version: 6.3.1.2
Build ID: 6.3.1-1
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: it-IT (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

PS: if a new user "fixed" the issue, this means it is an issue from other system components, that is:
new user -> cleans $HOME, not just LO configuration but also EVERYTHING such as GTK/QT settings, cache, etc.)
Comment 21 Xisco Faulí 2019-10-16 12:06:02 UTC
I believe this issue should be gone with the option dialog being welded ( see bug 122850 )
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 22 Willy Weisz 2019-10-16 19:26:15 UTC
I'm now running version 6.3.2.2 of LibreOffice, and the delay I've described in comment 19 has disappeared. The option window pops up immediately.

So the problem was corrected before the 6.4 branch has started.
Comment 23 Macky 2019-10-18 08:58:44 UTC
Hi Xisco,

I tested with both 6.3.2.2 and the daily master (6.4.0.0.alpha1+, Build ID: da50f3e15e38474a51361bdddbc0951dec5674bf). The problem remains exactly the same.

The only extra info that is printed when I launch from a terminal is the following:

warn:vcl.plugadapt:15664:15664:vcl/source/app/salplug.cxx:115: could not load shared object libvclplug_kde4lo.so


This is printed as soon as I launch ./soffice, without even trying to launch the options window.
Comment 24 Julien Nabet 2019-10-18 09:10:37 UTC
(In reply to Macky from comment #23)
>...
> warn:vcl.plugadapt:15664:15664:vcl/source/app/salplug.cxx:115: could not
> load shared object libvclplug_kde4lo.so
>...

kde4 support has been removed from LO 6.3 (see https://wiki.documentfoundation.org/ReleaseNotes/6.3#KDE4_VCL_plugin).
If you want to stick to KDE, you must use KDE5
Comment 25 Macky 2019-10-18 09:19:18 UTC
Hi Julien,

I don't have kde4 or any qt4 libraries. I have KDE5/Plasma installed but I use LXQt. This is what I get from Help->About...


Version: 6.4.0.0.alpha1+
Build ID: da50f3e15e38474a51361bdddbc0951dec5674bf
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time: 2019-10-17_14:43:54
Locale: en-IE (en_IE.UTF-8); UI-Language: en-US
Calc: threaded


I have tried by clearing out all locale info, but the behaviour does not change.
Comment 26 Julien Nabet 2019-10-18 09:35:51 UTC
Would it be possible you retrieve a strace (not a backtrace/stacktrace), see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_an_strace_log ?

I'd like to know what calls kde4 whereas you use LO with kf5 rendering.

I wonder too if you shouldn't remove any LO trace (from Arch repo or from manual install), then remove/rename your LO directory profile https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_an_strace_log
and install last 6.3 version from Arch repo.

Michael: thought you might be interested in this one since it concerns a kde4 shared lib called from LO 6.3 and even master build.
Comment 27 Macky 2019-10-18 10:09:50 UTC
Created attachment 155112 [details]
strace for hang on Tools->Options

I removed the old strace.log file, performed "rm -rf ~/.config/libreoffice", and executed soffice with --strace. I have attached the log file.

To generate it, I launched soffice, perfomed Tools->Options, waited for several minutes, and forcefully killed soffice.bin.
Comment 28 Macky 2019-10-18 10:55:12 UTC
Created attachment 155113 [details]
strace for Arch Linux's default LO package

Generated the same way as strace-macky.log, except that this one is for the default (LibreOffice 6.3.2.2) package of Arch Linux.
Comment 29 Michael Weghorn 2019-10-18 19:58:46 UTC
(In reply to Macky from comment #23)
> The only extra info that is printed when I launch from a terminal is the
> following:
> 
> warn:vcl.plugadapt:15664:15664:vcl/source/app/salplug.cxx:115: could not
> load shared object libvclplug_kde4lo.so
> 
> 
> This is printed as soon as I launch ./soffice, without even trying to launch
> the options window.

That sounds like some environment variable like SAL_USE_VCLPLUGIN was explicitly pointing to kde4.

Can you check the output of 'env | grep kde4' (and your ~/.bashrc or ~/.bash_aliases)?

I can e.g. provoke such a message with an arbitrary dummy VCL plugin as well like this:

$ SAL_USE_VCLPLUGIN=foobar ./instdir/program/soffice.bin --writer
warn:vcl.plugadapt:48698:48698:vcl/source/app/salplug.cxx:115: could not load shared object libvclplug_foobarlo.so

That should be unrelated to the actual problem, though.



(In reply to Macky from comment #27)
> Created attachment 155112 [details]
> strace for hang on Tools->Options
> 
> I removed the old strace.log file, performed "rm -rf ~/.config/libreoffice",
> and executed soffice with --strace. I have attached the log file.
> 
> To generate it, I launched soffice, perfomed Tools->Options, waited for
> several minutes, and forcefully killed soffice.bin.

At a quick glance, that looks like it might be the same problem as mentioned in comment 19, seems GPG-related. Lines 3251800 ff look like this:

    20237 15:26:03.891496 stat("/run/user/1000/gnupg", {st_mode=S_IFDIR|0700, st_size=140, ...}) = 0
    20237 15:26:03.891535 getuid()          = 1000
    20237 15:26:03.891568 stat("/run/user/1000/gnupg/S.gpg-agent", {st_mode=S_IFSOCK|0600, st_size=0, ...}) = 0
    20237 15:26:03.891609 socket(AF_UNIX, SOCK_STREAM, 0) = 5
    20237 15:26:03.891649 stat("/run/user/1000/gnupg/S.gpg-agent", {st_mode=S_IFSOCK|0600, st_size=0, ...}) = 0
    20237 15:26:03.891691 connect(5, {sa_family=AF_UNIX, sun_path="/run/user/1000/gnupg/S.gpg-agent"}, 34 <unfinished ...>
    20160 15:26:04.383977 <... select resumed>) = 0 (Timeout)
    20160 15:26:04.384163 select(30, [27 29], [], NULL, {tv_sec=1, tv_usec=0}) = 0 (Timeout)

and then there's a lot of 'poll'ing.

Can you try what happens if you kill any GPG-related process or temporarily rename  your ~/.gpg directory (don't delete it, it may contain private keys,...)?
Comment 30 Julien Nabet 2019-10-18 20:40:40 UTC
Also, I noticed libKF5KDELibs4Support.so.5 in strace, could you check you don't have libkf5kdelibs4support-data package?
Comment 31 Macky 2019-10-19 05:23:14 UTC
Created attachment 155143 [details]
strace of Tools->Options working properly

Hi Julien,

> That sounds like some environment variable like SAL_USE_VCLPLUGIN was explicitly pointing to kde4.

Yes, apparently, LXQt sets it on startup, but I can set it to anything I want without affecting LXQt. https://github.com/lxqt/lxqt/issues/1673

I tested on plain Plasma instead of LXQt, the problem remained.

> could you check you don't have libkf5kdelibs4support-data package?

I do have kdelibs4support, and I can't uninstall it because critical components of Plasma depend on it. Specifically, I have calligra, knetattach, kolourpaint, plasma-workspace, qtcurve-kde installed. Of these, knetattach and plasma-workspace cannot be removed without removing all of KDE5/Plama.


> Can you try what happens if you kill any GPG-related process or temporarily rename  your ~/.gpg directory (don't delete it, it may contain private keys,...)?

I don't have a ~/.gpg directory. I have a ~/.gnupg, which I temporarily renamed. I also stopped gpg-agent and tried again after ensuring gpg-agent was not running.

Apparently, this solves it! I renamed the backup.gnupg to .gnupg (as it was, originally), enabled the auto-start of gpg-agent and tried again on a fresh login.

This time around, opening Tools->Options works fine!

It looks like LO was hanging because of some conflict within ~/.gnupg. After I removed that conflict and allowed LO to initialize itself properly, LO started behaving normal. There are still plenty of "Bad file descriptor" messages in the logs, but at least Tools->Options opens properly.

I have attached the latest strace where Tools->Options opens properly.

Thank you for your help in resolving this!
Comment 32 Julien Nabet 2019-10-19 07:08:14 UTC
Macky: if you re read the last comments, you'll see that it's not me but Michael Weghorn who found the rootcause so you can thank him :-)

Let's put this one to WFM then.