Bug Hunting Session
Bug 117742 - On format menu, when numbered list is enabled, keyboard navigation is broken
Summary: On format menu, when numbered list is enabled, keyboard navigation is broken
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Main-Menu Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2018-05-22 13:51 UTC by Alex ARNAUD
Modified: 2019-03-11 06:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2018-05-22 13:51:37 UTC
Description:
Hello all,

Steps to Reproduce:
1. Open LibreOffice Writer on an empty page
2. Write "Hello world"
3. Press F12
4. Press down arrow until to go on a sub-menu

Actual Results:  
The keyboard focus goes on a sub-menu of a menu item.

Expected Results:
LibreOffice shouldn't go to a sub menu until we press right arrow.


Reproducible: Always


User Profile Reset: No



Additional Info:
I'm using Libreoffice daily build with VCL GTK3 on Debian 9 "Stretch". The daily build comes from Git: git://dev-downloads.libreoffice.org/lo-linux-dbgutil-daily.git

Best regards,
Alex.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Dieter Praas 2018-05-24 17:03:25 UTC
Not repoducible for me. If I press F12 the text becomes a list "1. Hello World" and nothing happens, when I press the key "down arrow".
Comment 2 Alex ARNAUD 2018-05-25 13:43:42 UTC
(In reply to Dieter Praas from comment #1)
> Not repoducible for me. If I press F12 the text becomes a list "1. Hello
> World" and nothing happens, when I press the key "down arrow".

I've missed to tell press F10 after to press F12.

Best regards,
Alex.
Comment 3 Dieter Praas 2018-05-25 13:53:08 UTC
I tried to reproduce:

...

F12 => Keyboard focus is on menu "file"
Down Arrow => Keyboard focus is on sub-menu "New" (without opening sub menu)

Everything is like I would expect. So I can't see any problem

Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL
Comment 4 Alex ARNAUD 2018-05-25 14:28:01 UTC
(In reply to Dieter Praas from comment #3)
> I tried to reproduce:
> 
> ...
> 
> F12 => Keyboard focus is on menu "file"
> Down Arrow => Keyboard focus is on sub-menu "New" (without opening sub menu)
> 
> Everything is like I would expect. So I can't see any problem

I reexplain the steps:
1. Open LibreOffice Writer on an empty page
2. Write "Hello world"
3. Press F12
4. Press F10
5. Go on the format menu with keyboard
6. Press down arrow until to go on a sub-menu
Comment 5 Dieter Praas 2018-05-25 14:57:24 UTC
I'm sorry, but I still can't see the problem. Perhaps somebody else can help.
Comment 6 Alex ARNAUD 2018-05-25 16:49:52 UTC
(In reply to Dieter Praas from comment #5)
> I'm sorry, but I still can't see the problem. Perhaps somebody else can help.

Are you testing with daily build?

Best regards,
Alex.
Comment 7 Dieter Praas 2018-05-25 17:43:46 UTC
(In reply to Alex ARNAUD from comment #6)
> Are you testing with daily build?
> 
> Best regards,
> Alex.

Tested with

Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL
Comment 8 Xisco Faulí 2018-05-29 14:57:49 UTC
I can't reproduce it in

Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

nor in

Version: 6.2.0.0.alpha0+
Build ID: 8f9f66e8d2bae94c1f469ffc51bdbffeba853a2b
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 9 Buovjaga 2018-06-18 07:42:16 UTC
No repro. With GTK3 it only shows the sub menu, but does not focus into it. So I can continue hitting down arrow in the top-level Format menu.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: dc9ee533dc707cc10b99d537eaccc3ee5aa555fe
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 16th 2018
Comment 10 fatfish 2018-11-29 08:15:02 UTC
I can't reproduce it on my libreoffice.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 11 brian chen 2018-11-29 09:26:42 UTC
Bug not reproducible in version

I followed the steps given by Alex. It turns out that LibreOffice wouldn't go to the sub-menu until I press the right button. Just as the Expected Results.
Comment 12 Xisco Faulí 2018-11-29 09:33:19 UTC
Hello Alex Arnaud,
i can't reproduce it in

Version: 6.2.0.0.beta1+
Build ID: ce7bb69f8205bcbe36cba4c53bd110e07ef3e05d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 13 Alex ARNAUD 2019-02-16 15:29:28 UTC
OK, I cannot reproduce this on LibreOffice daily build.