Bug 117758 - Save copy of odt file containing formula leaves temporary file.
Summary: Save copy of odt file containing formula leaves temporary file.
Status: RESOLVED DUPLICATE of bug 117757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-05-23 11:54 UTC by Mark Hung
Modified: 2018-07-03 11:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2018-05-23 11:54:26 UTC
Sample file.

1. Open attachment of tdf#117757. It contains a simple formula.
2. Use "Save a Copy" to save the copy of the document.

Actual result: there is a temporary file ( something like lu5420hvp2hf.tmp ) left in the same directory.
Expected result: Writer should remove temporary files as soon as the document saved.

Note: not sure if "Save a copy" and "Save as" have different routes. But since "Save" and "Save as" have different results I decide to open two issues for "Save a copy" and "Save as".

Verified with:
Version: 6.1.0.0.alpha1+ (x64)
Build ID: 0e8d2cb6b7af441642ffe3e94cfccb526fb12b49
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: zh-TW (zh_TW); Calc: group

Open up a new issue per comment#11 of tdf#117225.
Comment 1 Xisco Faulí 2018-05-29 13:09:31 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-01-17 18:11:41 +0100
committer	Julien Nabet <serval2412@yahoo.fr>	2018-01-18 07:12:42 +0100
commit	27938e1bbd5f3405c47b9933be7489eeb03920f3 (patch)
tree	792f4df230b6364ef8eb578e647454648e2afd62
parent	c915fdbfc77ac78d543bc097cd809edd7e6da8cb (diff)
sfx2 store: create temp files next to local files (storage case)
This is similar to commit 5259ab8104cfba60c40748ed0cd59d93df038c5b (sfx2
store: create temp files next to local files, 2018-01-08), except there
only the stream case was handled (e.g. sw HTML export), while this is
the storage case (e.g. ODT export).

Bisected with: bibisect-win32-6.1

Adding Cc: to Miklos Vajna
Comment 2 Miklos Vajna 2018-07-03 11:58:11 UTC
Makes sense, now I can confirm that the fix for bug 117757 was a fix for this one as well.

*** This bug has been marked as a duplicate of bug 117757 ***