Bug 117757 - Save odt file with formula as another file leaves temp file in the same directory.
Summary: Save odt file with formula as another file leaves temp file in the same direc...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: bibisected, bisected, regression
: 117758 117759 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-23 11:42 UTC by Mark Hung
Modified: 2018-07-03 15:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file. (10.86 KB, application/vnd.oasis.opendocument.text)
2018-05-23 11:42 UTC, Mark Hung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2018-05-23 11:42:35 UTC
Created attachment 142245 [details]
Sample file.

1. Open the attached file that contains a simple formula.
2. Use "Save as" (Ctrl+Shift+s) the file as odt document.

Actual result: there is a temporary file ( something like lu5420hvp2hf.tmp ) left in the same directory.
Expected result: Writer should remove temporary files as soon as the document saved.

Note: if user just modifies the content and use "Save" ( Ctrl + s ) to save the file instead of using "Save as" ( Ctrl + Shift + s), there is no temporary file left.
Comment 1 Mark Hung 2018-05-23 11:49:36 UTC
Verified with:
Version: 6.1.0.0.alpha1+ (x64)
Build ID: 0e8d2cb6b7af441642ffe3e94cfccb526fb12b49
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: zh-TW (zh_TW); Calc: group

Open up a new issue per comment#11 of tdf#117225.
Comment 2 Xisco Faulí 2018-05-29 13:06:16 UTC
I guess we can close this as a dupe of bug 117225

*** This bug has been marked as a duplicate of bug 117225 ***
Comment 3 Xisco Faulí 2018-05-29 13:09:21 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-01-17 18:11:41 +0100
committer	Julien Nabet <serval2412@yahoo.fr>	2018-01-18 07:12:42 +0100
commit	27938e1bbd5f3405c47b9933be7489eeb03920f3 (patch)
tree	792f4df230b6364ef8eb578e647454648e2afd62
parent	c915fdbfc77ac78d543bc097cd809edd7e6da8cb (diff)
sfx2 store: create temp files next to local files (storage case)
This is similar to commit 5259ab8104cfba60c40748ed0cd59d93df038c5b (sfx2
store: create temp files next to local files, 2018-01-08), except there
only the stream case was handled (e.g. sw HTML export), while this is
the storage case (e.g. ODT export).

Bisected with: bibisect-win32-6.1

Adding Cc: to Miklos Vajna
Comment 4 Miklos Vajna 2018-06-26 12:49:14 UTC
Can reproduce on Windows only, will take a look.
Comment 5 Commit Notification 2018-07-03 10:00:31 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8fd1a814ffc80f2802c5b980febabcffe9606cb

tdf#117757 sfx2 save-as: fix leftover temporary files for embedded objects

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2018-07-03 11:58:11 UTC
*** Bug 117758 has been marked as a duplicate of this bug. ***
Comment 7 Miklos Vajna 2018-07-03 12:07:04 UTC
*** Bug 117759 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-07-03 15:59:10 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d4e41009c42b26d318af20ac1e2da301212c1cf&h=libreoffice-6-1

tdf#117757 sfx2 save-as: fix leftover temporary files for embedded objects

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.