Bug 117759 - Create new odt file containing formula leaves temporary file.
Summary: Create new odt file containing formula leaves temporary file.
Status: RESOLVED DUPLICATE of bug 117757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-05-23 12:02 UTC by Mark Hung
Modified: 2018-07-03 12:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2018-05-23 12:02:02 UTC
1. Create a new text document in Writer.
2. Insert / Object / Formula to insert a formula into the document.
3. Use "Save" (Ctrl+S) to save the document as odt file.

Actual result: there is a temporary file ( something like lu5420hvp2hf.tmp ) left in the same directory.
Expected result: Writer should remove temporary files as soon as the document saved.

Note: Open up a new issue per comment#11 of tdf#117225.

Verified with:
Version: 6.1.0.0.alpha1+ (x64)
Build ID: 0e8d2cb6b7af441642ffe3e94cfccb526fb12b49
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: zh-TW (zh_TW); Calc: group
Comment 1 raal 2018-05-28 05:03:48 UTC
I can not confirm with Version: 6.2.0.0.alpha0+
Build ID: c0fbf99e5601da27c59d131bcca24fafd259e508
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 2 raal 2018-05-28 05:25:22 UTC
I can confirm with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 6c896485c006f8492310441b4e6861db09a4b7a8
CPU threads: 1; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-05-26_23:24:38

regression in 6.1
Comment 3 Aron Budea 2018-05-28 06:10:28 UTC
Originates from the same commit as mentioned in bug 117225 comment 3.
Comment 4 Xisco Faulí 2018-06-05 21:09:29 UTC
Adding Cc: to Miklos Vajna
Comment 5 Miklos Vajna 2018-07-03 12:07:04 UTC
Now that bug 117757 is fixed, I see that the same fix helps here as well. Which makes sense, saving a new doc is the same codepath as save as.

*** This bug has been marked as a duplicate of bug 117757 ***