Bug 118728 - CRASH: Problem with mailing function
Summary: CRASH: Problem with mailing function
Status: RESOLVED DUPLICATE of bug 117480
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Jean-Sebastien Bevilacqua
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 121951 (view as bug list)
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-07-12 14:26 UTC by Jean-Sebastien Bevilacqua
Modified: 2019-01-18 08:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
exchange_database_file (10.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-07-12 14:26 UTC, Jean-Sebastien Bevilacqua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sebastien Bevilacqua 2018-07-12 14:26:16 UTC
Created attachment 143521 [details]
exchange_database_file

Hello,
When I try to print in a file from a mailing document, LibreOffice crashes.

Step to reproduce:

1 - Open Writer and go to Edit > Exchange Database
2 - Browse the database donnees.ods (joined) and add it
3 - Go to View > Data Sources and unroll donnees > Tables and click on Feuille1
4 - Select each column and drag it to the writer document
5 - Go to File > Print (click yes when the popup appears)
6 - Set the output to File and save the document

The crash appears.

I reproduced this crash with gdb and I got this error just before the crash:

warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_addressbooksource.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeprintdocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergesavedocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergecreatedocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeemaildocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeexcludeentry.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergecurrententry.png' from icon theme 'elementary'
warn:ucb.ucp.gio:2486:2486:ucb/source/ucp/gio/gio_content.cxx:392: ignoring GError "Operation not supported" for <>
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_addressbooksource.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeprintdocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergesavedocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergecreatedocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeemaildocuments.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergeexcludeentry.png' from icon theme 'elementary'
warn:fwk.uiconfiguration:2486:2486:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_mailmergecurrententry.png' from icon theme 'elementary'
warn:svx.fmcomp:2486:2486:svx/source/fmcomp/fmgridcl.cxx:1898: N3com3sun4star3uno9ExceptionE
warn:vcl:2486:2486:vcl/source/app/salusereventlist.cxx:114: Uncaught com.sun.star.lang.DisposedException 

Thread 1 "soffice.bin" received signal SIGABRT, Aborted.
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
51	../sysdeps/unix/sysv/linux/raise.c: Aucun fichier ou dossier de ce type.
(gdb) c
Continuing.
warn:vcl:2486:2486:vcl/source/window/dialog.cxx:864: Dialog::StartExecuteModal() - Parent not visible
warn:sfx.view:2486:2486:sfx2/source/view/viewfrm.cxx:3047: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
[Thread 0x7fffd1f29700 (LWP 4033) exited]
[New Thread 0x7fffd1f29700 (LWP 4043)]
warn:sfx.view:2486:2486:sfx2/source/view/viewfrm.cxx:3047: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
[Thread 0x7fffd1f29700 (LWP 4043) exited]
[Thread 0x7fffc8ac4700 (LWP 3967) exited]


This problem exists on master.
Comment 1 Jean-Sebastien Bevilacqua 2018-07-12 14:40:46 UTC
Bisection:

5.4.7.2 -> No bug
6.0.0.0.alpha -> Bug
All version above 6 and master  -> Bug
Comment 2 Jean-Sebastien Bevilacqua 2018-07-12 14:42:02 UTC
Maybe related to this: https://bugs.documentfoundation.org/show_bug.cgi?id=108572

I am reverting the patch to confirm.
Comment 3 Aron Budea 2018-07-13 03:15:00 UTC
You didn't list the latest commit hash you reproduced the crash with, but if it's earlier than 07-05, I'd give it a try with a fresher build, see bug 116543.

Backtrace information is rather limited as well, these steps should provide more extensive backtrace: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 4 Xisco Faulí 2018-07-13 09:10:10 UTC
Most likely, a dupe of bug 116543.

Please reopen it if you can still reproduce it in the latest version

*** This bug has been marked as a duplicate of bug 116543 ***
Comment 5 Jean-Sebastien Bevilacqua 2018-07-16 10:45:14 UTC
Bug is still present on master
Comment 6 Jean-Sebastien Bevilacqua 2018-07-16 10:48:08 UTC
I did a bisection and this commit creates the bug:
97477ee5e11951a5a25a91b89f1b71a1b78ac8f5
Comment 7 Xisco Faulí 2018-07-16 12:50:55 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: dbf8ad9bc385411c349095dfa66345464b4215d6
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 8 Xisco Faulí 2018-07-16 12:58:11 UTC
@Mike, this issue is similar to bug 116543, I thought you could be interested...
Comment 9 Jean-Sebastien Bevilacqua 2018-08-10 14:52:30 UTC
I wrote a patch that fixes it: https://gerrit.libreoffice.org/#/c/58837/
Comment 10 Aron Budea 2018-08-11 21:52:11 UTC
(In reply to Jean-Sebastien Bevilacqua from comment #9)
> I wrote a patch that fixes it: https://gerrit.libreoffice.org/#/c/58837/
Thanks for taking a stab at this, Jean-Sebastien! Unfortunately as far as I can see this patch brings back bug 108572. Is there a chance the fixed behavior could be preserved?
Comment 11 Jean-Sebastien Bevilacqua 2018-08-13 15:22:26 UTC
Thanks M. Budea for noticing this regression.
We should wait for Mike Kaganski which knows this better than me.

JS
Comment 12 Xisco Faulí 2018-11-12 12:45:50 UTC
Still reproducible in

Versión: 6.1.3.2
Id. de compilación: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

(In reply to Jean-Sebastien Bevilacqua from comment #11)
> Thanks M. Budea for noticing this regression.
> We should wait for Mike Kaganski which knows this better than me.
> 
> JS

@Mike Kaganski, any chance you could take a look at this issue after you fixed bug 116543 ?
Comment 13 Julien Nabet 2018-12-16 19:16:57 UTC
*** Bug 121951 has been marked as a duplicate of this bug. ***
Comment 14 Xisco Faulí 2019-01-07 11:10:57 UTC
It no longer crashes in

Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

after https://git.libreoffice.org/core/+/92edea090128839f54a7f628662529e66d657ab4%5E%21
but the output file is blank...
Closing as a duplicate of bug 117480

*** This bug has been marked as a duplicate of bug 117480 ***