Bug 118751 - FIREBIRD: Firebird support is available by default with version 6.1RC
Summary: FIREBIRD: Firebird support is available by default with version 6.1RC
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.1.0.2 target:6.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-13 18:02 UTC by Drew Jensen
Modified: 2018-08-16 12:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-07-13 18:02:16 UTC
Description:
The firebird support should not be available unless experimental features are enabled via the options dialog.

checked using Ubuntu 18.04 (64bit) version:
Version: 6.1.0.1.0+
Build ID: ff0e7e5427c2851341d01e8917a1b5df0c08e557
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-07-13_10:25:46
Locale: en-US (en_US.UTF-8); Calc: group threaded


Steps to Reproduce:
1. Start Libo 6.1 from a clean install, or ensure that experimental features are disabled in options.
2. Open an ODB with a firebird sdbc database.
3. 

Actual Results:
The firedbird data engine is available.

Expected Results:
The firebird data engine should not be available.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-07-14 11:23:30 UTC
Done only for 6-1 branch: https://gerrit.libreoffice.org/#/c/57429/1
Comment 2 Commit Notification 2018-07-18 13:39:31 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88abae93c5e0a030eca36d7e33909ad52e1c71a2&h=libreoffice-6-1

tdf#118751: Revert "tdf#117081: show Firebird by default"

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 robert 2018-07-30 14:17:08 UTC
I have tested exactly this with LO 6.1.0.2 and written down it in bug 119003.

If the Firebird dataengine isn't available - why could one open an existing internal Firebird database without any problems?

Remember: Experimental features are "off", but database could be opened, but not created.
Comment 4 Drew Jensen 2018-07-30 14:23:55 UTC
(In reply to robert from comment #3)
> I have tested exactly this with LO 6.1.0.2 and written down it in bug 119003.
> 
> If the Firebird dataengine isn't available - why could one open an existing
> internal Firebird database without any problems?
> 
> Remember: Experimental features are "off", but database could be opened, but
> not created.

Yup.
Comment 5 Drew Jensen 2018-07-30 14:51:48 UTC
To be clear using 6.0.5 when experimental features are not engaged and attempting to open a fb embedded/file Base file generates the following error:

SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the URL 'sdbc:embedded:firebird'.
Comment 6 Xisco Faulí 2018-07-30 17:05:47 UTC
> If the Firebird dataengine isn't available - why could one open an existing
> internal Firebird database without any problems?

the firebird dataengine is available and embedded in 6.1. The commit above just hides the option when creating a new database.

Would you prefer to show error instead of opening the firebird database if you can open it? Personally I find it alright as it's in 6.1 right now, IMHO, it should be left as it's and this closed as RESOLVED FIXED
Comment 7 robert 2018-07-30 17:35:27 UTC
We can't say "HSQLDB is deprecated" and won't offer a normal possibility to create more Firebird databases. So if we want to push Firebird we have to offer the creating of new Firebird databases.

When we say "HSQLDB is our standard" we should leaf it as it is with this patch. Firebird-users won't recognize the creating of a new Firebird-database isn't there .

The wizard for migrating from HSQLDB to Firebird is the one, which must be experimental, because the wizard mostly can't create a working database yet.
Comment 8 Drew Jensen 2018-07-30 18:24:27 UTC
(In reply to robert from comment #7)
> We can't say "HSQLDB is deprecated" and won't offer a normal possibility to
> create more Firebird databases. So if we want to push Firebird we have to
> offer the creating of new Firebird databases.
> 
> When we say "HSQLDB is our standard" we should leaf it as it is with this
> patch. Firebird-users won't recognize the creating of a new
> Firebird-database isn't there .
> 
> The wizard for migrating from HSQLDB to Firebird is the one, which must be
> experimental, because the wizard mostly can't create a working database yet.

One point - deprecated doesn't mean removed. 

Otherwise - (In reply to Xisco Faulí from comment #6)
> > If the Firebird dataengine isn't available - why could one open an existing
> > internal Firebird database without any problems?
> 
> the firebird dataengine is available and embedded in 6.1. The commit above
> just hides the option when creating a new database.
> 
> Would you prefer to show error instead of opening the firebird database if
> you can open it? Personally I find it alright as it's in 6.1 right now,
> IMHO, it should be left as it's and this closed as RESOLVED FIXED

The only reason for opening this issue was because of the ESC decision to roll it back to experimental and I expected that meant the behavior would be consistent with 5.4 and 6.0. 

Anyway, my mistake for marking it verified in the first place on just a test of whether the create new db function was turned off.

So, just now I took a fb file in 6.1 and created two new tables, created indexes and a relationship, created a query, created a form and report based on the query, ran the report and used the odb to feed a calc sheet with drag drop from the beamer window and a writer file using it as the datasource for a mail merge. All worked as I would expect with 6.1. So the only features not available with experimental features turned off are the ability to create a new fb based ODB and run the migration assistant.

5.4 and 6.0 of course can not open these files without experimental enabled, 6.1 can but not the features above, and 6.2 (at this point at least) doesn't need experimental enabled at all.

As for consistency, there are four different versions of the application on my machine that 'support' firebird (5.4, 6.0, 6.1 and 6.2) and each one seems to offer slightly different feature set support, yet all four report an sdbc driver version of 1.0 and if that can be true I suppose having experimental mean different things in different versions is no big deal.

Finally I guess, there are nine days to release and the pre-release marketing has already kicked off with that as a hard date.

So, will put it back to resolved and make a mention in the release notes.
Comment 9 Mike Kaganski 2018-08-15 19:49:38 UTC
Hey, this all is a huge mess. ESC has *never* decided to get FB back to experimental - it only decided to make *migration assistant* experimental, and revert removal of HSQLDB support. The plan was to make FB not experimental for 6.1, which would start wider testing, but not force people to convert their existing DBs; and - OK, let HSQLDB be the *default* choice in the new embedded DB wizard. But filing and "fixing" this bug, the dialog got rid of the FB option, thus making the whole FB effectively "experimental" again for another half a year (despite the engine is already available, without a UI to create, it's ~useless).

The 6.1 release notes include (rightfully!) a reference to bug 117081 to designate the non-experimental status of FB; please revert the revert to make it all good!
Comment 10 Drew Jensen 2018-08-15 20:22:32 UTC
(In reply to Mike Kaganski from comment #9)
> Hey, this all is a huge mess. ESC has *never* decided to get FB back to
> experimental - it only decided to make *migration assistant* experimental,
> and revert removal of HSQLDB support. The plan was to make FB not
> experimental for 6.1, which would start wider testing, but not force people
> to convert their existing DBs; and - OK, let HSQLDB be the *default* choice
> in the new embedded DB wizard. But filing and "fixing" this bug, the dialog
> got rid of the FB option, thus making the whole FB effectively
> "experimental" again for another half a year (despite the engine is already
> available, without a UI to create, it's ~useless).
> 
> The 6.1 release notes include (rightfully!) a reference to bug 117081 to
> designate the non-experimental status of FB; please revert the revert to
> make it all good!

If support is on from default then the ability to create new files should be on by default, your right it doesn't make sense not to do that.
Comment 11 Xisco Faulí 2018-08-16 08:31:13 UTC
Reverted in https://gerrit.libreoffice.org/#/c/59158/
Comment 12 Drew Jensen 2018-08-16 11:26:19 UTC
(In reply to Mike Kaganski from comment #9)
> Hey, this all is a huge mess. ESC has *never* decided to get FB back to
> experimental - it only decided to make *migration assistant* experimental,
> and revert removal of HSQLDB support. The plan was to make FB not
> experimental for 6.1, which would start wider testing, but not force people
> to convert their existing DBs; and - OK, let HSQLDB be the *default* choice
> in the new embedded DB wizard. But filing and "fixing" this bug, the dialog
> got rid of the FB option, thus making the whole FB effectively
> "experimental" again for another half a year (despite the engine is already
> available, without a UI to create, it's ~useless).
> 
> The 6.1 release notes include (rightfully!) a reference to bug 117081 to
> designate the non-experimental status of FB; please revert the revert to
> make it all good!

Mike,

One thing I will take issue with though. It isn't more testing needed for the Firebird implementation it is more coding - can't test what isn't there.
Comment 13 Commit Notification 2018-08-16 12:42:31 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c957c5a4a0d3f621087b6dab468caaa4ed1a3e39&h=libreoffice-6-1

Revert "tdf#118751: Revert "tdf#117081: show Firebird by default""

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.