Bug Hunting Session
Bug 119127 - LibreOffice hangs reopening the "Select Firefox Theme" for a second time
Summary: LibreOffice hangs reopening the "Select Firefox Theme" for a second time
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Muhammet Kara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2018-08-06 15:29 UTC by Telesto
Modified: 2018-10-08 11:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-06 15:29:39 UTC
Description:
LibreOffice hangs reopening the "Select Firefox Theme" for a second time (follow up of bug 117866)

Steps to Reproduce:
1. Launch LibreOffice;
2. Start a new Writer document;
3. Open the "Select Firefox Theme":
     - Open the "Tools" menu;
     - Select "Options...";
     - Expand the "LibreOffice" section in the tree;
     - Select the "Personlisation" item in the tree;
     - Click the "Select Theme" button.
4. You will see the "Select Firefox Theme" dialog, with 9 gray rectangles,
which are used to display theme previews;
5. Click one of the categories - e.g. "Abstract";
6. LibreOffice will start loading and showing theme previews in those gray
rectangles;
7. Click the "Cancel" button (without waiting for a theme)
8. Press the Select Theme button again -> hang
 
Alternative
7. Click the "OK" button (without waiting for a theme) -> Hang

Actual Results:
Hang

Expected Results:
No hang


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 1b21ff86effe58ae368457de8fec654ba4c8edd9
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-30_03:13:35
Locale: en-US (nl_NL); Calc: CL
Comment 1 Xisco Faulí 2018-08-06 16:16:17 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 4804a1474ccba8df57f0a0151bd69237e82eb618
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 2 Xisco Faulí 2018-08-06 16:33:13 UTC
In

Version: 6.2.0.0.alpha0+
Build ID: 921f285c7ff713ad219d3e3385d7e7d12d33581e
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

it hangs when the Select Theme is closed, but only for 10 seconds approximately... then, it's fine...
Comment 3 Joao Farias 2018-08-07 20:51:20 UTC
I can confirm that it just hangs for a few seconds on Windows 10.

Telesto, could you confirm if you are experience a permanent freezing or just for a few seconds as well? If it´s the second case, you can close the bug.

Version: 6.1.0.2 (x64)
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 4 Telesto 2018-08-08 12:04:24 UTC
The Mozilla theming site is very slow for me (probably location depended). So it will work eventually (but far from perfect). 

However lets assume worst case. Mozilla site is down or internet access is filtered/blocked by a firewall. LibO will not respond.
Comment 5 Xisco Faulí 2018-08-08 13:35:30 UTC
Another approach would be to check if the backend work, and if not, close the dialog and show a message...

UX Team, what do you think ?
Comment 6 Heiko Tietze 2018-08-16 11:31:55 UTC
Is this a dup of bug 118881?
Comment 7 Telesto 2018-08-16 12:13:14 UTC
(In reply to Heiko Tietze from comment #6)
> Is this a dup of bug 118881?

This not a dupe of bug 118881. Bug is more a less an example. 
1. Prior to bug 118881 previews did load, but in my case very slowly
2. Instead of waiting I would close the dialog and reopen it again (maybe this the is better). However, the theming dialog won't respond (and hang), because the theming backend is still processing the first attempt in the background. This can be problematic if the Mozilla site is down, slow responding or without any existing connection because of a firewall blocking it.

Closing the theming dialog should abort the preview downloading process instead of still processing it the background

Xisco is (additionally?) suggestion a dialog for connection issues
Comment 8 Telesto 2018-08-19 09:48:31 UTC
The unresponsiveness/connection aspect is probably a more general issue, when looking at: bug 45307, bug 43338, bug 91237
Comment 9 Heiko Tietze 2018-08-29 18:22:52 UTC
(In reply to Xisco Faulí from comment #5)
> Another approach would be to check if the backend work, and if not, close
> the dialog and show a message...
> 
> UX Team, what do you think ?

Don't think it's a solution. The user should always get a precise feedback what's going on and how long she has to wait for data. At least we have to show the names and allow to load a theme ignoring the thumbnail.

No idea how to set the status.
Comment 10 Heiko Tietze 2018-10-08 09:13:10 UTC
Personas have been reworked by Muhammet and greatly improved in https://gerrit.libreoffice.org/#/c/61449/. Thumbnails are not only retrieved fast enough but also cached. So I'm closing this ticket as fixed.