Download it now!
Bug 119129 - Installation and Startup options - Quickstarter and Desktop shortcut seem backward.
Summary: Installation and Startup options - Quickstarter and Desktop shortcut seem bac...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Quickstarter
  Show dependency treegraph
 
Reported: 2018-08-06 18:51 UTC by Steven Lee
Modified: 2019-02-13 18:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Lee 2018-08-06 18:51:52 UTC
Description:
The defaults in the LibreOffice installation are not set appropriately. This is especially true for the Windows environment. 

I install LibreOffice on most of my client machines, almost all of the servers I work on, and specifically for those folks who don't have access to expensive alternatives. 

It seems to me that some of the setup options are backwards. 

"Create a start link on desktop" should be unchecked. Windows users don't want or need, and more importantly don't use an Office front end application. They tend to use the applications themselves. They also tend to use Windows File Explorer for file management. Only complete novices have any need an Office front end. 

The default installation, and the custom installation have, "Create a start link on the desktop" checked. 

The next thing that seems to be backwards is, "Load LibreOffice <Version number> during system start-up" 

It is unchecked by default. It should be checked. LibreOffice starts up a great deal faster when this is checked. The icon should be available in the System Tray (Windows), automatically. 

This seems backwards to me, as anything that makes a program faster and more responsive should be done automatically, instead of not at all. 

Even after this option is checked, it frequently isn't turned on within the program. After a LibreOffice program is started, it is necessary to go to Tools, and Options, General, and then re-check, "Load LibreOffice during system start-up" before this function sticks. Perhaps it's possible to run Writer, for example, at the end of the installation and make sure that this feature is set to on, rather than off. 

After setting this option during the installation, and then opening a LibreOffice program, and then setting the option again, it still doesn't take until after you close the LibreOffice program and then open it again. 

This should be completely automatic, selected by default, and only turned off if a user wants to do so. 




Steps to Reproduce:
1.Install LibreOffice
2.It happens backwards every time.
3.

Actual Results:
This happens all the time. The installation values are backwards. 

Expected Results:
I expect it to happen backwards and it does, rather reliably. 


Reproducible: Always


User Profile Reset: No



Additional Info:
As described previously.
Comment 1 V Stuart Foote 2018-08-07 04:10:39 UTC
Thank you, but just no... Quickstarter was removed from the lInux builds and was  never implemented on macOS builds. So it is a Windows only hack that followed Microsoft's OSA launcher that was dropped with Office 2003.

I've long argued as have others, that Win7+ jump list structure is superior implementation and that the Quickstarter should be removed from Windows builds.

We've kicked it around for years, but I do not see *this* change to the Windows installer as at all desirable. Conversely, I on all my Windows client installations, disable the Quickstarter with a custom installation and set proper Start menu and Task bar pinnings.

For me a clear => WF

=-ref-=

bug 116142

bug 116694
Comment 2 Tor Lillqvist 2018-08-07 06:04:48 UTC
What is an "Office front end application"?
Comment 3 Timur 2018-08-07 08:56:01 UTC
Stuart, you wrote FM but set NEW, please explain why. 
There are 2 requests here. 
I don't agree with reasoning that "Create a start link on desktop" should be unchecked. Personally I use taskbar shortcut for LO but point is I want to start LO often and than choose document. 
I could agree that "Load LibreOffice <Version number> during system start-up" could be checked, but it's up to user. For deployed installation, you can set it administratively. We have Bug 35568 here. Unlike Stuart, I'm in favor of QuickStart because I have in mind older computers.
Comment 4 V Stuart Foote 2018-08-07 12:07:05 UTC
(In reply to Timur from comment #3)
> Stuart, you wrote FM but set NEW, please explain why. 

New because it is an enhancement, and not completely unreasonable. We allow that, but rather than a heavy handed WF to start--I mark the Blocking and See alsos and allow the discussion to take its course.

Otherwise, my position remains unchanged. Up to an intrepid dev to finally kill this off.
Comment 5 V Stuart Foote 2019-02-13 18:42:06 UTC
No movement => WF