Bug 119173 - Unresponsiveness toggling back from Print Preview to normal view in a document with a lot of comments
Summary: Unresponsiveness toggling back from Print Preview to normal view in a documen...
Status: RESOLVED DUPLICATE of bug 119340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 119131 (view as bug list)
Depends on:
Blocks: Writer-Comments CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-08-09 11:22 UTC by Telesto
Modified: 2018-09-05 07:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (12.37 KB, application/vnd.oasis.opendocument.text)
2018-08-09 11:23 UTC, Telesto
Details
Bibisect log (3.56 KB, text/plain)
2018-08-11 14:51 UTC, Telesto
Details
Second example (16.75 KB, application/vnd.oasis.opendocument.presentation)
2018-08-11 16:13 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-09 11:22:44 UTC
Description:
Unresponsiveness toggling back from Print Preview to normal view

Steps to Reproduce:
1. Open the attached file
2. Switch to Print Preview
3. Switch back to normal view (monitor CPU usage)

Actual Results:
Processing time has increased

Expected Results:
Same as with 6.0


Reproducible: Always


User Profile Reset: No



Additional Info:
Repro with
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: nl-NL (nl_NL); Calc: CL

no repro with
Version: 6.0.0.1.0+
Build ID: 47cc374c0659fd3db74a1b184c870eaa56bc385b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-08-09 11:23:00 UTC
Created attachment 144059 [details]
Example file
Comment 2 Telesto 2018-08-11 14:51:06 UTC
Created attachment 144107 [details]
Bibisect log

Bisected to
author	Jan-Marek Glogowski <glogow@fbihome.de>	2018-07-09 09:06:55 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2018-07-09 22:11:35 +0200
commit	fad862e290d727fc9fefe206f6e4b807482c4175 (patch)
tree	5195c1277fce198e5b69d552e9209665d8007faf
parent	9d754a59154c40235c240bb0e7f47a2006fa85bd (diff)
tdf#118555 fix HFONT fallback handing / lifecycle
Instead of storing the never changing DC in the WinFontInstance
store the HFONT, which is Windows logical font instance.

Then set the correct HFONT instance from the layout when rendering
its text.

This also changes the HFONT ownership and lifecycle. The HFONT
is moved from the mhFonts to the WinFontInstance, if available,
so it has a proper referenced lifecycle. The mhFonts is still
needed, as embedded font just supply an HFONT and no
WinFontInstance.
Comment 3 Telesto 2018-08-11 16:13:38 UTC
Created attachment 144111 [details]
Second example

Another example
1. Open the attached Impress Presentation
2. File opening time has doubled (from 6 to 12 seconds give or take) (bisected to the same commit)
Comment 4 Telesto 2018-08-11 21:46:35 UTC
*** Bug 119131 has been marked as a duplicate of this bug. ***
Comment 5 Dieter 2018-08-23 09:25:57 UTC
I confirmn it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL

much better in

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 6 Telesto 2018-08-23 09:57:39 UTC
adding Cc: to Jan-Marek Glogowski

Three cases:
1. Comment 0 (confirmed) - Unresponsiveness toggling back from Print Preview
2. Comment 3 (unconfirmed) - Slow file opening
3. Bug 119438 (unconfirmed) - Slowdown in paste/undo
Comment 7 Telesto 2018-09-05 07:01:21 UTC

*** This bug has been marked as a duplicate of bug 119340 ***