Bug 119438 - Slow pasting & cursor lags behind at undo
Summary: Slow pasting & cursor lags behind at undo
Status: RESOLVED DUPLICATE of bug 119340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-08-23 08:01 UTC by Telesto
Modified: 2018-09-05 06:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file (14.45 KB, application/vnd.oasis.opendocument.text)
2018-08-23 08:01 UTC, Telesto
Details
Bibisect log (3.23 KB, text/plain)
2018-08-23 08:02 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-23 08:01:09 UTC
Description:
Slow pasting & cursor lags behind at undo

Steps to Reproduce:
1. Open the attached file
2. Select two bullets points (including the content) and copy them
3. Paste them in the empty cell (holding CTRL+V). Bit laggy
4. Undo CTRL+Z (content will disappear slowly)

Actual Results:
Slowdowns

Expected Results:
Fast & responsive


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-20_22:43:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-08-23 08:01:50 UTC
Created attachment 144380 [details]
Sample file
Comment 2 Telesto 2018-08-23 08:02:06 UTC
Created attachment 144381 [details]
Bibisect log

Bisected to
author	Jan-Marek Glogowski <glogow@fbihome.de>	2018-07-09 09:06:55 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2018-07-09 22:11:35 +0200
commit fad862e290d727fc9fefe206f6e4b807482c4175 (patch)
tree 5195c1277fce198e5b69d552e9209665d8007faf
parent 9d754a59154c40235c240bb0e7f47a2006fa85bd (diff)
tdf#118555 fix HFONT fallback handing / lifecycle
Instead of storing the never changing DC in the WinFontInstance
store the HFONT, which is Windows logical font instance.

Then set the correct HFONT instance from the layout when rendering
its text.

This also changes the HFONT ownership and lifecycle. The HFONT
is moved from the mhFonts to the WinFontInstance, if available,
so it has a proper referenced lifecycle. The mhFonts is still
needed, as embedded font just supply an HFONT and no
WinFontInstance.
Comment 3 Telesto 2018-08-23 08:04:30 UTC
Separate report, combining bugs in one bug report related to the same commit isn't working to well
Comment 4 Xisco Faulí 2018-08-29 16:53:23 UTC
Adding Cc: to Jan-Marek Glogowski
Comment 5 Jan-Marek Glogowski 2018-08-29 17:22:31 UTC
Please retest with current master if the fixes for bug 119458 help here too.

At least I can't reproduce directly.

Now I don't have OpenGL on Windows, so it can be an other problem.
Comment 6 Telesto 2018-08-29 20:35:04 UTC
(In reply to Jan-Marek Glogowski from comment #5)
> Please retest with current master if the fixes for bug 119458 help here too.
> 
> At least I can't reproduce directly.
> 
> Now I don't have OpenGL on Windows, so it can be an other problem.

I do still reproduce this
Version: 6.2.0.0.alpha0+
Build ID: 22f2d8c41aa0a0a4cfa215c07ec06ae38cde7da8
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-29_04:32:58
Locale: nl-NL (nl_NL); Calc: CL

However, root cause is probably the same as bug 119340 or bug 119173.
Comment 7 Telesto 2018-09-05 06:59:29 UTC
No repro with
Version: 6.2.0.0.alpha0+
Build ID: 5e8fd488f17fe0433cc9b31ace6527fb06ea3bb0
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-05_02:20:05
Locale: pl-PL (nl_NL); Calc: CL

*** This bug has been marked as a duplicate of bug 119340 ***