Bug 119338 - Paragraph borders are non-continuous on paragraphs with paragraph spacing
Summary: Paragraph borders are non-continuous on paragraphs with paragraph spacing
Status: RESOLVED DUPLICATE of bug 115296
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Borders Paragraph-Line-Spacing Paragraph-Spacing
  Show dependency treegraph
 
Reported: 2018-08-18 03:27 UTC by Philip Rayment
Modified: 2018-08-20 16:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Rayment 2018-08-18 03:27:09 UTC
Description:
When formatting in Writer, when left and/or right paragraph borders are applied to a groups of paragraphs that also have space above/below (of more than a trivial amount at least), the borders are non-continuous, unlike previous versions.

Steps to Reproduce:
1. Write two or more paragraphs of text 
2. Select all paragraphs, the use Format>Paragraph>Borders>set all borders or left and/or right borders
3. With the same paragraphs, use Format>Paragraphs>Indents & Spacing>Spacing above or below> set to, say, 0.10"

Actual Results:
The vertical borders are non-continuous; they have gaps between the paragraphs.

Expected Results:
The vertical borders should have been continuous.


Reproducible: Always


User Profile Reset: No



Additional Info:
I upgraded from version 6.0.5.2, because of the bug where F11 wouldn't open the styles windows (actually it flashed open then closed again).
Comment 1 Dieter 2018-08-18 07:31:43 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL

but not with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Regina Henschel 2018-08-18 17:41:29 UTC
That is likely duplicate to bug 115296. See also the bugs listed there as duplicate.
Comment 3 Dieter 2018-08-19 10:37:01 UTC
(In reply to Regina Henschel from comment #2)
> That is likely duplicate to bug 115296. See also the bugs listed there as
> duplicate.

Could be, but ten we should change the summary of bug 115296. I hope, this bug can be fixed soon, because I assume it is usual to ad borders to several paragraphs. So a lot of people will run in troubles if they change to LO 6.1
Comment 4 Xisco Faulí 2018-08-20 16:06:54 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=1d86f43a10f097aa4925bd48870477001098f5ff which is the same as in bug 115296.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 115296 ***