Bug 119415 - Browser-based help search feature does not honor the "module" drop-down (local offline)
Summary: Browser-based help search feature does not honor the "module" drop-down (loca...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.3.0 target:6.2.0.1
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-08-22 05:30 UTC by Jim Avera
Modified: 2018-11-22 17:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Suggestion: placeholder inside input (4.77 KB, image/png)
2018-11-16 17:09 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2018-08-22 05:30:49 UTC
Description:
The online documentation has a drop-down to select a "module" (Writer, Calc, etc.) but it appears to have no effect on what the Index search box returns.  As a result, searches return many confusing & irrelevant hits.

In particular, getting help for Calc features is difficult because searches return hits for Writer, and they appear first.

STEPS TO REPRODUCE:

1. Start Calc using a development build, then Help->LibreOfficeDev Help
to open the online documentation.

On my system, this opens file:///home/admin/lotest/6.1.1.0.0/opt/libreofficedev6.1/help/en-US/text/scalc/main0000.html

2. Click the "Module" drop-down and select "Calc"

3. Type "moving" into the search box. 

RESULTS: 
  A long list of stuff is shown under a "WRITER" heading.  Then (have to scroll down) there is a "CALC" heading followed by only two hits, both of which go to "Move or Copy a Sheet".  That's it.

EXPECTED RESULTS:
  Similar to what you get when using offline help (same information, possibly different formatting).   Using v6.0.3.2, searching for "moving" in offline help returns these as the first hits:
   cell, rows and columns by drag and drop
   spreadsheets
   tab stops on ruler
   toolbars
   using guide lines in presentations
   visible cells only

None of these appear in online help search results for Calc except "spreadsheets".

Steps to Reproduce:
.

Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Jim Avera 2018-08-22 17:05:07 UTC
Hrm... I didn't notice that it opens a LOCAL file in my browser (file://<installdir>/help/en-US/text/scalc/main0000.html)

So it is not online help after all, but local offline help which now seems to be implemented with html viewed in the user's browser.

This is a MUCH more serious problem, if this is the production help system users will see!   It is virtually unusable for finding Calc help.

I changed the bug title to "Browser-based help..." instead of "Online...".
Comment 2 Commit Notification 2018-11-09 20:15:09 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/9fb9990b3568c973cc41d5600492e0791e44d40a%5E%21

tdf#119415 change from fuse.js to fuzzysort.js
Comment 3 Commit Notification 2018-11-15 12:56:58 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/7e2a609f6d78d91c43ddaf76247c95668f402d06%5E%21

tdf#119415 Revert string change
Comment 4 Buovjaga 2018-11-15 13:17:24 UTC
Now we have a problem: how to communicate to the users that the filter is tied to the module category. Translations make the string too long, if added above the search box. Same problem with adding a placeholder text inside the search box.

Jim: how do you propose to solve the problem?
Comment 5 Jim Avera 2018-11-16 01:00:29 UTC
I don't understand the problem about translations.  Which field gets too long?

But really, there would not be such a big problem if each application (Writer, Calc, etc.) just started help already filtered for that application.   So in Calc, you would not get all those Writer hits first (preferably non-Calc help would not be offered *at all* in Calc, but that's a bigger problem).

For example, in Calc, Help should open 
   <instdir>/help/<lang>/text/scalc/main0000.html 
straightaway, not
   <instdir>/help/en-US/text/scalc/main0000.html
as is currently the case (in master).


In summary: Make Help in each application only show help related to that application, or failing that, pre-configure the search mechanism to show app-related hits first.

I don't think this is "FIXED" yet.
Comment 6 Buovjaga 2018-11-16 08:25:50 UTC
(In reply to Jim Avera from comment #5)
> I don't understand the problem about translations.  Which field gets too
> long?
> 
> But really, there would not be such a big problem if each application
> (Writer, Calc, etc.) just started help already filtered for that
> application.   So in Calc, you would not get all those Writer hits first
> (preferably non-Calc help would not be offered *at all* in Calc, but that's
> a bigger problem).
> 
> For example, in Calc, Help should open 
>    <instdir>/help/<lang>/text/scalc/main0000.html 
> straightaway, not
>    <instdir>/help/en-US/text/scalc/main0000.html
> as is currently the case (in master).
> 
> 
> In summary: Make Help in each application only show help related to that
> application, or failing that, pre-configure the search mechanism to show
> app-related hits first.
> 
> I don't think this is "FIXED" yet.

Oh, this is fixed alright and you can verify it by testing at https://helponline.libreoffice.org/6.2/
Global (Shared) results are always included in the results of every module, but otherwise the results are now limited based on the url fragment text/module/

At first, the "Index" text was replaced with "Index of chosen module", but this resulted in translations that put the text in two lines, which is not good. I guess a note could be placed under the pagination, so it does not matter how many lines it takes.
Comment 7 Adolfo Jayme 2018-11-16 17:09:59 UTC
Created attachment 146694 [details]
Suggestion: placeholder inside input
Comment 8 Jim Avera 2018-11-17 03:26:25 UTC
> Oh, this is fixed alright and you can verify it by testing at 
> https://helponline.libreoffice.org/6.2/

Hmm.  I re-downloaded master today, 14 Nov 2018; From Calc, opening Help initially displays WRITER headings; searching for "moving" shows hits for BASIC, GLOBAL, WRITER, CALC, and IMPRESS in that order.   

Should I be seeing only GLOBAL and CALC?

I downloaded from

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF//current/master~2018-11-14_19.34.46_LibreOfficeDev_6.2.0.0.alpha1_Linux_x86-64_deb.tar.gz

and

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF//current/master~2018-11-14_19.34.46_LibreOfficeDev_6.2.0.0.alpha1_Linux_x86-64_deb_helppack_en-US.tar.gz
Comment 9 Buovjaga 2018-11-17 08:00:08 UTC
(In reply to Jim Avera from comment #8)
> > Oh, this is fixed alright and you can verify it by testing at 
> > https://helponline.libreoffice.org/6.2/
> 
> Hmm.  I re-downloaded master today, 14 Nov 2018; From Calc, opening Help
> initially displays WRITER headings; searching for "moving" shows hits for
> BASIC, GLOBAL, WRITER, CALC, and IMPRESS in that order.   
> 
> Should I be seeing only GLOBAL and CALC?

Please tell us the exact page you were on. As you see from the online version, it works: https://helponline.libreoffice.org/6.2/en-US/text/scalc/main0000.html?DbPAR=CALC

(In reply to Adolfo Jayme from comment #7)
> Created attachment 146694 [details]
> Suggestion: placeholder inside input

I thought about this so much my head hurts. I came up with the version in the screenshot by myself, but scrapped it due to it being grammatically awkward. It should be like "Search in chosen module" and then we go into the territory, where the string in some languages will always be longer than the search box. For example French: "Rechercher dans le module choisi"
Comment 10 Jim Avera 2018-11-17 16:42:16 UTC
 Buovjaga: The URL you gave does work (it immediately shows CALC info), but that is not how the actual Calc application behaves.  

If I run Calc and do Help->LibreOfficeDevHelp, a browser windows opens displaying WRITER info in the left panel.

Maybe your fixes just haven't yet made it into the builds.   I re-downloaded this morning and it still behaves the old way.


Version: 6.2.0.0.alpha1+
Build ID: 32865e69c9774d5545a3100158798b6763ff62f0
CPU threads: 12; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-16_22:22:59
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Jim Avera 2018-11-17 16:43:40 UTC
The exact page which was opened by Calc: Help->LibreOfficeDevHelp was

file://.../6.2.0.0.alpha1/opt/libreofficedev6.2/help/en-US/text/shared/main0108.html?System=UNIX&DbPAR=CALC&HID=.uno:HelpIndex#bm_id3149178
Comment 12 Buovjaga 2018-11-17 17:06:21 UTC
(In reply to Jim Avera from comment #11)
> The exact page which was opened by Calc: Help->LibreOfficeDevHelp was
> 
> file://.../6.2.0.0.alpha1/opt/libreofficedev6.2/help/en-US/text/shared/
> main0108.html?System=UNIX&DbPAR=CALC&HID=.uno:HelpIndex#bm_id3149178

That page is the help about Help: https://helponline.libreoffice.org/6.2/en-US/text/shared/main0108.html?System=UNIX&DbPAR=CALC

The url has text/shared so that means it is a common topic.

Working as intended.
Comment 13 Jim Avera 2018-11-17 21:56:07 UTC
But is that really intended?   If a user is running the Calc application and asks for Help, why is it helpful to show that generic info (or worse, only WRITER info)?

IMO Help in Calc should automatically show help for Calc (and similarly for other apps).
Comment 14 Buovjaga 2018-11-18 09:20:56 UTC
(In reply to Jim Avera from comment #13)
> But is that really intended?   If a user is running the Calc application and
> asks for Help, why is it helpful to show that generic info (or worse, only
> WRITER info)?
> 
> IMO Help in Calc should automatically show help for Calc (and similarly for
> other apps).

I meant it was the intended result for the index filter behaviour. What you are talking about is bug 87352
Comment 15 Adolfo Jayme 2018-11-20 00:11:38 UTC
(In reply to Buovjaga from comment #9)
> (In reply to Adolfo Jayme from comment #7)
> > Created attachment 146694 [details]
> > Suggestion: placeholder inside input
> 
> I thought about this so much my head hurts. I came up with the version in
> the screenshot by myself, but scrapped it due to it being grammatically
> awkward. It should be like "Search in chosen module" and then we go into the
> territory, where the string in some languages will always be longer than the
> search box. For example French: "Rechercher dans le module choisi"

Please go ahead with that string; the issue is fixable with CSS (namely, reducing the font size and making the search box span the whole column — right now it’s got a ridiculous max-width property that I shall be removing.)
Comment 16 Commit Notification 2018-11-20 22:03:23 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/126ef50e9756e79bf5b500edeaa9275260a1b7d3%5E%21

tdf#119415 Add placeholder text for index filter
Comment 17 Commit Notification 2018-11-20 22:09:19 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/help/+/10c207f682a65bb3ff434689822024e828308341%5E%21

tdf#119415 Add placeholder text for index filter
Comment 18 Commit Notification 2018-11-22 17:54:22 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/ad162dec44f8dc15cfa7405cba597b76cba8b3bd%5E%21

tdf#119415 Widen search box and style placeholder
Comment 19 Commit Notification 2018-11-22 17:57:19 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/help/+/6e0523b7cdce9919412bf5209c64d1df5061651e%5E%21

tdf#119415 Widen search box and style placeholder