Download it now!
Bug 119625 - Firebird: Migration: "value exceeds range for a valid time"
Summary: Firebird: Migration: "value exceeds range for a valid time"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on: 119669
Blocks: Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2018-08-31 18:14 UTC by Terrence Enger
Modified: 2018-11-22 21:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2018-08-31 18:14:01 UTC
This bug report arises from my poking into bug 117732.

These observations are collected from daily Linux dbgutil bibisect
repository version 2018-07-01 running on debian-buster.  From
2018-07-06 on, the conversion fails silently and the .odb retains the
HSQL database.


STR
---
Once only:

(1) Preparation:
    (1.1) Download date_time_test.zip
          <https://bugs.documentfoundation.org/attachment.cgi?id=142236>
          attached to tdf#117732 "Firebird: Migration: Time values are
          being changed during migration process (data type TIME and
          DATETIME)"
    (1.2) extract moreTime_hsql.odb
    (1.3) rename moreTime_hsql.odb to moreTime_hsql.odb_received

Per test:

(2) Copy moreTime_hsql.odb_received to moreTime_sql.odb

(3) Open moreTime_hsql.odb.  Program presents database window.

(4) In Database pane, click <Tables>.  Program presents dialog Confirm
    Migration.

(5) In Confirm Migration prompt, click <Yes>.

    Expected:  Database window.  Table tst_data has 7 rows.

    Observed:  Message
                   firebird_sdbc error:
                   *value exceeds the range for a valid time
                   caused by
                   'isc_dsql_execute'

(6) Click <OK>.  Program presents database window.

    Expected:  Table tst_data contains 7 rows.

    Observed:  Table tst_data has only 1 row.
Comment 1 Alex Thurgood 2018-09-03 08:09:10 UTC
Testing with 

Version: 6.2.0.0.alpha0+
Build ID: b8658c0e847afe1ed199c5fa7a2dd5d1d61ccbac
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded

I see no error message, but then again, no migration is performed, irrespective of the number of times I press on the "Yes" button (Experimental options activated).
Comment 2 Terrence Enger 2018-09-03 14:57:11 UTC
Sorry, Alex.  I was slow updating bugzilla.

This message is not visible now.  Bug 119669 reports a message to the
terminal instead (and no migration performed).

I am leaving this report open in the expectation that this problem
will reappear when migration proceeds.
Comment 3 Drew Jensen 2018-09-03 19:20:31 UTC
(In reply to Terrence Enger from comment #2)
> Sorry, Alex.  I was slow updating bugzilla.
> 
> This message is not visible now.  Bug 119669 reports a message to the
> terminal instead (and no migration performed).
> 
> I am leaving this report open in the expectation that this problem
> will reappear when migration proceeds.

Which is today - today's build picked up the patch that gets it running again.

Using Ubuntu 18.04 and 
Version: 6.2.0.0.alpha0+
Build ID: dff829e863fd05bedd5bcb713cd80c10fa582932
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-03_05:45:17


The error displayed is:
firebird_sdbc error:
*value exceeds the range for a valid time
caused by
'isc_dsql_execute'

Yes only one record is migrated, the other six are dropped.
Comment 4 Terrence Enger 2018-09-05 17:47:40 UTC
I have a patch waiting of gerrit:
<https://gerrit.libreoffice.org/#/c/60048/>
Comment 5 Commit Notification 2018-10-22 14:19:38 UTC
Terrence Enger committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d7dd4e1e4e072db8bcfe4d52b8c185187353e74

    tdf#119625: coerce migrated Time between 0 and 24 hours

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2018-11-22 16:21:18 UTC
A polite ping to Terrence Enger:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 7 Terrence Enger 2018-11-22 21:04:59 UTC
Thank you, Xisco, for the reminder.  I am setting status RESOLVED
FIXED.

As I am the reporter of the bug, it would normally fall to me to set
status VERIFIED FIXED.  However, I suggest that someone else should do
that with this bug.  Julian, would you volunteer for this?
Comment 8 Julien Nabet 2018-11-22 21:09:40 UTC
(In reply to Terrence Enger from comment #7)
>...
> As I am the reporter of the bug, it would normally fall to me to set
> status VERIFIED FIXED.  However, I suggest that someone else should do
> that with this bug.  Julian, would you volunteer for this?

I can't verify it since I remember that for some tests I did about a fix, it worked, for others it didn't work.
Comment 9 Terrence Enger 2018-11-22 21:41:37 UTC
@Julian,

Can you recall or recreate the failing tests?  I am worried that that
bug may not be fixed after all.