Bug 119669 - Firebird: Migration: unhandled exception
Summary: Firebird: Migration: unhandled exception
Status: RESOLVED DUPLICATE of bug 118750
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird-Migration 119625
  Show dependency treegraph
 
Reported: 2018-09-03 14:43 UTC by Terrence Enger
Modified: 2018-09-04 01:24 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace from throw (9.37 KB, text/plain)
2018-09-03 14:43 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2018-09-03 14:43:35 UTC
Created attachment 144632 [details]
backtrace from throw

This report arises from poking into bug 119625, which I am deeming
this bug to block.

On debian-buster, with a local build of commit 1d0727a1 (2018-08-27),
using file moreTime_hsql.odb contained in date_time_test.zip
<https://bugs.documentfoundation.org/attachment.cgi?id=142236>
attached to but 117732, my attempt to run conversion from embedded
HSQL to Firebird fails with messages in the terminal:

    warn:dbaccess:974:974:dbaccess/source/ui/misc/datasourceconnector.cxx:148: DBG_UNHANDLED_EXCEPTION in com::sun::star::uno::Reference<com::sun::star::sdbc::XConnection> dbaui::ODatasourceConnector::connect(const com::sun::star::uno::Reference<com::sun::star::sdbc::XDataSource>&, dbtools::SQLExceptionInfo*) const
        type: com.sun.star.container.NoSuchElementException
        message: /home/vmiklos/git/libreoffice/master/package/source/xstor/xstorage.cxx:2736:
Comment 1 Terrence Enger 2018-09-04 01:24:04 UTC
From similarity of symptoms and from the fact that the conversion now
runs (albeit still subject to bug 119625), I am closing this bug as a
duplicate of bug 118750.

*** This bug has been marked as a duplicate of bug 118750 ***